Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1281224

Re: [PATCH] Input: atmel_mxt_ts - add generic platform data for Chromebooks

From Javier Martinez Canillas <javier@osg.samsung.com>
Newsgroups linux.kernel
Subject Re: [PATCH] Input: atmel_mxt_ts - add generic platform data for Chromebooks
Date 2015-12-01 22:30 +0100
Message-ID <qB0EN-6zP-11@gated-at.bofh.it> (permalink)
References <qyqYN-3tS-1@gated-at.bofh.it> <qyri9-3QA-5@gated-at.bofh.it> <qB0EN-6zP-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Hello Dmitry,

On 12/01/2015 06:21 PM, Dmitry Torokhov wrote:

[snip]

>>>  
>>> +static unsigned int chromebook_tp_buttons[] = {
>>
>> Maybe naming it chromebook_t19_buttons instead to make it clear that the
>> mapping is specific to the T19 object or at least document that assumption?
> 
> The idea was to document that the mapping is applied to the touchpad
> and not any other Atmel device that might have T19 object in it, similar
> to samus_touchpad_buttons[] array.
>

You are right, the naming makes sense then indeed.

Thanks a lot for the explanation.
 
>>
>> Although is mentioned in the commit message so I don't have a strong
>> preference and the patch looks good to me:
>>
>> Reviewed-by: Javier Martinez Canillas <javier@osg.samsung.com>
> 
> Thank you for the review.
> 

Best regards,
-- 
Javier Martinez Canillas
Open Source Group
Samsung Research America
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH] Input: atmel_mxt_ts - add generic platform data for  Chromebooks Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-12-01 22:30 +0100
  Re: [PATCH] Input: atmel_mxt_ts - add generic platform data for  Chromebooks Javier Martinez Canillas <javier@osg.samsung.com> - 2015-12-01 22:30 +0100

csiph-web