Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1281087

Re: [kbuild-all] [PATCH] locking_selftest: Save/restore migrate_disable_atomic in locking selftest

From Sebastian Andrzej Siewior <bigeasy@linutronix.de>
Newsgroups linux.kernel
Subject Re: [kbuild-all] [PATCH] locking_selftest: Save/restore migrate_disable_atomic in locking selftest
Date 2015-12-01 19:00 +0100
Message-ID <qAXnA-4kq-1@gated-at.bofh.it> (permalink)
References (1 earlier) <qxTTc-7a2-3@gated-at.bofh.it> <qxZFg-2qN-1@gated-at.bofh.it> <qy08i-2R4-9@gated-at.bofh.it> <qy0rF-30z-43@gated-at.bofh.it> <qy0UG-3v4-11@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 11/23/2015 04:03 PM, Fengguang Wu wrote:
> Thanks! Yes, a stable branch name would be better than "linux-4.1.y-rt"
> that's like to become stable over time.

finally. I got to it.
I pushed two branches @ pub/scm/linux/kernel/git/rt/linux-rt-devel.git:

	for-kbuild-bot/current-stable [0]
	for-kbuild-bot/prepare-release [1]

Branch [0] should contain the last -RT release. This could be used for
testing patches against (if you find one with the RT marker in subject).
The tree should start a stable-tree marker (currently it is v4.1.13)
and have -RT tree applied on top. You should be able compile after each
commit (between the stable tag and HEAD) and nothing should introduce
warnings or fail to compile.
The second branch [1] would be similar to the first one except that I
plan to push stuff there before I make a release it. Does this make
sense or do I over think this?
If you do compile tests, it would be nice if you could enable
CONFIG_PREEMPT_RT_FULL. That is where most of the changes start to work.
Nevertheless it should also work without it(i.e. no preemption or
desktop).
If you have slightly different naming scheme or suggestions just tell
me I will adapt to it:)

Thank you for the service.

> Thanks,
> Fengguang

Sebastian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [kbuild-all] [PATCH] locking_selftest: Save/restore  migrate_disable_atomic in locking selftest Sebastian Andrzej Siewior <bigeasy@linutronix.de> - 2015-12-01 19:00 +0100
  Re: [kbuild-all] [PATCH] locking_selftest: Save/restore  migrate_disable_atomic in locking selftest Fengguang Wu <lkp@intel.com> - 2015-12-03 03:00 +0100

csiph-web