Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1280831

Re: [PATCH v2 2/4] driver core: handle -EPROBE_DEFER from bus_type.match()

From Ulf Hansson <ulf.hansson@linaro.org>
Newsgroups linux.kernel
Subject Re: [PATCH v2 2/4] driver core: handle -EPROBE_DEFER from bus_type.match()
Date 2015-12-01 14:00 +0100
Message-ID <qASHf-1kx-7@gated-at.bofh.it> (permalink)
References <qz4jw-5fF-7@gated-at.bofh.it> <qz4jw-5fF-11@gated-at.bofh.it> <qAwQr-4ef-25@gated-at.bofh.it> <qAPq2-7Ls-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[...]

>>> @@ -500,8 +501,17 @@ static int __device_attach_driver(struct
>>> device_driver *drv, void *_data)
>>>          if (dev->driver)
>>>                  return -EBUSY;
>>>
>>> -       if (!driver_match_device(drv, dev))
>>> +       ret = driver_match_device(drv, dev);
>>> +       if (!ret)
>>>                  return 0;
>>> +       else if (ret < 0) {
>>
>> Depending on what happens with the added dev_warn() below, perhaps a
>> switch statement can make it a bit clearer, instead of these messy if
>> clauses?
>
>
> Frankly, I have no idea how to convert this to switch statement and make

You are right!

I was thinking that "1" was the only supported positive value,
according to the documentation.

> the code easier to read. Please note that we have the following 4 cases:
>
> ret > 0: positive match
> ret == 0: negative match
> ret == -EPROBE_DEFER: deferred probe
> ret < 0: other, unknown error
>
> Another way to encode this logic is the following code:
>
> if (ret == 0) {
>         /* no match */
>         return 0;
> } else if (ret == -EPROBE_DEFER) {
>         dev_dbg(dev, "Device match requests probe deferral\n");
>         driver_deferred_probe_add(dev);
>         return ret;
> } else if (ret < 0) {
>         dev_dbg(dev, "Bus failed to match device: %d", ret);
>         return ret;
> } /* ret > 0 means positive match */

Okay! To me this looks better!

[...]

Kind regards
Uffe
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH v2 2/4] driver core: handle -EPROBE_DEFER from  bus_type.match() Marek Szyprowski <m.szyprowski@samsung.com> - 2015-12-01 10:30 +0100
  Re: [PATCH v2 2/4] driver core: handle -EPROBE_DEFER from bus_type.match() Ulf Hansson <ulf.hansson@linaro.org> - 2015-12-01 14:00 +0100

csiph-web