Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1224739

Re: [PATCH V2 1/2] mm: Replace nr_node_ids for loop with for_each_node in list lru

From Vladimir Davydov <vdavydov@parallels.com>
Newsgroups linux.kernel
Subject Re: [PATCH V2 1/2] mm: Replace nr_node_ids for loop with for_each_node in list lru
Date 2015-09-15 10:00 +0200
Message-ID <q8TjI-6Xi-29@gated-at.bofh.it> (permalink)
References <q8NQZ-7HD-3@gated-at.bofh.it> <q8NQZ-7HD-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Sep 15, 2015 at 07:38:36AM +0530, Raghavendra K T wrote:
> The functions used in the patch are in slowpath, which gets called
> whenever alloc_super is called during mounts.
> 
> Though this should not make difference for the architectures with
> sequential numa node ids, for the powerpc which can potentially have
> sparse node ids (for e.g., 4 node system having numa ids, 0,1,16,17
> is common), this patch saves some unnecessary allocations for
> non existing numa nodes.
> 
> Even without that saving, perhaps patch makes code more readable.
> 
> [ Take memcg_aware check outside for_each loop: Vldimir]
> Signed-off-by: Raghavendra K T <raghavendra.kt@linux.vnet.ibm.com>

Reviewed-by: Vladimir Davydov <vdavydov@parallels.com>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

[PATCH V2  1/2] mm: Replace nr_node_ids for loop with for_each_node in list lru Raghavendra K T <raghavendra.kt@linux.vnet.ibm.com> - 2015-09-15 04:10 +0200
  Re: [PATCH V2  1/2] mm: Replace nr_node_ids for loop with for_each_node  in list lru Raghavendra K T <raghavendra.kt@linux.vnet.ibm.com> - 2015-09-15 04:20 +0200
  Re: [PATCH V2  1/2] mm: Replace nr_node_ids for loop with  for_each_node in list lru Vladimir Davydov <vdavydov@parallels.com> - 2015-09-15 10:00 +0200

csiph-web