Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1223554
| From | Dmitry Torokhov <dmitry.torokhov@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] Input: ad714x: Convert to using managed resources |
| Date | 2015-09-13 09:10 +0200 |
| Message-ID | <q89Ad-va-7@gated-at.bofh.it> (permalink) |
| References | <q7Urv-3Ep-1@gated-at.bofh.it> <q7XIJ-5k-11@gated-at.bofh.it> <q87I5-6io-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat, Sep 12, 2015 at 10:08 PM, Vaishali Thakkar <vthakkar1994@gmail.com> wrote: > On Sat, Sep 12, 2015 at 11:52 PM, Dmitry Torokhov > <dmitry.torokhov@gmail.com> wrote: >> On Sat, Sep 12, 2015 at 08:26:18PM +0530, Vaishali Thakkar wrote: >>> Use managed resource functions devm_request_threaded_irq, >>> devm_inpute_allocate_device and devm_kzalloc to simplify >>> error handling. Also, remove use of input_unregister_device >>> as input_register_device itself handles it and works as >>> resource managed function. >>> >>> To be compatible with the change, various gotos are replaced >>> with direct returns, and unneeded labels are dropped. With >>> these changes remove ad714x_remove and corresponding calls of >>> it as they are now redundant. >>> >>> Signed-off-by: Vaishali Thakkar <vthakkar1994@gmail.com> >>> --- >>> Please note that this patch is having three lines over 80 >>> characters as limiting them to 80 characters makes code >>> less readable. >> >> You can actually remove input[input_alloc] and that will allow you to >> stay witing 80 columnts. Does the following version still work for you? > > Sure. This makes perfect sense. Thanks. > > Can I send v2 of a patch with all changes you suggested or would you > like me to split this patch in 2 patches? If the version I sent works for you there is no need to resend/splt. Thanks. -- Dmitry -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] Input: ad714x: Convert to using managed resources Vaishali Thakkar <vthakkar1994@gmail.com> - 2015-09-12 17:00 +0200
Re: [PATCH] Input: ad714x: Convert to using managed resources Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-09-12 20:30 +0200
Re: [PATCH] Input: ad714x: Convert to using managed resources Vaishali Thakkar <vthakkar1994@gmail.com> - 2015-09-13 07:10 +0200
Re: [PATCH] Input: ad714x: Convert to using managed resources Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2015-09-13 09:10 +0200
Re: [PATCH] Input: ad714x: Convert to using managed resources Vaishali Thakkar <vthakkar1994@gmail.com> - 2015-09-13 13:30 +0200
csiph-web