Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1219152

Re: [RESEND RFC v4 2/3] mm: make optimistic check for swapin readahead

From Vlastimil Babka <vbabka@suse.cz>
Newsgroups linux.kernel
Subject Re: [RESEND RFC v4 2/3] mm: make optimistic check for swapin readahead
Date 2015-09-04 18:20 +0200
Message-ID <q51Sx-7bq-7@gated-at.bofh.it> (permalink)
References <q4JLY-6kV-5@gated-at.bofh.it> <q4JM0-6kV-41@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 09/03/2015 10:51 PM, Ebru Akagunduz wrote:
> This patch introduces new sysfs integer knob
> /sys/kernel/mm/transparent_hugepage/khugepaged/max_ptes_swap
> which makes optimistic check for swapin readahead to
> increase thp collapse rate. Before getting swapped
> out pages to memory, checks them and allows up to a
> certain number. It also prints out using tracepoints
> amount of unmapped ptes.
> 
> Signed-off-by: Ebru Akagunduz <ebru.akagunduz@gmail.com>

...

>  #include <asm/pgalloc.h>
> @@ -49,7 +50,8 @@ static const char *const khugepaged_status_string[] = {
>  	"page_swap_cache",
>  	"could_not_delete_page_from_lru",
>  	"alloc_huge_page_fail",
> -	"ccgroup_charge_fail"
> +	"ccgroup_charge_fail",
> +	"exceed_swap_pte"
>  };
>  
>  enum scan_result {
> @@ -73,7 +75,8 @@ enum scan_result {
>  	SCAN_SWAP_CACHE_PAGE,
>  	SCAN_DEL_PAGE_LRU,
>  	SCAN_ALLOC_HUGE_PAGE_FAIL,
> -	SCAN_CGROUP_CHARGE_FAIL
> +	SCAN_CGROUP_CHARGE_FAIL,
> +	MM_EXCEED_SWAP_PTE

This one should be renamed too.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[RESEND RFC v4 2/3] mm: make optimistic check for swapin readahead Ebru Akagunduz <ebru.akagunduz@gmail.com> - 2015-09-03 23:00 +0200
  Re: [RESEND RFC v4 2/3] mm: make optimistic check for swapin  readahead Vlastimil Babka <vbabka@suse.cz> - 2015-09-04 18:20 +0200

csiph-web