Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1218047
| From | Yakir Yang <ykk@rock-chips.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 01/16] drm: exynos/dp: fix code style |
| Date | 2015-09-03 07:40 +0200 |
| Message-ID | <q4vpF-2GW-9@gated-at.bofh.it> (permalink) |
| References | <q3MCf-5Sy-11@gated-at.bofh.it> <q3MCf-5Sy-21@gated-at.bofh.it> <q4qzE-4aY-7@gated-at.bofh.it> <q4uWB-28R-3@gated-at.bofh.it> <q4uWB-28R-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Krzysztof,
在 09/03/2015 01:08 PM, Krzysztof Kozlowski 写道:
> On 03.09.2015 14:04, Yakir Yang wrote:
>> Hi Krzysztof,
>>
>> 在 09/03/2015 08:21 AM, Krzysztof Kozlowski 写道:
>>> On 01.09.2015 14:46, Yakir Yang wrote:
>>>> After run "checkpatch.pl -f --subjective" command, I see there
>>>> are lots of alignment problem in exynos_dp driver, so let just
>>>> fix them.
>>> Hi,
>>>
>>> Warnings from checkpatch are not a reason for a commit. Reason for a
>>> commit could be for example an unreadable code, violation of
>>> coding-style leading to decrease in code maintainability or just
>>> improving the code readability so it will be easier to review and
>>> maintain it.
>>>
>>> You do not make commits because some tool tells you that. We do not
>>> listen to machines :) ... If that would be the case, the commit could be
>>> made automatically, without human interaction. Such automated commit
>>> could be even easily tested by the machine by comparing object files.
>>>
>>> Especially that you enabled "subjective" rule. This is not a valid
>>> motivation for a commit.
>>>
>>> Please rephrase this to sensible reason and convince that change is
>>> worth the effort.
>> Oh, nice, thanks for your remind. I would rephrase the commit.
>>
>>>> - Take Romain suggest, rebase on linux-next branch
>>> That comment seems unrelated to the commit. Please remove it.
>> Done,
>>
>>>> Signed-off-by: Yakir Yang <ykk@rock-chips.com>
>>>> ---
>>>> Changes in v4: None
>>>> Changes in v3: None
>>>> Changes in v2:
>>>> - Take Joe Preches advise, improved commit message more readable, and
>>>> avoid using some uncommon style like bellow:
>>>> - retval = exynos_dp_read_bytes_from_i2c(...
>>>> ...)
>>>> + retval =
>>>> + exynos_dp_read_bytes_from_i2c(......);
>>>>
>>>> drivers/gpu/drm/exynos/exynos_dp_core.c | 226
>>>> ++++++++++++++++----------------
>>>> drivers/gpu/drm/exynos/exynos_dp_core.h | 54 ++++----
>>>> drivers/gpu/drm/exynos/exynos_dp_reg.c | 106 +++++++--------
>>>> 3 files changed, 188 insertions(+), 198 deletions(-)
>>>>
>>>> diff --git a/drivers/gpu/drm/exynos/exynos_dp_core.c
>>>> b/drivers/gpu/drm/exynos/exynos_dp_core.c
>>>> index d66ade0..266f7f7 100644
>>>> --- a/drivers/gpu/drm/exynos/exynos_dp_core.c
>>>> +++ b/drivers/gpu/drm/exynos/exynos_dp_core.c
>>>> @@ -115,8 +115,8 @@ static int exynos_dp_read_edid(struct
>>>> exynos_dp_device *dp)
>>>> /* Read Extension Flag, Number of 128-byte EDID extension
>>>> blocks */
>>>> retval = exynos_dp_read_byte_from_i2c(dp, I2C_EDID_DEVICE_ADDR,
>>>> - EDID_EXTENSION_FLAG,
>>>> - &extend_block);
>>>> + EDID_EXTENSION_FLAG,
>>>> + &extend_block);
>>>> if (retval)
>>>> return retval;
>>>> @@ -124,10 +124,11 @@ static int exynos_dp_read_edid(struct
>>>> exynos_dp_device *dp)
>>>> dev_dbg(dp->dev, "EDID data includes a single extension!\n");
>>>> /* Read EDID data */
>>>> - retval = exynos_dp_read_bytes_from_i2c(dp,
>>>> I2C_EDID_DEVICE_ADDR,
>>>> - EDID_HEADER_PATTERN,
>>>> - EDID_BLOCK_LENGTH,
>>>> - &edid[EDID_HEADER_PATTERN]);
>>>> + retval = exynos_dp_read_bytes_from_i2c(
>>>> + dp, I2C_EDID_DEVICE_ADDR,
>>>> + EDID_HEADER_PATTERN,
>>>> + EDID_BLOCK_LENGTH,
>>>> + &edid[EDID_HEADER_PATTERN]);
>>>> if (retval != 0) {
>>>> dev_err(dp->dev, "EDID Read failed!\n");
>>>> return -EIO;
>>>> @@ -139,11 +140,11 @@ static int exynos_dp_read_edid(struct
>>>> exynos_dp_device *dp)
>>>> }
>>>> /* Read additional EDID data */
>>>> - retval = exynos_dp_read_bytes_from_i2c(dp,
>>>> - I2C_EDID_DEVICE_ADDR,
>>>> - EDID_BLOCK_LENGTH,
>>>> - EDID_BLOCK_LENGTH,
>>>> - &edid[EDID_BLOCK_LENGTH]);
>>>> + retval = exynos_dp_read_bytes_from_i2c(
>>>> + dp, I2C_EDID_DEVICE_ADDR,
>>>> + EDID_BLOCK_LENGTH,
>>>> + EDID_BLOCK_LENGTH,
>>>> + &edid[EDID_BLOCK_LENGTH]);
>>>> if (retval != 0) {
>>>> dev_err(dp->dev, "EDID Read failed!\n");
>>>> return -EIO;
>>>> @@ -155,24 +156,22 @@ static int exynos_dp_read_edid(struct
>>>> exynos_dp_device *dp)
>>>> }
>>>> exynos_dp_read_byte_from_dpcd(dp, DP_TEST_REQUEST,
>>>> - &test_vector);
>>>> + &test_vector);
>>>> if (test_vector & DP_TEST_LINK_EDID_READ) {
>>>> - exynos_dp_write_byte_to_dpcd(dp,
>>>> - DP_TEST_EDID_CHECKSUM,
>>>> + exynos_dp_write_byte_to_dpcd(
>>>> + dp, DP_TEST_EDID_CHECKSUM,
>>>> edid[EDID_BLOCK_LENGTH + EDID_CHECKSUM]);
>>>> - exynos_dp_write_byte_to_dpcd(dp,
>>>> - DP_TEST_RESPONSE,
>>>> + exynos_dp_write_byte_to_dpcd(
>>>> + dp, DP_TEST_RESPONSE,
>>>> DP_TEST_EDID_CHECKSUM_WRITE);
>>> To me, missing argument after opening parenthesis, looks worse. I would
>>> prefer:
>>>
>>> exynos_dp_write_byte_to_dpcd(dp,
>>>
>>> Why you moved the 'dp' argument to new line?
>> Hmm... Just like style tool indicate, no more warning after
>> that change.
>>
>> For now, I would like to follow the original style, just improved
>> some obvious style problem. :-)
> What was the checkpatch warning that said 'dp' has to move to new line?
> I tried this and I don't see it.
checkpatch haven't remind me that put dp to new line would fix
this warning, this just come from my experiments. And I works,
no more warnings from checkpatch, so I toke this style.
- Yakir
> Best regards,
> Krzysztof
>
>
>
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v4 0/16] Add Analogix Core Display Port Driver Yakir Yang <ykk@rock-chips.com> - 2015-09-01 07:50 +0200
[PATCH v4 01/16] drm: exynos/dp: fix code style Yakir Yang <ykk@rock-chips.com> - 2015-09-01 07:50 +0200
Re: [PATCH v4 01/16] drm: exynos/dp: fix code style Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-03 02:30 +0200
Re: [PATCH v4 01/16] drm: exynos/dp: fix code style Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-03 07:10 +0200
Re: [PATCH v4 01/16] drm: exynos/dp: fix code style Yakir Yang <ykk@rock-chips.com> - 2015-09-03 07:40 +0200
Re: [PATCH v4 01/16] drm: exynos/dp: fix code style Joe Perches <joe@perches.com> - 2015-09-03 08:00 +0200
Re: [PATCH v4 01/16] drm: exynos/dp: fix code style Yakir Yang <ykk@rock-chips.com> - 2015-09-06 03:40 +0200
Re: [PATCH v4 01/16] drm: exynos/dp: fix code style Yakir Yang <ykk@rock-chips.com> - 2015-09-03 07:10 +0200
[PATCH v4 04/16] drm: bridge: analogix/dp: remove duplicate configuration of link rate and link count Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:00 +0200
[PATCH v4 05/16] drm: bridge: analogix/dp: dynamic parse sync_pol & interlace & colorimetry Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:00 +0200
Re: [PATCH v4 05/16] drm: bridge: analogix/dp: dynamic parse sync_pol & interlace & colorimetry Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-03 10:10 +0200
Re: [PATCH v4 05/16] drm: bridge: analogix/dp: dynamic parse sync_pol & interlace & colorimetry Yakir Yang <ykk@rock-chips.com> - 2015-09-06 04:10 +0200
[PATCH v4 11/16] drm: bridge: analogix/dp: add platform device type support Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:10 +0200
Re: [PATCH v4 11/16] drm: bridge: analogix/dp: add platform device type support Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-04 02:40 +0200
Re: [PATCH v4 11/16] drm: bridge: analogix/dp: add platform device type support Yakir Yang <ykk@rock-chips.com> - 2015-09-06 06:10 +0200
Re: [PATCH v4 11/16] drm: bridge: analogix/dp: add platform device type support Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-07 02:00 +0200
Re: [PATCH v4 11/16] drm: bridge: analogix/dp: add platform device type support Yakir Yang <ykk@rock-chips.com> - 2015-09-07 03:50 +0200
[PATCH v4 08/16] drm: rockchip/dp: add rockchip platform dp driver Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:10 +0200
Re: [PATCH v4 08/16] drm: rockchip/dp: add rockchip platform dp driver Heiko Stuebner <heiko@sntech.de> - 2015-09-01 16:30 +0200
Re: [PATCH v4 08/16] drm: rockchip/dp: add rockchip platform dp driver Yakir Yang <ykk@rock-chips.com> - 2015-09-01 16:50 +0200
Re: [PATCH v4 08/16] drm: rockchip/dp: add rockchip platform dp driver Heiko Stuebner <heiko@sntech.de> - 2015-09-01 23:10 +0200
Re: [PATCH v4 08/16] drm: rockchip/dp: add rockchip platform dp driver Yakir Yang <ykk@rock-chips.com> - 2015-09-02 04:00 +0200
[PATCH v4 06/16] Documentation: drm/bridge: add document for analogix_dp Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:10 +0200
[PATCH v4 09/16] drm: rockchip: add bpc and color mode setting Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:10 +0200
Re: [PATCH v4 09/16] drm: rockchip: add bpc and color mode setting Heiko Stuebner <heiko@sntech.de> - 2015-09-01 23:10 +0200
Re: [PATCH v4 09/16] drm: rockchip: add bpc and color mode setting Yakir Yang <ykk@rock-chips.com> - 2015-09-02 04:10 +0200
Re: [PATCH v4 09/16] drm: rockchip: add bpc and color mode setting Thierry Reding <treding@nvidia.com> - 2015-09-02 10:40 +0200
Re: [PATCH v4 09/16] drm: rockchip: add bpc and color mode setting Yakir Yang <ykk@rock-chips.com> - 2015-09-02 12:10 +0200
Re: [PATCH v4 09/16] drm: rockchip: add bpc and color mode setting Thierry Reding <treding@nvidia.com> - 2015-09-03 10:40 +0200
Re: [PATCH v4 09/16] drm: rockchip: add bpc and color mode setting Yakir Yang <ykk@rock-chips.com> - 2015-09-06 04:10 +0200
[PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:10 +0200
Re: [PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Heiko Stuebner <heiko@sntech.de> - 2015-09-01 19:00 +0200
Re: [PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Heiko Stuebner <heiko@sntech.de> - 2015-09-01 23:00 +0200
Re: [PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Yakir Yang <ykk@rock-chips.com> - 2015-09-02 03:50 +0200
Re: [PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Yakir Yang <ykk@rock-chips.com> - 2015-09-02 03:10 +0200
Re: [PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Rob Herring <robherring2@gmail.com> - 2015-09-02 15:30 +0200
Re: [PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Yakir Yang <ykk@rock-chips.com> - 2015-09-03 05:30 +0200
Re: [PATCH v4 10/16] phy: Add driver for rockchip Display Port PHY Heiko Stuebner <heiko@sntech.de> - 2015-09-03 16:00 +0200
[PATCH v4 07/16] ARM: dts: exynos/dp: remove some properties that deprecated by analogix_dp driver Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:10 +0200
Re: [PATCH v4 07/16] ARM: dts: exynos/dp: remove some properties that deprecated by analogix_dp driver Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-03 02:10 +0200
[PATCH v4 15/16] drm: bridge: analogix/dp: move hpd detect to connector detect function Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:20 +0200
[PATCH v4 12/16] drm: bridge: analogix/dp: add some rk3288 special registers setting Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:20 +0200
[PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:20 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Rob Herring <robherring2@gmail.com> - 2015-09-02 22:20 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Yakir Yang <ykk@rock-chips.com> - 2015-09-03 06:30 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Thierry Reding <treding@nvidia.com> - 2015-09-03 11:10 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Russell King - ARM Linux <linux@arm.linux.org.uk> - 2015-09-04 12:30 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Thierry Reding <treding@nvidia.com> - 2015-09-07 10:30 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Rob Herring <robherring2@gmail.com> - 2015-09-04 23:50 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Yakir Yang <ykk@rock-chips.com> - 2015-09-06 10:30 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Thierry Reding <treding@nvidia.com> - 2015-09-07 10:40 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Thierry Reding <treding@nvidia.com> - 2015-09-03 10:50 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Rob Herring <robherring2@gmail.com> - 2015-09-04 00:00 +0200
Re: [PATCH v4 14/16] drm: bridge: analogix/dp: try force hpd after plug in lookup failed Thierry Reding <treding@nvidia.com> - 2015-09-04 12:10 +0200
[PATCH v4 13/16] drm: bridge: analogix/dp: add max link rate and lane count limit for RK3288 Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:20 +0200
[PATCH v4 16/16] drm: bridge: analogix/dp: add edid modes parse in get_modes method Yakir Yang <ykk@rock-chips.com> - 2015-09-01 08:30 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Heiko Stuebner <heiko@sntech.de> - 2015-09-01 22:50 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Yakir Yang <ykk@rock-chips.com> - 2015-09-02 03:50 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Rob Herring <robherring2@gmail.com> - 2015-09-04 23:10 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Heiko Stuebner <heiko@sntech.de> - 2015-09-04 23:40 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Thierry Reding <treding@nvidia.com> - 2015-09-07 10:20 +0200
Re: [PATCH v4 0/16] Add Analogix Core Display Port Driver Heiko Stuebner <heiko@sntech.de> - 2015-09-02 00:20 +0200
Re: [PATCH v4 0/16] Add Analogix Core Display Port Driver Yakir Yang <ykk@rock-chips.com> - 2015-09-02 04:20 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Emil Velikov <emil.l.velikov@gmail.com> - 2015-09-02 17:00 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Yakir Yang <ykk@rock-chips.com> - 2015-09-03 06:00 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-03 03:00 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Yakir Yang <ykk@rock-chips.com> - 2015-09-03 07:40 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-04 02:50 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Yakir Yang <ykk@rock-chips.com> - 2015-09-06 10:00 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Krzysztof Kozlowski <k.kozlowski@samsung.com> - 2015-09-07 02:30 +0200
Re: [PATCH v4 03/16] drm: bridge: analogix/dp: split exynos dp driver to bridge dir Yakir Yang <ykk@rock-chips.com> - 2015-09-07 04:30 +0200
csiph-web