Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1215808

Re: [PATCH]: acpica/nfit: Rename not-armed bit definition

From Dan Williams <dan.j.williams@intel.com>
Newsgroups linux.kernel
Subject Re: [PATCH]: acpica/nfit: Rename not-armed bit definition
Date 2015-08-29 17:30 +0200
Message-ID <q2QeS-5LL-21@gated-at.bofh.it> (permalink)
References <q2t8B-6dU-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Aug 28, 2015 at 7:40 AM, Toshi Kani <toshi.kani@hp.com> wrote:
> ACPI 6.0 NFIT Memory Device State Flags in Table 5-129 defines
> bit 3 as follows.
>
>   Bit [3] set to 1 to indicate that the Memory Device is observed
>   to be not armed prior to OSPM hand off. A Memory Device is
>   considered armed if it is able to accept persistent writes.
>
> This bit is currently defined as ACPI_NFIT_MEM_ARMED, which can be
> confusing as if the Memory Device is armed when this bit is set.
>
> Change the name to ACPI_NFIT_MEM_NOT_ARMED per the spec.
>
> Signed-off-by: Toshi Kani <toshi.kani@hp.com>
> Cc: Bob Moore <robert.moore@intel.com>
> Cc: Dan Williams <dan.j.williams@intel.com>

Acked-by: Dan Williams <dan.j.williams@intel.com>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH]: acpica/nfit: Rename not-armed bit definition Toshi Kani <toshi.kani@hp.com> - 2015-08-28 16:50 +0200
  RE: [PATCH]: acpica/nfit: Rename not-armed bit definition "Moore, Robert" <robert.moore@intel.com> - 2015-08-28 17:50 +0200
  Re: [PATCH]: acpica/nfit: Rename not-armed bit definition Dan Williams <dan.j.williams@intel.com> - 2015-08-29 17:30 +0200

csiph-web