Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1213293
| From | Joe Stringer <joestringer@nicira.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCHv5 net-next 10/10] openvswitch: Allow attaching helpers to ct action |
| Date | 2015-08-25 22:20 +0200 |
| Message-ID | <q1sRk-ky-3@gated-at.bofh.it> (permalink) |
| References | <q1arn-7k8-3@gated-at.bofh.it> <q1aro-7k8-17@gated-at.bofh.it> <q1riy-6ju-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 25 August 2015 at 11:33, Thomas Graf <tgraf@suug.ch> wrote: > On 08/24/15 at 05:32pm, Joe Stringer wrote: >> Add support for using conntrack helpers to assist protocol detection. >> The new OVS_CT_ATTR_HELPER attribute of the CT action specifies a helper >> to be used for this connection. If no helper is specified, then helpers >> will be automatically applied as per the sysctl configuration of >> net.netfilter.nf_conntrack_helper. >> >> The helper may be specified as part of the conntrack action, eg: >> ct(helper=ftp). Initial packets for related connections should be >> committed to allow later packets for the flow to be considered >> established. >> >> Example ovs-ofctl flows allowing FTP connections from ports 1->2: >> in_port=1,tcp,action=ct(helper=ftp,commit),2 >> in_port=2,tcp,ct_state=-trk,action=ct(recirc) >> in_port=2,tcp,ct_state=+trk-new+est,action=1 >> in_port=2,tcp,ct_state=+trk+rel,action=1 > > Not subject to this patch but we may want to revisit the syntax of the > state flags. It's neatly compressed like this but ct_state=untracked > ct_state=related might be more readable. The +trk should be implicit > for anything !untracked Fair criticism. My thoughts were that this was a reasonable middleground between representing masked flags like "ct_state=0xc2/0xc3" vs. having overly verbose state descriptions like the corresponding "ct_state=tracked,!new,established,reply_direction". Either way, we need to represent the three possible states for each flag: set and we care about the value, unset and we care about the value, or we don't care about the value. Arguably the example above is a bit imprecise, because the +trk flows intersect. Omitting the "+trk" would make all of the return flows intersect. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCHv5 net-next 00/10] OVS conntrack support Joe Stringer <joestringer@nicira.com> - 2015-08-25 02:40 +0200
[PATCHv5 net-next 06/10] openvswitch: Allow matching on conntrack mark Joe Stringer <joestringer@nicira.com> - 2015-08-25 02:40 +0200
Re: [PATCHv5 net-next 06/10] openvswitch: Allow matching on conntrack mark Pravin Shelar <pshelar@nicira.com> - 2015-08-25 22:40 +0200
[PATCHv5 net-next 02/10] openvswitch: Move MASKED* macros to datapath.h Joe Stringer <joestringer@nicira.com> - 2015-08-25 02:40 +0200
[PATCHv5 net-next 10/10] openvswitch: Allow attaching helpers to ct action Joe Stringer <joestringer@nicira.com> - 2015-08-25 02:40 +0200
Re: [PATCHv5 net-next 10/10] openvswitch: Allow attaching helpers to ct action Thomas Graf <tgraf@suug.ch> - 2015-08-25 20:40 +0200
Re: [PATCHv5 net-next 10/10] openvswitch: Allow attaching helpers to ct action Joe Stringer <joestringer@nicira.com> - 2015-08-25 22:20 +0200
Re: [PATCHv5 net-next 10/10] openvswitch: Allow attaching helpers to ct action Pravin Shelar <pshelar@nicira.com> - 2015-08-25 22:50 +0200
[PATCHv5 net-next 07/10] netfilter: Always export nf_connlabels_replace() Joe Stringer <joestringer@nicira.com> - 2015-08-25 02:40 +0200
[PATCHv5 net-next 04/10] dst: Add __skb_dst_copy() variation Joe Stringer <joestringer@nicira.com> - 2015-08-25 02:40 +0200
Re: [PATCHv5 net-next 05/10] openvswitch: Add conntrack action Thomas Graf <tgraf@suug.ch> - 2015-08-25 20:30 +0200
Re: [PATCHv5 net-next 05/10] openvswitch: Add conntrack action Pravin Shelar <pshelar@nicira.com> - 2015-08-25 21:30 +0200
csiph-web