Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1213948
| Path | csiph.com!au2pb.net!feeder.erje.net!us.feeder.erje.net!news2.arglkargh.de!news.mixmin.net!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Jiri Olsa <jolsa@redhat.com> |
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 05/11] perf tools: Move tracing_path stuff under same namespace |
| Date | Wed, 26 Aug 2015 17:10:01 +0200 |
| Message-ID | <q1KuR-Rx-3@gated-at.bofh.it> (permalink) |
| References | <q1Jfs-7l6-5@gated-at.bofh.it> <q1Jft-7l6-19@gated-at.bofh.it> <q1Kbw-fe-19@gated-at.bofh.it> <q1Kbw-fe-25@gated-at.bofh.it> <q1Klb-qE-5@gated-at.bofh.it> |
| X-Original-To | Arnaldo Carvalho de Melo <acme@kernel.org> |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset=us-ascii |
| Content-Disposition | inline |
| User-Agent | Mutt/1.5.23 (2014-03-12) |
| X-Scanned-By | MIMEDefang 2.68 on 10.5.11.26 |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 47 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Jiri Olsa <jolsa@kernel.org>, lkml <linux-kernel@vger.kernel.org>, David Ahern <dsahern@gmail.com>, Ingo Molnar <mingo@kernel.org>, Namhyung Kim <namhyung@kernel.org>, Peter Zijlstra <a.p.zijlstra@chello.nl>, Matt Fleming <matt@codeblueprint.co.uk>, Raphaƫl Beamonte <raphael.beamonte@gmail.com> |
| X-Original-Date | Wed, 26 Aug 2015 17:06:37 +0200 |
| X-Original-Message-ID | <20150826150637.GF26643@krava.brq.redhat.com> |
| X-Original-References | <1440596813-12844-1-git-send-email-jolsa@kernel.org> <1440596813-12844-6-git-send-email-jolsa@kernel.org> <20150826144211.GF18596@kernel.org> <20150826144836.GD26643@krava.brq.redhat.com> <20150826145855.GA1139@kernel.org> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | csiph.com linux.kernel:1213948 |
Show key headers only | View raw
On Wed, Aug 26, 2015 at 11:58:55AM -0300, Arnaldo Carvalho de Melo wrote:
> Em Wed, Aug 26, 2015 at 04:48:36PM +0200, Jiri Olsa escreveu:
> > On Wed, Aug 26, 2015 at 11:42:11AM -0300, Arnaldo Carvalho de Melo wrote:
> > > Em Wed, Aug 26, 2015 at 03:46:47PM +0200, Jiri Olsa escreveu:
> > > > Renaming all functions touching tracing_path under same
> > > > namespace. New interface is:
> > >
> > > But we were trying to have debugfs stuff in tools/lib/api/fs/, so that
> > > it could eventually be used by some other tools, etc, and now we're
> > > going the other way around, de-librarifying, not good :-\
> >
> > well this gathers tracefs/debugfs together, the api/fs/{trace|debug}fs
> > are just building blocks
> >
> > I only moved the debugfs__strerror_open_tp out of the debugfs object
> > because it needs to be one layer up, because it needs to touch tracefs
> > as well
>
> Why not leave it there, since, for historical reasons, what is tracefs
> now was something implemented inside debugfs, so having that special
> case in debugfs__strerror_open_tp():
>
> if (!access(debugfs_mountpoint, R_OK) && strncmp(filename, "tracing/", 8) == 0) {
>
> Is ok, since tools will need to deal with older kernels, etc.
>
> But ok, I see your point, we should rename it to something like
> tracepoint__strerror_open_definition(), so as to detach this from
> "debugfs" _and_ "tracefs", pseudo-filesystem based DWARF-like stuff
> (event definitions), but then why not have that somewhere in
> tools/lib/api/tracepoint/.
no problem with moving it over to the lib
how about having api/fs/tpfs
or eventsfs
or tracingfs
doing the same as tracing_path* stuff ATM
jirka
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 05/11] perf tools: Move tracing_path stuff under same namespace Jiri Olsa <jolsa@kernel.org> - 2015-08-26 15:50 +0200
Re: [PATCH 05/11] perf tools: Move tracing_path stuff under same namespace Arnaldo Carvalho de Melo <acme@kernel.org> - 2015-08-26 16:50 +0200
Re: [PATCH 05/11] perf tools: Move tracing_path stuff under same namespace Jiri Olsa <jolsa@redhat.com> - 2015-08-26 16:50 +0200
Re: [PATCH 05/11] perf tools: Move tracing_path stuff under same namespace Arnaldo Carvalho de Melo <acme@kernel.org> - 2015-08-26 17:00 +0200
Re: [PATCH 05/11] perf tools: Move tracing_path stuff under same namespace Jiri Olsa <jolsa@redhat.com> - 2015-08-26 17:10 +0200
Re: [PATCH 05/11] perf tools: Move tracing_path stuff under same namespace Matt Fleming <matt@codeblueprint.co.uk> - 2015-08-28 15:10 +0200
Re: [PATCH 05/11] perf tools: Move tracing_path stuff under same namespace Jiri Olsa <jolsa@redhat.com> - 2015-08-31 09:50 +0200
csiph-web