Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1161125
| From | Daniel Martin <consume.noise@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] hid: Add secondary vendor id for the marco, USB_DEVICE_ID_MS_TYPE_COVER_3_V2 |
| Date | 2015-06-09 10:40 +0200 |
| Message-ID | <pzneG-19M-7@gated-at.bofh.it> (permalink) |
| References | <pslKG-5aO-15@gated-at.bofh.it> <pslKG-5aO-13@gated-at.bofh.it> <psoIx-1au-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 21 May 2015 at 04:40, Alan Wu <alan.c.wu@gmail.com> wrote: > Hello Jiri, > I believe the patch may work, but I would rename the IDs. Obviously > I can't test Surface 3 non-Pro cover, but the difference is likely due > to the following: > > This is 0x07dc (I do own) > http://www.microsoftstore.com/store/msusa/en_US/pdp/Surface-Pro-Type-Cover/productID.300193600 > > This is 0x07de (I do not own) > http://www.microsoftstore.com/store/msusa/en_US/pdp/Surface-3-Type-Cover/productID.314885800 > > I would rename 0x07dc to USB_DEVICE_ID_MS_TYPE_COVER_PRO_3 (original > submitted patch) > and 0x07de to USB_DEVICE_ID_MS_TYPE_COVER_3 (Nicholas' patch). > > I would probably also rename 0x07dd to USB_DEVICE_ID_MS_TYPE_COVER_PRO_3_JP. I've got another Type Cover 3 (0x07e2 ) here, where I was going to send a patch for. According to the small picture, it looks like a 0x07de - grey, not that glossy keys. How should I name the define? Won't it be better to append the model number to distinguish the Type Covers? I've got a 0x07dc (model 1644) and 0x07e2 (model 1709). ... USB_DEVICE_ID_MS_TYPE_COVER_3_M1644 ... USB_DEVICE_ID_MS_TYPE_COVER_3_M1709 The model number (pretty small) can be found on the connector above the CE sign on the right. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH] hid: Add secondary vendor id for the marco, USB_DEVICE_ID_MS_TYPE_COVER_3_V2 Daniel Martin <consume.noise@gmail.com> - 2015-06-09 10:40 +0200
csiph-web