Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1210477

Re: [PATCH 07/10] mm: page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM

From Michal Hocko <mhocko@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH 07/10] mm: page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM
Date 2015-08-20 14:50 +0200
Message-ID <pZxs5-57Q-3@gated-at.bofh.it> (permalink)
References <pWBLz-1Xg-7@gated-at.bofh.it> <pWBLA-1Xg-17@gated-at.bofh.it> <pZx8K-4Lv-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu 20-08-15 14:28:57, Michal Hocko wrote:
> On Wed 12-08-15 11:45:32, Mel Gorman wrote:
> > __GFP_WAIT was used to signal that the caller was in atomic context and
> > could not sleep.  Now it is possible to distinguish between true atomic
> > context and callers that are not willing to sleep. The latter should clear
> > __GFP_DIRECT_RECLAIM so kswapd will still wake. As clearing __GFP_WAIT
> > behaves differently, there is a risk that people will clear the wrong
> > flags. This patch renames __GFP_WAIT to __GFP_RECLAIM to clearly indicate
> > what it does -- setting it allows all reclaim activity, clearing them
> > prevents it.
> > 
> > Signed-off-by: Mel Gorman <mgorman@techsingularity.net>
> 
> I haven't checked all the converted places too deeply but they look
> straightforward.
> 
> Acked-by: Michal Hocko <mhocko@suse.cz>

I meant @suse.com, dang the old one is hardwired into my hands...
-- 
Michal Hocko
SUSE Labs
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 07/10] mm: page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM Mel Gorman <mgorman@techsingularity.net> - 2015-08-12 12:50 +0200
  Re: [PATCH 07/10] mm: page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM Michal Hocko <mhocko@kernel.org> - 2015-08-20 14:30 +0200
    Re: [PATCH 07/10] mm: page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM Michal Hocko <mhocko@kernel.org> - 2015-08-20 14:50 +0200
  Re: [PATCH 07/10] mm: page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM Vlastimil Babka <vbabka@suse.cz> - 2015-08-21 16:30 +0200
    Re: [PATCH 07/10] mm: page_alloc: Rename __GFP_WAIT to __GFP_RECLAIM Mel Gorman <mgorman@techsingularity.net> - 2015-08-21 23:00 +0200

csiph-web