Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1211199
| From | "Liang, Kan" <kan.liang@intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | RE: [PATCH V4 1/7] perf,tools: introduce generic FEAT for CPU attributes |
| Date | 2015-08-21 16:30 +0200 |
| Message-ID | <pZVur-6eW-25@gated-at.bofh.it> (permalink) |
| References | <pYWLU-27E-5@gated-at.bofh.it> <pYWLU-27E-3@gated-at.bofh.it> <pZQl5-77f-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
>
> On Tue, Aug 18, 2015 at 10:16:35AM -0400, Kan Liang wrote:
>
> SNIP
>
> > diff --git a/tools/perf/util/header.h b/tools/perf/util/header.h index
> > 9b53b65..233c24d 100644
> > --- a/tools/perf/util/header.h
> > +++ b/tools/perf/util/header.h
> > @@ -31,6 +31,7 @@ enum {
> > HEADER_PMU_MAPPINGS,
> > HEADER_GROUP_DESC,
> > HEADER_AUXTRACE,
> > + HEADER_CPU_ATTR,
> > HEADER_LAST_FEATURE,
> > HEADER_FEAT_BITS = 256,
> > };
> > @@ -66,6 +67,11 @@ struct perf_header; int
> > perf_file_header__read(struct perf_file_header *header,
> > struct perf_header *ph, int fd);
> >
> > +enum perf_header_cpu_attr {
> > + PERF_HEADER_CPU_MAX_FREQ = 0,
> > + PERF_HEADER_CPU_ATTR_MAX,
> > +};
> > +
> > struct perf_session_env {
> > char *hostname;
> > char *os_release;
> > @@ -75,6 +81,7 @@ struct perf_session_env {
> > int nr_cpus_avail;
> > char *cpu_desc;
> > char *cpuid;
> > + u64 cpu_attr[PERF_HEADER_CPU_ATTR_MAX];
>
> it'd more readable having struct with all fields instead of the tag accesible
> array
Do you mean replace cpu_attr[] to something like this?
@@ -89,6 +95,9 @@ struct perf_session_env {
char *sibling_threads;
char *numa_nodes;
char *pmu_mappings;
+ struct {
+ u64 freq;
+ } cpu_attr;
Thanks,
Kan
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH V4 1/7] perf,tools: introduce generic FEAT for CPU attributes Jiri Olsa <jolsa@redhat.com> - 2015-08-21 11:00 +0200 RE: [PATCH V4 1/7] perf,tools: introduce generic FEAT for CPU attributes "Liang, Kan" <kan.liang@intel.com> - 2015-08-21 16:30 +0200
csiph-web