Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1210930

[PATCH v4 08/52] PCI: Remove duplicated code for resource sorting

From Yinghai Lu <yinghai@kernel.org>
Newsgroups linux.kernel
Subject [PATCH v4 08/52] PCI: Remove duplicated code for resource sorting
Date 2015-08-21 08:40 +0200
Message-ID <pZO9B-44i-37@gated-at.bofh.it> (permalink)
References <pZNZT-3SZ-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Now sort_resources() and pdev_sort_resources() all have sorting
code.

As we are going to call sort_resources() several places later, so
choose to keep sort_resources(), and remove related code in
pdev_sort_resources().


Signed-off-by: Yinghai Lu <yinghai@kernel.org>
---
 drivers/pci/setup-bus.c | 22 +++-------------------
 1 file changed, 3 insertions(+), 19 deletions(-)

diff --git a/drivers/pci/setup-bus.c b/drivers/pci/setup-bus.c
index 555a7a3..44d63c0 100644
--- a/drivers/pci/setup-bus.c
+++ b/drivers/pci/setup-bus.c
@@ -214,9 +214,8 @@ static void pdev_sort_resources(struct pci_dev *dev,
 
 	for (i = 0; i < PCI_NUM_RESOURCES; i++) {
 		struct resource *r;
-		struct pci_dev_resource *dev_res, *tmp;
+		struct pci_dev_resource *tmp;
 		resource_size_t r_align;
-		struct list_head *n;
 
 		r = &dev->resource[i];
 
@@ -239,22 +238,7 @@ static void pdev_sort_resources(struct pci_dev *dev,
 		tmp->res = r;
 		tmp->dev = dev;
 
-		/* fallback is smallest one or list is empty*/
-		n = head;
-		list_for_each_entry(dev_res, head, list) {
-			resource_size_t align;
-
-			align = __pci_resource_alignment(dev_res->dev,
-							 dev_res->res,
-							 realloc_head);
-
-			if (r_align > align) {
-				n = &dev_res->list;
-				break;
-			}
-		}
-		/* Insert it just before n*/
-		list_add_tail(&tmp->list, n);
+		list_add_tail(&tmp->list, head);
 	}
 }
 
@@ -557,9 +541,9 @@ static void __assign_resources_sorted(struct list_head *head,
 	}
 	free_list(&save_head);
 
+requested_and_reassign:
 	sort_resources(head);
 
-requested_and_reassign:
 	/* Satisfy the must-have resource requests */
 	assign_requested_resources_sorted(head, fail_head);
 
-- 
1.8.4.5

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 00/52] PCI: Resource allocation cleanup for v4.3 Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 23/52] PCI: Add support for more than two alt_size under same bridge Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 09/52] PCI: Rename pdev_sort_resources() to pdev_assign_resources_prepare() Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 18/52] PCI: Move comment to pci_need_to_release() Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 04/52] PCI: Optimize bus min_align/size calculation during sizing Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 27/52] PCI: Move ISA io port align out of calculate_iosize() Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 08/52] PCI: Remove duplicated code for resource sorting Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 05/52] PCI: Optimize bus align/size calculation for optional during sizing Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 36/52] PCI: Only treat non-pref mmio64 as pref if all bridges have MEM_64 Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 43/52] OF/PCI: Add IORESOURCE_MEM_64 for 64-bit resource Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
    Re: [PATCH v4 43/52] OF/PCI: Add IORESOURCE_MEM_64 for 64-bit resource Rob Herring <robherring2@gmail.com> - 2015-08-21 20:20 +0200
      Re: [PATCH v4 43/52] OF/PCI: Add IORESOURCE_MEM_64 for 64-bit resource Yinghai Lu <yinghai@kernel.org> - 2015-08-21 20:30 +0200
  [PATCH v4 15/52] PCI: Cache window alignment value during bus sizing Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 01/52] PCI: Cleanup res_to_dev_res() printout Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 32/52] PCI: Kill macro checking for bus io port sizing Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 21/52] PCI: Move saved required resource list out of required+optional assigning Yinghai Lu <yinghai@kernel.org> - 2015-08-21 08:40 +0200
  [PATCH v4 22/52] PCI: Add alt_size ressource allocation support Yinghai Lu <yinghai@kernel.org> - 2015-08-21 09:30 +0200
  [PATCH v4 44/52] PCI: Treat optional as required in first try for bridge rescan Yinghai Lu <yinghai@kernel.org> - 2015-08-21 09:30 +0200
  [PATCH v4 29/52] PCI: Unify calculate_size() for io port and MMIO Yinghai Lu <yinghai@kernel.org> - 2015-08-21 09:30 +0200

csiph-web