Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1209499

Re: [PATCH v3 09/51] PCI: Rename pdev_sort_resources to pdev_check_resources

From Yinghai Lu <yinghai@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH v3 09/51] PCI: Rename pdev_sort_resources to pdev_check_resources
Date 2015-08-18 23:50 +0200
Message-ID <pYWVz-2nZ-11@gated-at.bofh.it> (permalink)
References <pR09X-8vE-5@gated-at.bofh.it> <pR0a2-8vE-99@gated-at.bofh.it> <pYCtP-5KG-5@gated-at.bofh.it> <pYWLV-27E-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Tue, Aug 18, 2015 at 2:36 PM, Yinghai Lu <yinghai@kernel.org> wrote:
> On Mon, Aug 17, 2015 at 4:53 PM, Bjorn Helgaas <bhelgaas@google.com> wrote:
>> On Mon, Jul 27, 2015 at 04:29:27PM -0700, Yinghai Lu wrote:
>>> We don't do sorting in those functions anymore, so change "sort" to "check"
>>> instead.
>>
>> What *do* we do in those functions?  "Check" doesn't tell me anything.
>
> Put all children devices' resources that need to assign in one list, and also
> do some sanitary checking like if align is good or not.

or change to dev_assign_resources_prepare() ?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH v3 09/51] PCI: Rename pdev_sort_resources to  pdev_check_resources Bjorn Helgaas <bhelgaas@google.com> - 2015-08-18 02:00 +0200
  Re: [PATCH v3 09/51] PCI: Rename pdev_sort_resources to pdev_check_resources Yinghai Lu <yinghai@kernel.org> - 2015-08-18 23:40 +0200
    Re: [PATCH v3 09/51] PCI: Rename pdev_sort_resources to pdev_check_resources Yinghai Lu <yinghai@kernel.org> - 2015-08-18 23:50 +0200

csiph-web