Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1206674
| From | Christian Borntraeger <borntraeger@de.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper |
| Date | 2015-08-13 12:10 +0200 |
| Message-ID | <pWXCs-7m-73@gated-at.bofh.it> (permalink) |
| References | <pU9Tr-6QK-1@gated-at.bofh.it> <pU9Ts-6QK-7@gated-at.bofh.it> <pWKlQ-5Rw-5@gated-at.bofh.it> <pWWQ3-7nz-25@gated-at.bofh.it> <pWWZJ-7z0-29@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Am 13.08.2015 um 11:29 schrieb Paolo Bonzini: > > > On 13/08/2015 11:11, Radim Krčmář wrote: >>>> for the new interface. maybe we can rename kvm_check_request in a separate patch somewhen. >> I wonder why haven't we copied the naming convention from bit operations >> (or if programming would be better if German was its language), >> >> kvm_test_request >> kvm_set_request >> kvm_clear_request >> kvm_test_and_clear_request >> >> The only disadvantage is that >> kvm_test_and_clear_request >> is longer than >> kvm_check_request >> 123456789 >> by whooping 9 characters. >> >> I could live with that. > > Yes, that would be much better. +1 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 0/5] KVM: optimize userspace exits with a new ioctl Radim Krčmář <rkrcmar@redhat.com> - 2015-08-05 18:40 +0200
[PATCH v2 1/5] KVM: add kvm_has_request wrapper Radim Krčmář <rkrcmar@redhat.com> - 2015-08-05 18:40 +0200
Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper Christian Borntraeger <borntraeger@de.ibm.com> - 2015-08-12 22:00 +0200
Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper Radim Krčmář <rkrcmar@redhat.com> - 2015-08-13 11:20 +0200
Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper Paolo Bonzini <pbonzini@redhat.com> - 2015-08-13 11:30 +0200
Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper Christian Borntraeger <borntraeger@de.ibm.com> - 2015-08-13 12:10 +0200
Re: [PATCH v2 1/5] KVM: add kvm_has_request wrapper Radim Krčmář <rkrcmar@redhat.com> - 2015-08-14 10:50 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Paolo Bonzini <pbonzini@redhat.com> - 2015-08-05 18:40 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Paolo Bonzini <pbonzini@redhat.com> - 2015-08-06 16:10 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Radim Krčmář <rkrcmar@redhat.com> - 2015-08-07 04:40 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Radim Krčmář <rkrcmar@redhat.com> - 2015-08-06 16:50 +0200
[PATCH v2 3/5] KVM: x86: add request_exits debug counter Radim Krčmář <rkrcmar@redhat.com> - 2015-08-05 18:40 +0200
[PATCH v2 5/5] KVM: refactor asynchronous vcpu ioctl dispatch Radim Krčmář <rkrcmar@redhat.com> - 2015-08-05 18:40 +0200
Re: [PATCH v2 5/5] KVM: refactor asynchronous vcpu ioctl dispatch Christian Borntraeger <borntraeger@de.ibm.com> - 2015-08-12 22:10 +0200
Re: [PATCH v2 5/5] KVM: refactor asynchronous vcpu ioctl dispatch Radim Krčmář <rkrcmar@redhat.com> - 2015-08-13 11:00 +0200
Re: [PATCH v2 5/5] KVM: refactor asynchronous vcpu ioctl dispatch Paolo Bonzini <pbonzini@redhat.com> - 2015-08-13 11:30 +0200
[PATCH v2 2/5] KVM: add KVM_REQ_EXIT request for userspace exit Radim Krčmář <rkrcmar@redhat.com> - 2015-08-05 18:40 +0200
[PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Radim Krčmář <rkrcmar@redhat.com> - 2015-08-05 18:40 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Avi Kivity <avi.kivity@gmail.com> - 2015-08-16 22:30 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Paolo Bonzini <pbonzini@redhat.com> - 2015-08-17 15:20 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Avi Kivity <avi.kivity@gmail.com> - 2015-08-18 20:40 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Paolo Bonzini <pbonzini@redhat.com> - 2015-08-18 22:00 +0200
Re: [PATCH v2 4/5] KVM: add KVM_USER_EXIT vcpu ioctl for userspace exit Avi Kivity <avi.kivity@gmail.com> - 2015-08-19 08:50 +0200
csiph-web