Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1201401
| From | Xiao Guangrong <guangrong.xiao@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v2 8/9] KVM: MMU: fully check zero bits for sptes |
| Date | 2015-08-06 05:00 +0200 |
| Message-ID | <pUjzr-3Vy-3@gated-at.bofh.it> (permalink) |
| References | <pTYlk-6ZG-5@gated-at.bofh.it> <pTYlk-6ZG-25@gated-at.bofh.it> <pU3XH-6Iq-17@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 08/05/2015 06:12 PM, Paolo Bonzini wrote:
>
>
> On 05/08/2015 06:04, Xiao Guangrong wrote:
>> - for_each_shadow_entry_lockless(vcpu, addr, iterator, spte)
>> + for_each_shadow_entry_lockless(vcpu, addr, iterator, spte) {
>> + leaf = iterator.level;
>> +
>> + if (!root)
>> + root = leaf;
>> +
>> + sptes[leaf - 1] = spte;
>> +
>
> I'm a bit undecided between this and open-coding the macro:
>
> for (shadow_walk_init(&iterator, vcpu, addr), root = iterator.level;
> shadow_walk_okay(&iterator);
> __shadow_walk_next(&iterator, spte)) {
> leaf = iterator.level;
> spte = mmu_spte_get_lockless(iterator.sptep);
>
> Any second opinions?
Your adjustment is good to me, i do not have other ideas... :)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v2 0/9] KVM: MMU: fix and improve validation of mmio page fault Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
[PATCH v2 6/9] KVM: MMU: introduce the framework to check zero bits on sptes Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
[PATCH v2 5/9] KVM: MMU: split reset_rsvds_bits_mask_ept Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
[PATCH v2 4/9] KVM: MMU: split reset_rsvds_bits_mask Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
[PATCH v2 1/9] KVM: MMU: fix validation of mmio page fault Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
[PATCH v2 9/9] KVM: VMX: drop ept misconfig check Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
[PATCH v2 2/9] KVM: MMU: move FNAME(is_rsvd_bits_set) to mmu.c Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
[PATCH v2 8/9] KVM: MMU: fully check zero bits for sptes Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-05 06:20 +0200
Re: [PATCH v2 8/9] KVM: MMU: fully check zero bits for sptes Paolo Bonzini <pbonzini@redhat.com> - 2015-08-05 12:20 +0200
Re: [PATCH v2 8/9] KVM: MMU: fully check zero bits for sptes Xiao Guangrong <guangrong.xiao@linux.intel.com> - 2015-08-06 05:00 +0200
csiph-web