Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1200533

Re: [PATCH 4/7] x86/vm86: Move vm86 fields out of thread_struct

From Ingo Molnar <mingo@kernel.org>
Newsgroups linux.kernel
Subject Re: [PATCH 4/7] x86/vm86: Move vm86 fields out of thread_struct
Date 2015-08-05 10:50 +0200
Message-ID <pU2yB-4zf-5@gated-at.bofh.it> (permalink)
References <pO7KF-2Os-3@gated-at.bofh.it> <pO7Um-2ZL-15@gated-at.bofh.it> <pOA0h-1le-3@gated-at.bofh.it> <pOHO9-40A-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


* Brian Gerst <brgerst@gmail.com> wrote:

> > Btw., the variable names here are crazy. I had to look twice to realize that 
> > we have 'v86' and 'vm86' which are two different things.
> >
> > Also, vm86plus_struct variables and fields are named wildly inconsistently: 
> > sometimes it's 'vm86.vm86_info', sometimes it's 'v86', sometimes 'user'. Ugh.
> >
> > Other fields have naming inconsistencies as well: for example we have 
> > thread.vm86->vm86plus.vm86dbg_active. 'vm86' is repeated _three_ times in that 
> > name, for no good reason.
> >
> > So please clean up the naming to make this all easier to read. Only the 
> > highest level field should have 'vm86' in it - all subsequent fields will 
> > inherit that name one way or another.
> 
> Some of these field names are visible to userspace and can't change.

That's a misconception: bits in the uapi headers can be renamed just fine.

The kernel ABI is that _semantics_ that user-space code relies on must not change.

Cleaning up field names is absolutely legit to do, and we've done it numerous 
times in the past. Especially where they are so confusing and inconsistent as in 
the vm86 code.

Thanks,

	Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

Re: [PATCH 4/7] x86/vm86: Move vm86 fields out of thread_struct Ingo Molnar <mingo@kernel.org> - 2015-08-05 10:50 +0200
  Re: [PATCH 4/7] x86/vm86: Move vm86 fields out of thread_struct Linus Torvalds <torvalds@linux-foundation.org> - 2015-08-05 11:00 +0200

csiph-web