Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1199214

Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface

From Steven Rostedt <rostedt@goodmis.org>
Newsgroups linux.kernel
Subject Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface
Date 2015-08-03 21:30 +0200
Message-ID <pTtAS-40w-9@gated-at.bofh.it> (permalink)
References (1 earlier) <pRd7f-27d-75@gated-at.bofh.it> <pRtOF-189-11@gated-at.bofh.it> <pRvdL-31w-13@gated-at.bofh.it> <pTthw-3DC-15@gated-at.bofh.it> <pTtrc-3P6-23@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, 3 Aug 2015 21:18:16 +0200
Peter Zijlstra <peterz@infradead.org> wrote:

> On Mon, Aug 03, 2015 at 03:03:59PM -0400, Steven Rostedt wrote:
> 
> > I wonder if static_branch_set_false(&blah) would be a better name to
> > understand. What does "disable" / "enable" mean?
> 
> "make false" / "make true" ? Check a local dictionary.
> 
> http://lmgtfy.com/?q=enable

I know the definition on enable :-p

> 
> "2. computing: make (a device or system) operational; active"
> 
> A value can be true/false, an action that makes true/false is
> enable/disable.

enable is more "activate" and disable is more "deactivate" not "make
true" and "make false". It's subtle, but there is a difference. Try
switching it around in other contexts. One could "disable networking"
but saying "make networking false" doesn't make sense.

Technically, one can think: "activate the branch", but we are
activating not the branch, but the jump label itself. It's not as clear
as setting it to "true" or "false".

What the static_branch does is already confusing enough, we should try
to use the terminology that is as clear as possible.

"set_true" is more understandable than "enable" when one can question,
what exactly are we "enabling"?

-- Steve

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Peter Zijlstra <peterz@infradead.org> - 2015-07-29 10:50 +0200
  Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Steven Rostedt <rostedt@goodmis.org> - 2015-08-03 21:10 +0200
    Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Peter Zijlstra <peterz@infradead.org> - 2015-08-03 21:20 +0200
      Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Steven Rostedt <rostedt@goodmis.org> - 2015-08-03 21:30 +0200
        Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Peter Zijlstra <peterz@infradead.org> - 2015-08-03 22:10 +0200
          Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Steven Rostedt <rostedt@goodmis.org> - 2015-08-04 00:00 +0200
            Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Borislav Petkov <bp@alien8.de> - 2015-08-04 05:40 +0200
              Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Andy Lutomirski <luto@amacapital.net> - 2015-08-04 06:10 +0200
                Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Borislav Petkov <bp@alien8.de> - 2015-08-04 06:30 +0200
              Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Steven Rostedt <rostedt@goodmis.org> - 2015-08-04 14:10 +0200
                Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Borislav Petkov <bp@alien8.de> - 2015-08-04 16:40 +0200
                Re: [PATCH -v2 6/8] jump_label: Add a new static_key interface Andy Lutomirski <luto@amacapital.net> - 2015-08-04 17:00 +0200

csiph-web