Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1193898

Re: [PATCH 6/8] power: bq27xxx_battery: Fix typos and change naming for state of charge functions

From Pali Rohár <pali.rohar@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH 6/8] power: bq27xxx_battery: Fix typos and change naming for state of charge functions
Date 2015-07-28 10:50 +0200
Message-ID <pR8Kf-43p-49@gated-at.bofh.it> (permalink)
References <pPan8-46e-11@gated-at.bofh.it> <pPan9-46e-47@gated-at.bofh.it> <pPrnY-3ny-27@gated-at.bofh.it> <pPsk3-4Kr-27@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thursday 23 July 2015 12:19:16 Andrew F. Davis wrote:
> On 07/23/2015 11:15 AM, Pali Rohár wrote:
> > On Wednesday 22 July 2015 16:51:58 Andrew F. Davis wrote:
> >> Fix typos and change "relative state of charge" to "state of charge" as not
> >> all supported devices use relative state of charge.
> >>
> >> Signed-off-by: Andrew F. Davis <afd@ti.com>
> >> ---
> >>  drivers/power/bq27xxx_battery.c | 26 +++++++++++++-------------
> >>  1 file changed, 13 insertions(+), 13 deletions(-)
> >>
> >> diff --git a/drivers/power/bq27xxx_battery.c b/drivers/power/bq27xxx_battery.c
> >> index f5d7a137..5686da6 100644
> >> --- a/drivers/power/bq27xxx_battery.c
> >> +++ b/drivers/power/bq27xxx_battery.c
> >> @@ -231,26 +231,26 @@ static bool bq27xxx_is_chip_version_higher(struct bq27xxx_device_info *di)
> >>  }
> >>  
> >>  /*
> >> - * Return the battery Relative State-of-Charge
> >> + * Return the battery State-of-Charge
> >>   * Or < 0 if something fails.
> >>   */
> >> -static int bq27xxx_battery_read_rsoc(struct bq27xxx_device_info *di)
> >> +static int bq27xxx_battery_read_soc(struct bq27xxx_device_info *di)
> >>  {
> >> -	int rsoc;
> >> +	int soc;
> >>  
> >>  	if (di->chip == BQ27500 || di->chip == BQ27742)
> >> -		rsoc = bq27xxx_read(di, BQ27500_REG_SOC, false);
> >> +		soc = bq27xxx_read(di, BQ27500_REG_SOC, false);
> >>  	else if (di->chip == BQ27510)
> >> -		rsoc = bq27xxx_read(di, BQ27510_REG_SOC, false);
> >> +		soc = bq27xxx_read(di, BQ27510_REG_SOC, false);
> >>  	else if (di->chip == BQ27425)
> >> -		rsoc = bq27xxx_read(di, BQ27425_REG_SOC, false);
> >> +		soc = bq27xxx_read(di, BQ27425_REG_SOC, false);
> >>  	else
> >> -		rsoc = bq27xxx_read(di, BQ27000_REG_RSOC, true);
> >> +		soc = bq27xxx_read(di, BQ27000_REG_RSOC, true);
> >>  
> >> -	if (rsoc < 0)
> >> -		dev_dbg(di->dev, "error reading relative State-of-Charge\n");
> >> +	if (soc < 0)
> >> +		dev_dbg(di->dev, "error reading State-of-Charge\n");
> >>  
> >> -	return rsoc;
> >> +	return soc;
> >>  }
> >>  
> > 
> > It is good idea to have name function name "read_soc" with description
> > "Return State-of-Charge" and for some chips that function returns RSOC
> > (Relative)? For me it is quite misleading.
> > 
> 
> Most of the chips only return one type of SOC, and the docs refer to this
> as just "State-of-Charge". The bq27000 has "Relative" and " Compensated"
> but we only return one (Relative). So I figured this would be the more
> correct way to describe the general SOC reading function even when the
> chips may expose other types.
> 

Can you add short comment for bq27000 if-branch about it?

> >>  /*
> >> @@ -277,7 +277,7 @@ static int bq27xxx_battery_read_charge(struct bq27xxx_device_info *di, u8 reg)
> >>  }
> >>  
> >>  /*
> >> - * Return the battery Nominal available capaciy in µAh
> >> + * Return the battery Nominal available capacity in µAh
> >>   * Or < 0 if something fails.
> >>   */
> >>  static inline int bq27xxx_battery_read_nac(struct bq27xxx_device_info *di)
> >> @@ -418,7 +418,7 @@ static int bq27xxx_battery_read_time(struct bq27xxx_device_info *di, u8 reg)
> >>  }
> >>  
> >>  /*
> >> - * Read a power avg register.
> >> + * Read an average power register.
> >>   * Return < 0 if something fails.
> >>   */
> >>  static int bq27xxx_battery_read_pwr_avg(struct bq27xxx_device_info *di, u8 reg)
> >> @@ -500,7 +500,7 @@ static void bq27xxx_battery_update(struct bq27xxx_device_info *di)
> >>  			cache.charge_full = -ENODATA;
> >>  			cache.health = -ENODATA;
> >>  		} else {
> >> -			cache.capacity = bq27xxx_battery_read_rsoc(di);
> >> +			cache.capacity = bq27xxx_battery_read_soc(di);
> >>  			if (is_bq27742 || is_bq27510)
> >>  				cache.time_to_empty =
> >>  					bq27xxx_battery_read_time(di,
> > 
> 

-- 
Pali Rohár
pali.rohar@gmail.com
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

Re: [PATCH 6/8] power: bq27xxx_battery: Fix typos and change naming  for state of charge functions "Andrew F. Davis" <afd@ti.com> - 2015-07-23 19:20 +0200
  Re: [PATCH 6/8] power: bq27xxx_battery: Fix typos and change naming  for state of charge functions Pali Rohár <pali.rohar@gmail.com> - 2015-07-28 10:50 +0200

csiph-web