Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1193780
| From | James Liao <jamesjj.liao@mediatek.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes |
| Date | 2015-07-28 07:40 +0200 |
| Message-ID | <pR5Mm-8i5-5@gated-at.bofh.it> (permalink) |
| References | <pPBwZ-1vF-3@gated-at.bofh.it> <pPJuz-4vX-35@gated-at.bofh.it> <pQGNX-5qP-1@gated-at.bofh.it> <pQNPs-7dH-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, 2015-07-27 at 03:21 -0700, Matthias Brugger wrote:
> On Monday, July 27, 2015 10:56:22 AM James Liao wrote:
> > Hi Daniel,
> >
> > On Fri, 2015-07-24 at 19:32 +0800, Daniel Kurtz wrote:
> > > > @@ -88,6 +88,13 @@
> > > >
> > > > #clock-cells = <0>;
> > > >
> > > > };
> > > >
> > > > + cpum_ck: dummy_clk {
> > >
> > > I'm not a big fan of this "dummy_clk".
> > > The 'name' part of the devicetree node is supposed to be generic.
> > > So, perhaps just oscillator@2, and move it down below clk32k:
> > > oscillator@1.
> >
> > > Otherwise:
> > cpum_ck is a test clock which only available in IC test. It's empty on
> > MT8173 evaluation or production boards. Should we name this kind of
> > empty clock as an oscillator? Or is there a better name for it?
> >
>
> So if it will never be part of any available boards, why do you want to add
> it?
infra_cpum is a clock gate, and its clock comes from an external clock.
In previous versions we named the external clock as "clk_null", but it's
not accepted. A specified name is preferred even it's not available on
some boards. So I named it as cpum_ck in this patch.
Best regards,
James
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes James Liao <jamesjj.liao@mediatek.com> - 2015-07-24 05:10 +0200
Re: [PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes Daniel Kurtz <djkurtz@chromium.org> - 2015-07-24 13:40 +0200
Re: [PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes Matthias Brugger <matthias.bgg@gmail.com> - 2015-07-27 12:30 +0200
Re: [PATCH v4 7/7] arm64: dts: mt8173: Add subsystem clock controller device nodes James Liao <jamesjj.liao@mediatek.com> - 2015-07-28 07:40 +0200
csiph-web