Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1193652

[PATCH v3 0/2] dma: rename write-combine APIs with short form

From "Luis R. Rodriguez" <mcgrof@do-not-panic.com>
Newsgroups linux.kernel
Subject [PATCH v3 0/2] dma: rename write-combine APIs with short form
Date 2015-07-28 02:10 +0200
Message-ID <pR0CZ-Rv-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


From: "Luis R. Rodriguez" <mcgrof@suse.com>

Ingo, Boris (I think you're back from vacation, not sure if this 
should go through your tree or directly through Ingo),

Ingo had suggested for this series to be kept in my tree until we're
almost done with the merge window [0]. Since we missed inclusion on v4.2
as it was hard to measure when we're exactly close to the merge window
Ingo suggested on my v2 series to just add defines to make old callers
work, this would avoid conflicts should new code be added during the
next development window, and we could later remove this from future releases
once things settle [1]. This v3 series adds these define callers to
help get this merged at any point in time, so its doesnt' have to wait
to go in to the very last minute. This series was rebased on top of
linux-next next-20150727.

[0] http://lkml.kernel.org/r/20150601085332.GA14549@gmail.com
[1] http://lkml.kernel.org/r/20150718034242.GB21260@gmail.com

Luis R. Rodriguez (2):
  drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style
  dma: rename dma_*_writecombine() to dma_*_wc()

 arch/arm/mach-lpc32xx/phy3250.c           | 13 ++++++-------
 arch/arm/mach-netx/fb.c                   | 14 ++++++--------
 arch/arm/mach-nspire/clcd.c               | 13 ++++++-------
 arch/avr32/include/asm/dma-mapping.h      | 20 ++++++++++----------
 arch/avr32/mm/dma-coherent.c              | 12 ++++++------
 arch/metag/include/asm/dma-mapping.h      |  4 ++--
 arch/metag/kernel/dma.c                   |  6 +++---
 drivers/dma/iop-adma.c                    |  9 +++++----
 drivers/dma/mv_xor.c                      |  4 ++--
 drivers/dma/qcom_bam_dma.c                | 14 +++++++-------
 drivers/gpu/drm/drm_gem_cma_helper.c      | 13 ++++++-------
 drivers/gpu/drm/omapdrm/omap_dmm_tiler.c  | 13 ++++++-------
 drivers/gpu/drm/omapdrm/omap_gem.c        |  8 ++++----
 drivers/gpu/drm/sti/sti_cursor.c          | 20 ++++++++------------
 drivers/gpu/drm/sti/sti_gdp.c             |  3 +--
 drivers/gpu/drm/sti/sti_hqvdp.c           |  6 +++---
 drivers/gpu/drm/tegra/gem.c               | 11 +++++------
 drivers/gpu/host1x/cdma.c                 |  8 ++++----
 drivers/gpu/host1x/job.c                  | 10 ++++------
 drivers/media/platform/coda/coda-bit.c    | 10 +++++-----
 drivers/video/fbdev/acornfb.c             |  4 ++--
 drivers/video/fbdev/amba-clcd-versatile.c | 14 ++++++--------
 drivers/video/fbdev/amba-clcd.c           |  4 ++--
 drivers/video/fbdev/atmel_lcdfb.c         |  9 +++++----
 drivers/video/fbdev/ep93xx-fb.c           |  8 +++-----
 drivers/video/fbdev/gbefb.c               |  8 ++++----
 drivers/video/fbdev/imxfb.c               | 12 ++++++------
 drivers/video/fbdev/mx3fb.c               |  9 ++++-----
 drivers/video/fbdev/nuc900fb.c            |  8 ++++----
 drivers/video/fbdev/omap/lcdc.c           | 16 ++++++++--------
 drivers/video/fbdev/pxa168fb.c            |  8 ++++----
 drivers/video/fbdev/pxafb.c               |  4 ++--
 drivers/video/fbdev/s3c-fb.c              |  7 +++----
 drivers/video/fbdev/s3c2410fb.c           |  8 ++++----
 drivers/video/fbdev/sa1100fb.c            |  8 ++++----
 include/linux/dma-mapping.h               | 26 ++++++++++++++++++--------
 sound/arm/pxa2xx-pcm-lib.c                | 20 ++++++++------------
 sound/soc/fsl/imx-pcm-fiq.c               | 10 ++++------
 sound/soc/nuc900/nuc900-pcm.c             |  6 ++----
 sound/soc/omap/omap-pcm.c                 | 12 ++++--------
 40 files changed, 196 insertions(+), 216 deletions(-)

-- 
2.3.2.209.gd67f9d5.dirty

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH v3 0/2] dma: rename write-combine APIs with short form "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-07-28 02:10 +0200
  [PATCH v3 1/2] drivers/dma/iop-adma: Use dma_alloc_writecombine() kernel-style "Luis R. Rodriguez" <mcgrof@do-not-panic.com> - 2015-07-28 02:10 +0200
  Re: [PATCH v3 0/2] dma: rename write-combine APIs with short form "Luis R. Rodriguez" <mcgrof@suse.com> - 2015-08-03 22:50 +0200

csiph-web