Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1190579
| From | Greg KH <gregkh@linuxfoundation.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [char-misc-next 01/15 V2] mei: bus: fix drivers and devices names confusion |
| Date | 2015-07-23 06:40 +0200 |
| Message-ID | <pPgsy-4tQ-1@gated-at.bofh.it> (permalink) |
| References | <pBHLX-3zS-3@gated-at.bofh.it> <pBHLZ-3zS-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Jun 15, 2015 at 09:56:41PM +0300, Tomas Winkler wrote:
> In the mei bus layer there is use of different variables
> of driver and device types with no clear naming convention.
> There are generic struct device and struct driver,
> then mei_cl_{device, driver}, and finally mei_device which
> in this context serves as a bus device.
>
> The patch sets following naming convention:
>
> the variables of type struct device remains dev
> the variables of type struct driver remains drv
> the variables of type struct mei_cl_device are now cldev
> the variables of type struct mei_cl_driver are now cldrv
> the variables of type struct mei_device are now bus, in bus
> layer context
>
> Signed-off-by: Tomas Winkler <tomas.winkler@intel.com>
Due to the changes in Linus's tree, this doesn't apply to 4.2-rc3. Can
you refresh this series and resend? Same for the other outstanding mei
patches you have sent that I haven't applied.
thanks,
greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [char-misc-next 01/15 V2] mei: bus: fix drivers and devices names confusion Greg KH <gregkh@linuxfoundation.org> - 2015-07-23 06:40 +0200
csiph-web