Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1189843
| From | Josh Poimboeuf <jpoimboe@redhat.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC PATCH 13/21] x86/asm/crypto: Fix frame pointer usage in aesni-intel_asm.S |
| Date | 2015-07-22 14:00 +0200 |
| Message-ID | <pP0QN-5Wa-1@gated-at.bofh.it> (permalink) |
| References | (5 earlier) <pNrs6-Xz-7@gated-at.bofh.it> <pOe9s-3nL-11@gated-at.bofh.it> <pOjLQ-30h-17@gated-at.bofh.it> <pOn34-7R5-9@gated-at.bofh.it> <pOnFM-nL-11@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Jul 20, 2015 at 01:00:06PM -0500, Josh Poimboeuf wrote: > On Mon, Jul 20, 2015 at 07:21:24PM +0200, Ingo Molnar wrote: > > * Josh Poimboeuf <jpoimboe@redhat.com> wrote: > > Ok, I see how the naming scheme I proposed won't work with all that very well, but > > I'd still suggest using consistently named patterns. > > > > Let me suggest yet another approach. How about open-coding something like this: > > > > FUNCTION_START(func) > > > > push_bp > > mov_sp_bp > > > > ... > > > > pop_bp > > ret > > > > FUNCTION_END(func) > > > > This is just two easy things: > > > > - a redefine of the FUNCTION_ENTRY and ENDPROC names > > > > - the introduction of three quasi-mnemonics: push_bp, mov_sp_bp, pop_bp - which > > all look very similar to a real frame setup sequence, except that we can easily > > make them go away in the !CONFIG_FRAME_POINTERS case. > > > > The advantage of this approach would be: > > > > - it looks pretty 'natural' and very close to how the real disassembly looks > > like in CONFIG_FRAME_POINTERS=y kernels. So while it's not as compact as some > > of the other variants, it's close to what the real instruction sequence looks > > like and that is a positive quality in itself. > > > > - it also makes it apparent 'on sight' that it's probably a bug to have > > unbalanced push/pop sequences in a regular function, to any reasonably alert > > assembly coder. > > > > - if we ever unsupport framepointer kernels in the (far far) future, we can get > > rid of all lines with those 3 mnemonics and be done with it. > > > > - it's finegrained enough so that we can express all the special function/tail > > variants you listed above. > > > > What do you think? > > I agree that the edge cases make FUNCTION_ENTRY and FUNCTION_RETURN less > attractive. Slowly we are circling around to where we started :-) > > Personally, I prefer FRAME/ENDFRAME instead of push_bp/mov_sp_bp/pop_bp, > because it more communicates *what* it's doing rather than how. IMO, > it's easier to grok with a quick glance. Ingo, any chance this last paragraph was a convincing argument to continue to use FRAME/ENDFRAME over push_bp/mov_sp_bp/pop_bp? (I think this is the last outstanding issue from the reviews, so I'm all set to send out a new version of the patches once there's agreement on this issue.) -- Josh -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [RFC PATCH 13/21] x86/asm/crypto: Fix frame pointer usage in aesni-intel_asm.S Josh Poimboeuf <jpoimboe@redhat.com> - 2015-07-20 16:00 +0200
Re: [RFC PATCH 13/21] x86/asm/crypto: Fix frame pointer usage in aesni-intel_asm.S Ingo Molnar <mingo@kernel.org> - 2015-07-20 19:30 +0200
Re: [RFC PATCH 13/21] x86/asm/crypto: Fix frame pointer usage in aesni-intel_asm.S Josh Poimboeuf <jpoimboe@redhat.com> - 2015-07-20 20:10 +0200
Re: [RFC PATCH 13/21] x86/asm/crypto: Fix frame pointer usage in aesni-intel_asm.S Josh Poimboeuf <jpoimboe@redhat.com> - 2015-07-22 14:00 +0200
csiph-web