Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1189753
| From | Borislav Petkov <bp@alien8.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [RFC PATCH 0/4] x86/ras: Move AMD MCE injection module to arch/x86/ |
| Date | 2015-07-22 10:50 +0200 |
| Message-ID | <pOXSW-1JX-19@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
From: Borislav Petkov <bp@suse.de>
Hi all,
so this has been on my mind for a while now and the recent pull request
sdebacle imply accelerated it. The advantage of moving it closer to MCE
code is that improvements/additions to the MCE code can automatically
get injection functionality added for testing.
With that in place, injection of threshold and deferred errors will get
added.
Still RFC as there's more RAS stuff pending review currently.
Thanks.
Borislav Petkov (4):
RAS: Add a menuconfig option with descriptive text
x86/mce: Rename rcu_dereference_check_mce() to mce_log_get_idx_check()
x86/mce: Add a wrapper around mce_log() for injection
x86/ras: Move AMD MCE injector to arch/x86/ras/
arch/x86/Makefile | 2 ++
arch/x86/kernel/cpu/mcheck/mce-internal.h | 2 ++
arch/x86/kernel/cpu/mcheck/mce.c | 15 ++++++++---
arch/x86/ras/Kconfig | 11 +++++++++
arch/x86/ras/Makefile | 2 ++
{drivers/edac => arch/x86/ras}/mce_amd_inj.c | 6 ++---
drivers/edac/Kconfig | 10 --------
drivers/edac/Makefile | 1 -
drivers/ras/Kconfig | 37 ++++++++++++++++++++++++++--
9 files changed, 66 insertions(+), 20 deletions(-)
create mode 100644 arch/x86/ras/Kconfig
create mode 100644 arch/x86/ras/Makefile
rename {drivers/edac => arch/x86/ras}/mce_amd_inj.c (98%)
--
2.5.0.rc2.28.g6003e7f
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[RFC PATCH 0/4] x86/ras: Move AMD MCE injection module to arch/x86/ Borislav Petkov <bp@alien8.de> - 2015-07-22 10:50 +0200 [RFC PATCH 4/4] x86/ras: Move AMD MCE injector to arch/x86/ras/ Borislav Petkov <bp@alien8.de> - 2015-07-22 10:50 +0200 [RFC PATCH 2/4] x86/mce: Rename rcu_dereference_check_mce() to mce_log_get_idx_check() Borislav Petkov <bp@alien8.de> - 2015-07-22 10:50 +0200 [RFC PATCH 1/4] RAS: Add a menuconfig option with descriptive text Borislav Petkov <bp@alien8.de> - 2015-07-22 10:50 +0200
csiph-web