Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1187667

[PATCH 085/102] staging: rtl8192e: Rename init_rate_adaptive

From Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
Newsgroups linux.kernel
Subject [PATCH 085/102] staging: rtl8192e: Rename init_rate_adaptive
Date 2015-07-19 19:40 +0200
Message-ID <pO0Jf-15r-79@gated-at.bofh.it> (permalink)
References <pO0zw-TU-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Use naming schema found in other rtlwifi devices.
Rename init_rate_adaptive to rtl92e_init_adaptive_rate.

Signed-off-by: Mateusz Kulikowski <mateusz.kulikowski@gmail.com>
---
 drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c | 2 +-
 drivers/staging/rtl8192e/rtl8192e/rtl_dm.c     | 4 ++--
 drivers/staging/rtl8192e/rtl8192e/rtl_dm.h     | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c b/drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c
index f72b065..6f1dcd3 100644
--- a/drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c
+++ b/drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c
@@ -560,7 +560,7 @@ static void rtl8192_read_eeprom_info(struct net_device *dev)
 		RT_TRACE(COMP_INIT, "\n2T4R config\n");
 	}
 
-	init_rate_adaptive(dev);
+	rtl92e_init_adaptive_rate(dev);
 
 	priv->rf_chip = RF_8256;
 
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_dm.c b/drivers/staging/rtl8192e/rtl8192e/rtl_dm.c
index 564b17c..b600035 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_dm.c
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_dm.c
@@ -234,7 +234,7 @@ void init_hal_dm(struct net_device *dev)
 
 	dm_init_dynamic_txpower(dev);
 
-	init_rate_adaptive(dev);
+	rtl92e_init_adaptive_rate(dev);
 
 	dm_dig_init(dev);
 	rtl92e_dm_init_edca_turbo(dev);
@@ -307,7 +307,7 @@ static void dm_check_ac_dc_power(struct net_device *dev)
 };
 
 
-void init_rate_adaptive(struct net_device *dev)
+void rtl92e_init_adaptive_rate(struct net_device *dev)
 {
 
 	struct r8192_priv *priv = rtllib_priv(dev);
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_dm.h b/drivers/staging/rtl8192e/rtl8192e/rtl_dm.h
index 7147886..e7a2dcf 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_dm.h
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_dm.h
@@ -194,7 +194,7 @@ extern  void rtl92e_dm_deinit(struct net_device *dev);
 extern void rtl92e_dm_watchdog(struct net_device *dev);
 
 
-extern  void    init_rate_adaptive(struct net_device *dev);
+extern  void    rtl92e_init_adaptive_rate(struct net_device *dev);
 extern  void    rtl92e_dm_txpower_tracking_wq(void *data);
 
 extern  void rtl92e_dm_cck_txpower_adjust(struct net_device *dev, bool binch14);
-- 
1.8.4.1

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 000/102] staging: rtl8192e: Function names cleanup Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:30 +0200
  [PATCH 003/102] staging: rtl8192e: Rename PHY_SetRF8256CCKTxPower Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:30 +0200
  [PATCH 083/102] staging: rtl8192e: Rename dm_txpower_trackingcallback Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 012/102] staging: rtl8192e: Rename rtl8192_enable_tx Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 079/102] staging: rtl8192e: Rename dm_init_edca_turbo Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 075/102] staging: rtl8192e: Rename write_nic_word Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 018/102] staging: rtl8192e: Rename rtl8192_HalRxCheckStuck Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 078/102] staging: rtl8192e: Rename dm_cck_txpower_adjust Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 080/102] staging: rtl8192e: Rename dm_initialize_txpower_tracking Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 037/102] staging: rtl8192e: Rename rtl8192_phy_getTxPower Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 030/102] staging: rtl8192e: Rename PHY_ScanOperationBackup8192 Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 082/102] staging: rtl8192e: Rename dm_rf_pathcheck_workitemcallback Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 081/102] staging: rtl8192e: Rename dm_restore_dynamic_mechanism_state Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 089/102] staging: rtl8192e: Rename rtl8192E_suspend Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 074/102] staging: rtl8192e: Rename write_nic_dword Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 090/102] staging: rtl8192e: Rename IPSEnter Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 065/102] staging: rtl8192e: Rename rtl8192_rx_enable Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 052/102] staging: rtl8192e: Rename check_rfctrl_gpio_timer Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 084/102] staging: rtl8192e: Rename hal_dm_watchdog Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 043/102] staging: rtl8192e: Rename rtl8192_QueryBBReg Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 076/102] staging: rtl8192e: Rename deinit_hal_dm Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 077/102] staging: rtl8192e: Rename dm_backup_dynamic_mechanism_state Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 010/102] staging: rtl8192e: Rename rtl8192_EnableInterrupt Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 088/102] staging: rtl8192e: Rename rtl8192E_resume Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 086/102] staging: rtl8192e: Rename eprom_read Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 087/102] staging: rtl8192e: Rename rtl8192_pci_findadapter Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 085/102] staging: rtl8192e: Rename init_rate_adaptive Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:40 +0200
  [PATCH 047/102] staging: rtl8192e: Rename CamResetAllEntry Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 055/102] staging: rtl8192e: Rename NicIFEnableNIC Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 032/102] staging: rtl8192e: Rename rtl8192_BBConfig Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 041/102] staging: rtl8192e: Rename rtl8192_phy_setTxPower Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 064/102] staging: rtl8192e: Rename rtl8192_record_rxdesc_forlateruse Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 070/102] staging: rtl8192e: Rename rtl819x_translate_todbm Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 063/102] staging: rtl8192e: Rename rtl8192_pci_resetdescring Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 058/102] staging: rtl8192e: Rename read_nic_word Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 066/102] staging: rtl8192e: Rename rtl8192_SetWirelessMode Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 050/102] staging: rtl8192e: Rename setKey Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 071/102] staging: rtl8192e: Rename rtl819x_UpdateRxPktTimeStamp Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 045/102] staging: rtl8192e: Rename rtl8192_SetBWMode Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 062/102] staging: rtl8192e: Rename rtl8192_irq_enable Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 040/102] staging: rtl8192e: Rename rtl8192_phy_SetRFReg Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 072/102] staging: rtl8192e: Rename rtl819x_update_rxsignalstatistics8190pci Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 069/102] staging: rtl8192e: Rename rtl819x_query_rxpwrpercentage Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 059/102] staging: rtl8192e: Rename rtl8192_commit Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 053/102] staging: rtl8192e: Rename MgntActSet_RF_State Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 068/102] staging: rtl8192e: Rename rtl819x_evm_dbtopercentage Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 048/102] staging: rtl8192e: Rename CamRestoreAllEntry Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 061/102] staging: rtl8192e: Rename rtl8192_irq_disable Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 051/102] staging: rtl8192e: Rename set_swcam Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 060/102] staging: rtl8192e: Rename rtl8192_config_rate Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 056/102] staging: rtl8192e: Rename read_nic_byte Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 067/102] staging: rtl8192e: Rename rtl8192_tx_enable Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 042/102] staging: rtl8192e: Rename rtl8192_phy_SwChnl Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 054/102] staging: rtl8192e: Rename NicIFDisableNIC Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 046/102] staging: rtl8192e: Rename SetRFPowerState Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 039/102] staging: rtl8192e: Rename rtl8192_phy_RFConfig Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 057/102] staging: rtl8192e: Rename read_nic_dword Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 049/102] staging: rtl8192e: Rename EnableHWSecurityConfig8192 Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 038/102] staging: rtl8192e: Rename rtl8192_phy_QueryRFReg Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 19:50 +0200
  [PATCH 005/102] staging: rtl8192e: Rename cmpk_message_handle_tx Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 016/102] staging: rtl8192e: Rename rtl8192_GetHalfNmodeSupportByAPs Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 033/102] staging: rtl8192e: Rename rtl8192_phy_checkBBAndRF Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 025/102] staging: rtl8192e: Rename rtl8192_tx_fill_cmd_desc Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 022/102] staging: rtl8192e: Rename rtl8192_interrupt_recognized Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 001/102] staging: rtl8192e: Rename PHY_RF8256_Config Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 021/102] staging: rtl8192e: Rename rtl8192_InitializeVariables Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 026/102] staging: rtl8192e: Rename rtl8192_tx_fill_desc Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 006/102] staging: rtl8192e: Rename rtl8192_adapter_start Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 017/102] staging: rtl8192e: Rename rtl8192_GetNmodeSupportBySecCfg Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 024/102] staging: rtl8192e: Rename rtl8192_rx_query_status_desc Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 029/102] staging: rtl8192e: Rename InitialGain819xPci Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 027/102] staging: rtl8192e: Rename rtl8192_update_ratr_table Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 008/102] staging: rtl8192e: Rename rtl8192_ClearInterrupt Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 013/102] staging: rtl8192e: Rename rtl8192e_SetHwReg Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 011/102] staging: rtl8192e: Rename rtl8192_enable_rx Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 020/102] staging: rtl8192e: Rename rtl8192_HalTxCheckStuck Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 015/102] staging: rtl8192e: Rename rtl8192_get_eeprom_size Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 019/102] staging: rtl8192e: Rename rtl8192_halt_adapter Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 031/102] staging: rtl8192e: Rename PHY_SetRtl8192eRfOff Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 002/102] staging: rtl8192e: Rename PHY_SetRF8256Bandwidth Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 023/102] staging: rtl8192e: Rename rtl8192_link_change Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 004/102] staging: rtl8192e: Rename PHY_SetRF8256OFDMTxPower Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 035/102] staging: rtl8192e: Rename rtl8192_phy_configmac Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 034/102] staging: rtl8192e: Rename rtl8192_phy_CheckIsLegalRFPath Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 014/102] staging: rtl8192e: Rename rtl8192e_start_beacon Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 009/102] staging: rtl8192e: Rename rtl8192_DisableInterrupt Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 007/102] staging: rtl8192e: Rename rtl8192_AllowAllDestAddr Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 028/102] staging: rtl8192e: Rename firmware_init_param Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200
  [PATCH 036/102] staging: rtl8192e: Rename rtl8192_phy_ConfigRFWithHeaderFile Mateusz Kulikowski <mateusz.kulikowski@gmail.com> - 2015-07-19 20:00 +0200

csiph-web