Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1184793

[PATCH v5 0/9] regulator: Merge max77843 into max77693

From Krzysztof Kozlowski <k.kozlowski.k@gmail.com>
Newsgroups linux.kernel
Subject [PATCH v5 0/9] regulator: Merge max77843 into max77693
Date 2015-07-15 15:10 +0200
Message-ID <pMuBH-8op-9@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Hi,

The patchset merges max77843 regulator driver into max77693.

The patchset touches multiple subsystems so I think the best way
would be to merge it through one tree. I already got acks from extcon,
input, leds, mfd and power maintainers.

If there are no objections then everything could go through regulator
tree.


Changes since v4
================
1. When adding new header inclusion (max77693-common.h) put
   in alphabetical order (suggested by Jacek).
2. Patch 4/9: Add Jacek Anaszewski's ack (leds).


Changes since v3
================
1. Patch 4/9: Fix missing includei n leds driver (leds-max77693.c).
2. Rebase on v4.2-rc2.


Changes since v2
================
1. Rebase on v4.2-rc1.
2. Add acks: Chanwoo Choi, Dmitry Torokhov, Lee Jones. Thanks!


Changes since v1
================
1. Drop patch "regulator: max77693: Use core code for charger's
   is_enabled" because Mark Brown picked it up.
2. Patch 2: remove some more old IRQ extcon stuff (suggested by Chanwoo
   Choi).
3. Patch 6: minor fixes over defines (suggested by Lee Jones).
4. Send last patch, previously it slipped during "git send-email".
5. Add acks obtained for v1. I still need more of them.


Rationale
=========
The recently added max77843 regulator driver is very similar to
its older brother: the max77693. Both devices provide two safeouts
and a charger.

The main difference is in charger's output capabilities and related
registry values.

With some code additions the max77693 regulator driver can support both
chipsets. This reduces overall code duplication and is a first step
toward integrating other drivers for these devices. I plan to merge
also input/haptic drivers.


Patchset description
====================
Patches 1-2 do various cleanup.
Patch 3 prepares max77694 regulator driver for supporting different
devices.
Patch 4 switches max77693 drivers to common state container.
Patch 5 updates max77843 drivers to common state container.
Patches 6-7 do final cleanup before merging.
Patches 8-9 do the merge of max77843 regulator into max77693.


Dependencies
============
Everything is bisectable but next patches depend on previous ones.
So probably the easiest way would be picking picked up by one
maintainer.


Best regards,
Krzysztof

Krzysztof Kozlowski (9):
  mfd/extcon: max77693: Remove unused extern declarations and
    max77693_dev members
  mfd: max77693: Store I2C device type as enum and add default unknown
  regulator: max77693: Support different register configurations
  drivers: max77693: Move state container to common header
  drivers: max77843: Switch to common max77693 state container
  mfd/extcon: max77693: Rename defines to allow inclusion with max77843
  mfd/extcon: max77843: Rename defines to allow inclusion with max77693
  regulator: max77693: Add support for MAX77843 device
  regulator: Remove the max77843 driver

 drivers/extcon/extcon-max77693.c     |  94 +++++++---------
 drivers/extcon/extcon-max77843.c     |  66 +++++++-----
 drivers/input/misc/max77693-haptic.c |   1 +
 drivers/input/misc/max77843-haptic.c |   3 +-
 drivers/leds/leds-max77693.c         |   1 +
 drivers/mfd/max77693.c               |  31 +++---
 drivers/mfd/max77843.c               |  20 ++--
 drivers/power/max77693_charger.c     |   1 +
 drivers/regulator/Kconfig            |  16 +--
 drivers/regulator/Makefile           |   1 -
 drivers/regulator/max77693.c         | 161 ++++++++++++++++++++++++----
 drivers/regulator/max77843.c         | 201 -----------------------------------
 include/linux/mfd/max77693-common.h  |  49 +++++++++
 include/linux/mfd/max77693-private.h | 134 +++++++++--------------
 include/linux/mfd/max77843-private.h | 174 ++++++++++++++----------------
 15 files changed, 433 insertions(+), 520 deletions(-)
 delete mode 100644 drivers/regulator/max77843.c
 create mode 100644 include/linux/mfd/max77693-common.h

-- 
2.1.4

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH v5 0/9] regulator: Merge max77843 into max77693 Krzysztof Kozlowski <k.kozlowski.k@gmail.com> - 2015-07-15 15:10 +0200
  [PATCH v5 1/9] mfd/extcon: max77693: Remove unused extern declarations and max77693_dev members Krzysztof Kozlowski <k.kozlowski.k@gmail.com> - 2015-07-15 15:10 +0200
  [PATCH v5 7/9] mfd/extcon: max77843: Rename defines to allow inclusion with max77693 Krzysztof Kozlowski <k.kozlowski.k@gmail.com> - 2015-07-15 15:10 +0200

csiph-web