Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1184392
| From | Juergen Borleis <jbe@pengutronix.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH] serial: mxs-auart: keep the AUART unit in reset state when not in use |
| Date | 2015-07-15 09:40 +0200 |
| Message-ID | <pMpsn-LG-47@gated-at.bofh.it> (permalink) |
| References | <pM9GW-3no-13@gated-at.bofh.it> <pMcls-76R-15@gated-at.bofh.it> |
| Organization | Pengutronix e.K. |
Hi Stefan, On Tuesday 14 July 2015 19:33:04 Stefan Wahren wrote: > [...] > > diff --git a/drivers/tty/serial/mxs-auart.c > > b/drivers/tty/serial/mxs-auart.c index 13cf773..f42b6ad 100644 > > --- a/drivers/tty/serial/mxs-auart.c > > +++ b/drivers/tty/serial/mxs-auart.c > > @@ -858,6 +858,30 @@ static void mxs_auart_reset(struct uart_port *u) > > writel(AUART_CTRL0_CLKGATE, u->membase + AUART_CTRL0_CLR); > > } > > > > +static void mxs_auart_do_reset(struct uart_port *u) > > i think the naming of this new function is too similiar to > mxs_auart_reset() and doesn't represent the exact behavior. How about > mxs_auart_keep_reset() or mxs_auart_gate()? Hmm, maybe mxs_auart_reset() should be renamed instead, because it terminates the reset to this unit and make it work (called when the driver's probe function is running). But okay, mxs_auart_keep_reset() names more what it really does. > [...] > > + udelay(10); > > The delay in mxs_auart_reset() has a value of 3 microseconds. Why not the > same here? Hmm, good question. And why 3 us? :) I'm going to change it to 3 us as well. > [...] > > + /* reset the unit if not aready done */ > > Just a typo: already? Ups. Yes. Will fix. Thanks! Juergen -- Pengutronix e.K. | Juergen Borleis | Industrial Linux Solutions | http://www.pengutronix.de/ | -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH] serial: mxs-auart: keep the AUART unit in reset state when not in use Juergen Borleis <jbe@pengutronix.de> - 2015-07-14 16:50 +0200 Re: [PATCH] serial: mxs-auart: keep the AUART unit in reset state when not in use Juergen Borleis <jbe@pengutronix.de> - 2015-07-15 09:40 +0200
csiph-web