Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1183932
| From | Jaegeuk Kim <jaegeuk@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [f2fs-dev] [PATCH RESEND] f2fs: maintain extent cache in separated file |
| Date | 2015-07-14 21:30 +0200 |
| Message-ID | <pMe3V-1e8-31@gated-at.bofh.it> (permalink) |
| References | <pJUsG-1nS-21@gated-at.bofh.it> <pK0eK-4WO-5@gated-at.bofh.it> <pM5tE-Va-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jul 14, 2015 at 06:10:50PM +0800, Chao Yu wrote:
> Hi Jaegeuk,
>
> > -----Original Message-----
> > From: Chao Yu [mailto:yuchaochina@hotmail.com]
> > Sent: Thursday, July 09, 2015 12:16 AM
> > To: 'Jaegeuk Kim'
> > Cc: linux-kernel@vger.kernel.org; linux-f2fs-devel@lists.sourceforge.net
> > Subject: Re: [f2fs-dev] [PATCH RESEND] f2fs: maintain extent cache in separated file
> >
> > >From 8956df8fa1a669e8e476456e4afe0eccd8174684 Mon Sep 17 00:00:00 2001
> > From: Chao Yu <chao2.yu@samsung.com>
> > Date: Wed, 8 Jul 2015 20:49:05 +0800
> > Subject: [PATCH] f2fs: maintain extent cache in separated file
> >
> > This patch moves extent cache related code from data.c into extent_cache.c
> > since extent cache is independent feature, and its codes are not relate to
> > others in data.c, it's better for us to maintain them in separated place.
> >
> > There is no functionality change, but several small coding style fixes
> > including:
> > * rename __drop_largest_extent to f2fs_drop_largest_extent for exporting;
> > * rename misspelled word 'untill' to 'until';
> > * remove unneeded 'return' in the end of f2fs_destroy_extent_tree().
> >
>
> I think commit 0b84ceec9891 ("f2fs: don't try to split extents shorter than
> F2FS_MIN_EXTENT_LEN") is conflict with commit 392a1c419916 ("f2fs: maintain
> extent cache in separated file"), and it's not well resolved in dev-test.
>
> in commit 392a1c419916 ("f2fs: maintain extent cache in separated file"):
>
> - if (dei.len > F2FS_MIN_EXTENT_LEN) {
>
> + if (dei.len > 1) {
Good catch.
Not a big deal, so I just resolved that in this patch. :)
Thanks,
>
> So how about merging this patch (f2fs: maintain extent cache in separated file)
> first, and then merge Fan's patch? because one line modification in extent_cache.c
> for fixing conflict seems much easier.
>
> BTW, I have already fixed the building error in this patch, you can directly
> use the last sent patch in this thread showed in below link. :)
>
> http://sourceforge.net/p/linux-f2fs/mailman/message/34277570/
>
> Thanks,
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [f2fs-dev] [PATCH RESEND] f2fs: maintain extent cache in separated file Jaegeuk Kim <jaegeuk@kernel.org> - 2015-07-14 21:30 +0200
csiph-web