Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1178357
| Path | csiph.com!aioe.org!bofh.it!news.nic.it!robomod |
|---|---|
| From | Sumit Saxena <sumit.saxena@avagotech.com> |
| Newsgroups | linux.kernel |
| Subject | RE: [PATCH] megaraid:Remove no longer required variable ret from the function megasas_sync_map_info |
| Date | Tue, 07 Jul 2015 13:10:01 +0200 |
| Message-ID | <pJyVb-4UD-5@gated-at.bofh.it> (permalink) |
| References | <pJwTn-3rP-13@gated-at.bofh.it> <pJwTn-3rP-11@gated-at.bofh.it> <pJxZ8-4kL-11@gated-at.bofh.it> |
| X-Original-To | Frans Klaver <fransklaver@gmail.com> |
| Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=avagotech.com; s=google; h=from:references:in-reply-to:mime-version:thread-index:date :message-id:subject:to:cc:content-type; bh=rH5XL9ZYqq6i/F6mNKJ+44RBK/rmFB60GWHobovDJaU=; b=vf/ScubF4NutNhMwKqkG4kvke4ya8idBGdrQqKNdXKN1cPiEwtoC5BxIAd1dPsljgJ 1pxIhcEhbuNymlrjNBJq62EAeqo0X0uucxFIK7VNP2CMSwNR4qOQ9eNVYCiICLo0cTA7 7p3VaQKFE00IgQOiNKorrqnFcWiWMlMWyzUSI= |
| X-Google-Dkim-Signature | v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:from:references:in-reply-to:mime-version :thread-index:date:message-id:subject:to:cc:content-type; bh=rH5XL9ZYqq6i/F6mNKJ+44RBK/rmFB60GWHobovDJaU=; b=jrPKhWmHRyDBkks64S6GAaLKDe0jrx2U+VmgmTQqhP8t7UmrmTH7egJNboPGv8+qNj MGTnYcN5ej7cs5H7E3Bel7i4o8QmeOMqbWS/YeMzz7pWecNaTEpUpUr30vqkqQE9SWxw 66dsyi97tjLuG2FLO5kxRbeBgeqaspSy4aUNTIihK1zl/kpbPSCOrNiN5ILa6ZonRotR Wvfg8N6uSRjWvT6dw+z1RArgSQjPajyr64jd9SPXadGgChPflwGLtvDmmeFzWBcJrbZX jMzk3bYok+OgpIvyiWBQ/B5GOFVO/DlvEdYZ0QE3B8sMroEm4NQ2BL2ZvOoX1YLyvdvw Q2PQ== |
| X-Gm-Message-State | ALoCoQndRuNWm6gW3fdY02IniPMBFcYTopwOeR5C0gE57X9dsiSjUxrGfG0pimlGgkOiq86QIbNX |
| X-Received | by 10.152.37.102 with SMTP id x6mr3446490laj.69.1436267093012; Tue, 07 Jul 2015 04:04:53 -0700 (PDT) |
| MIME-Version | 1.0 |
| X-Mailer | Microsoft Outlook 14.0 |
| Thread-Index | AQHLgkEAjI3Cq1+tb1T4NOhpsOm3ZQGpfuNEAnDsPkqduXD1EA== |
| Content-Type | text/plain; charset=UTF-8 |
| Sender | robomod@news.nic.it |
| List-ID | <linux-kernel.vger.kernel.org> |
| X-Mailing-List | linux-kernel@vger.kernel.org |
| Approved | robomod@news.nic.it |
| Lines | 86 |
| Organization | linux.* mail to news gateway |
| X-Original-Cc | Nicholas Krause <xerofoify@gmail.com>, Kashyap Desai <kashyap.desai@avagotech.com>, Uday Lingala <uday.lingala@avagotech.com>, JBottomley@odin.com, "PDL,MEGARAIDLINUX" <megaraidlinux.pdl@avagotech.com>, linux-scsi@vger.kernel.org, linux-kernel@vger.kernel.org |
| X-Original-Date | Tue, 7 Jul 2015 16:34:51 +0530 |
| X-Original-Message-ID | <c379ae3f27d2ffc8cdc6b9e3cf2b989a@mail.gmail.com> |
| X-Original-References | <1436199198-16415-1-git-send-email-xerofoify@gmail.com> <3970836098e4580f9199a91daa257c48@mail.gmail.com> <CAH6sp9P4giamp-AQ_Ec3g-x8dcSXhgZo-1Wt8R7P2-p0-8Bbsw@mail.gmail.com> |
| X-Original-Sender | linux-kernel-owner@vger.kernel.org |
| Xref | aioe.org linux.kernel:1178357 |
Show key headers only | View raw
> -----Original Message-----
> From: Frans Klaver [mailto:fransklaver@gmail.com]
> Sent: Tuesday, July 07, 2015 3:37 PM
> To: Sumit Saxena
> Cc: Nicholas Krause; Kashyap Desai; Uday Lingala; JBottomley@odin.com;
> PDL,MEGARAIDLINUX; linux-scsi@vger.kernel.org;
> linux-kernel@vger.kernel.org
> Subject: Re: [PATCH] megaraid:Remove no longer required variable ret from
> the
> function megasas_sync_map_info
>
> Can't seem to find the original, so here's a reply to the ack mail.
>
> On Tue, Jul 7, 2015 at 10:49 AM, Sumit Saxena <sumit.saxena@avagotech.com>
> wrote:
> > -----Original Message-----
> > From: Nicholas Krause [mailto:xerofoify@gmail.com]
> > Sent: Monday, July 06, 2015 9:43 PM
> > To: kashyap.desai@avagotech.com
> > Cc: sumit.saxena@avagotech.com; uday.lingala@avagotech.com;
> > JBottomley@odin.com; megaraidlinux.pdl@avagotech.com;
> > linux-scsi@vger.kernel.org; linux-kernel@vger.kernel.org
> > Subject: [PATCH] megaraid:Remove no longer required variable ret from
> > the function megasas_sync_map_info
>
> Isn't something shorter like
>
> [PATCH] megaraid: remove pointless variable
>
> much more readable?
>
>
> > This removes the no longer required variable ret due to this variable
> > only ever being used at the end of the function megasas_sync_map_info
> > without changing it's value from the orginal setting of its value to
> > zero due to this just remove the variable ret and just return the
> > value of zero directly here in order to indicate to the caller the
> > call to this function has run successfully without any non recoverable
> > issues.
>
> No interpunction?
>
>
> > Signed-off-by: Nicholas Krause <xerofoify@gmail.com>
> > ---
> > drivers/scsi/megaraid/megaraid_sas_fusion.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > b/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > index 46a0f8f..b5a8c65 100644
> > --- a/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > +++ b/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > @@ -836,7 +836,7 @@ megasas_get_map_info(struct megasas_instance
> > *instance) int megasas_sync_map_info(struct megasas_instance
> > *instance) {
> > - int ret = 0, i;
> > + int i;
> > struct megasas_cmd *cmd;
> > struct megasas_dcmd_frame *dcmd;
> > u32 size_sync_info, num_lds;
> > @@ -906,7 +906,7 @@ megasas_sync_map_info(struct megasas_instance
> > *instance)
> >
> > instance->instancet->issue_dcmd(instance, cmd);
> >
> > - return ret;
> > + return 0;
> > }
> >
> > Acked-by: Sumit Saxena <sumit.saxena@avagotech.com>
>
> This ack in an outlook-style response confused the hell out of me ;).
Sorry for confusion. I just got new laptop with default outlook settings so
last message sent was in outlook-style, configured it now.
Thanks,
Sumit
>
> Thanks,
> Frans
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH] megaraid:Remove no longer required variable ret from the function megasas_sync_map_info Frans Klaver <fransklaver@gmail.com> - 2015-07-07 12:10 +0200 RE: [PATCH] megaraid:Remove no longer required variable ret from the function megasas_sync_map_info Sumit Saxena <sumit.saxena@avagotech.com> - 2015-07-07 13:10 +0200
csiph-web