Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1175101
| From | "Kirill A. Shutemov" <kirill@shutemov.name> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 05/11] mm: debug: dump page into a string rather than directly on screen |
| Date | 2015-07-01 11:00 +0200 |
| Message-ID | <pHm25-2Wc-1@gated-at.bofh.it> (permalink) |
| References | <pq4XD-6ml-3@gated-at.bofh.it> <pq4XE-6ml-15@gated-at.bofh.it> <pHdia-59-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, Jun 30, 2015 at 04:35:45PM -0700, David Rientjes wrote:
> I do understand the problem with the current VM_BUG_ON_PAGE() and
> VM_BUG_ON_VMA() stuff, and it compels me to ask about just going back to
> the normal
>
> VM_BUG_ON(cond);
>
> coupled with dump_page(), dump_vma(), dump_whatever(). It all seems so
> much simpler to me.
Is there a sensible way to couple them? I don't see much, except opencode
VM_BUG_ON():
if (IS_ENABLED(CONFIG_DEBUG_VM) && cond) {
dump_page(...);
dump_vma(...);
dump_whatever();
BUG();
}
That's too verbose to me to be usable.
BTW, I also tried[1] to solve this problem too, but people doesn't like
either.
[1] http://lkml.kernel.org/g/1412163121-4295-1-git-send-email-kirill.shutemov@linux.intel.com
--
Kirill A. Shutemov
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
Re: [PATCH 05/11] mm: debug: dump page into a string rather than directly on screen "Kirill A. Shutemov" <kirill@shutemov.name> - 2015-07-01 11:00 +0200
csiph-web