Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1169845
| From | Umesh Tiwari <umesh.t@samsung.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH] ftrace: correct the counter increment for trace_buffer data |
| Date | 2015-06-22 13:30 +0200 |
| Message-ID | <pE85j-2e7-3@gated-at.bofh.it> (permalink) |
| Organization | linux.* mail to news gateway |
In ftrace_dump, for disabling buffer, iter.tr->trace_buffer.data is used.
But for enabling, iter.trace_buffer->data is used.
Even though, both point to same buffer, for readability, same convention
should be used.
Signed-off-by: Umesh Tiwari <umesh.t@samsung.com>
---
kernel/trace/trace.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
index 62c6506..e6dc9c3 100644
--- a/kernel/trace/trace.c
+++ b/kernel/trace/trace.c
@@ -6698,7 +6698,7 @@ void ftrace_dump(enum ftrace_dump_mode oops_dump_mode)
trace_init_global_iter(&iter);
for_each_tracing_cpu(cpu) {
- atomic_inc(&per_cpu_ptr(iter.tr->trace_buffer.data, cpu)->disabled);
+ atomic_inc(&per_cpu_ptr(iter.trace_buffer->data, cpu)->disabled);
}
old_userobj = trace_flags & TRACE_ITER_SYM_USEROBJ;
--
1.7.9.5
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next | Find similar | Unroll thread
[PATCH] ftrace: correct the counter increment for trace_buffer data Umesh Tiwari <umesh.t@samsung.com> - 2015-06-22 13:30 +0200
csiph-web