Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1164484

Re: [PATCH] staging: comedi: cb_pcimdas: fix handlers for DI and DO subdevices

From Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Newsgroups linux.kernel
Subject Re: [PATCH] staging: comedi: cb_pcimdas: fix handlers for DI and DO subdevices
Date 2015-06-13 02:10 +0200
Message-ID <pAHbj-4H5-5@gated-at.bofh.it> (permalink)
References <pAzdM-1hh-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Fri, Jun 12, 2015 at 04:37:41PM +0100, Ian Abbott wrote:
> Normally, low-level Comedi drivers set an `insn_bits` handler for
> digital input (DI), digital output (DO) and digital input/output (DIO)
> subdevice types to handle normal reading and writing of digital
> channels.  The "cb_pcimdas" driver currently has an `insn_read` handler
> for the DI subdevice and an `insn_write` handler for the DO subdevice.
> However, the actual handler functions `cb_pcimdas_di_insn_read()` and
> `cb_pcimdas_do_insn_write()` are written to behave like `insn_bits`
> handlers.  Something's wrong there!  To fix it, set the functions as
> `insn_bits` handlers and rename them for consistency.
> 
> Fixes: e56d03dee14a ("staging: comedi: cb_pcimdas: add main connector digital input/output")
> Signed-off-by: Ian Abbott <abbotti@mev.co.uk>
> ---
> I left the "Fixes:" line non-line-wrapped.  Is that the correct thing to
> do?

Sure, that's fine, thanks.

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | Next | Find similar | Unroll thread


Thread

Re: [PATCH] staging: comedi: cb_pcimdas: fix handlers for DI and DO  subdevices Greg Kroah-Hartman <gregkh@linuxfoundation.org> - 2015-06-13 02:10 +0200

csiph-web