Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1164444

[PATCH 04/17] x86/tsc: Remove the rdtscp and rdtscpll macros

From Andy Lutomirski <luto@kernel.org>
Newsgroups linux.kernel
Subject [PATCH 04/17] x86/tsc: Remove the rdtscp and rdtscpll macros
Date 2015-06-13 01:50 +0200
Message-ID <pAGRY-44S-31@gated-at.bofh.it> (permalink)
References <pAGRX-44S-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


They have no users.  Leave native_read_tscp, which seems potentially
useful despite also having no callers.

Signed-off-by: Andy Lutomirski <luto@kernel.org>
---
 arch/x86/include/asm/msr.h      |  9 ---------
 arch/x86/include/asm/paravirt.h | 16 ----------------
 2 files changed, 25 deletions(-)

diff --git a/arch/x86/include/asm/msr.h b/arch/x86/include/asm/msr.h
index 8826780c80dd..8612b0086933 100644
--- a/arch/x86/include/asm/msr.h
+++ b/arch/x86/include/asm/msr.h
@@ -190,17 +190,8 @@ do {							\
 
 #define rdpmcl(counter, val) ((val) = native_read_pmc(counter))
 
-#define rdtscp(low, high, aux)					\
-do {                                                            \
-	unsigned long long _val = native_read_tscp(&(aux));     \
-	(low) = (u32)_val;                                      \
-	(high) = (u32)(_val >> 32);                             \
-} while (0)
-
-#define rdtscpll(val, aux) (val) = native_read_tscp(&(aux))
 
 #endif	/* !CONFIG_PARAVIRT */
-
 /*
  * 64-bit version of wrmsr_safe():
  */
diff --git a/arch/x86/include/asm/paravirt.h b/arch/x86/include/asm/paravirt.h
index 5dd49e3f472e..a5de6bd8abcc 100644
--- a/arch/x86/include/asm/paravirt.h
+++ b/arch/x86/include/asm/paravirt.h
@@ -218,22 +218,6 @@ static inline unsigned long long paravirt_rdtscp(unsigned int *aux)
 	return PVOP_CALL1(u64, pv_cpu_ops.read_tscp, aux);
 }
 
-#define rdtscp(low, high, aux)				\
-do {							\
-	int __aux;					\
-	unsigned long __val = paravirt_rdtscp(&__aux);	\
-	(low) = (u32)__val;				\
-	(high) = (u32)(__val >> 32);			\
-	(aux) = __aux;					\
-} while (0)
-
-#define rdtscpll(val, aux)				\
-do {							\
-	unsigned long __aux; 				\
-	val = paravirt_rdtscp(&__aux);			\
-	(aux) = __aux;					\
-} while (0)
-
 static inline void paravirt_alloc_ldt(struct desc_struct *ldt, unsigned entries)
 {
 	PVOP_VCALL2(pv_cpu_ops.alloc_ldt, ldt, entries);
-- 
2.4.2

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/17] x86/tsc: Clean up rdtsc helpers Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 13/17] x86/tsc: Rename native_read_tsc() to rdtsc_unordered() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 16/17] x86/tsc: Use rdtsc_ordered() in check_tsc_warp() and drop extra barriers Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 04/17] x86/tsc: Remove the rdtscp and rdtscpll macros Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 02/17] x86/msr/kvm: Remove vget_cycles() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 14/17] x86/tsc: Move rdtsc_barrier() and rename it to barrier_before_rdtsc() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 15/17] x86: Add rdtsc_ordered() and use it in trivial call sites Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 10/17] input/joystick/analog: Switch from rdtscl() to native_read_tsc() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 07/17] x86/cpu/amd: Use the full 64-bit TSC to detect the 2.6.2 bug Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 11/17] drivers/input/gameport: Replace rdtscl() with native_read_tsc() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 17/17] x86/tsc: In read_tsc, use rdtsc_ordered() instead of get_cycles() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 09/17] staging/lirc_serial: Remove TSC-based timing Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 16/17] x86/tsc: Use rdtsc_unordered() in check_tsc_warp() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 12/17] x86/tsc: Remove rdtscl() Andy Lutomirski <luto@kernel.org> - 2015-06-13 01:50 +0200
  [PATCH 03/17] x86/tsc: Replace rdtscll with native_read_tsc Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200
  [PATCH 01/17] x86/tsc: Inline native_read_tsc and remove __native_read_tsc Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200
  [PATCH 08/17] baycom_epp: Replace rdtscl() with native_read_tsc() Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200
  [PATCH 03/17] x86/tsc/paravirt: Remove the read_tsc and read_tscp paravirt hooks Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200
  [PATCH 05/17] x86/tsc: Remove the rdtscp and rdtscpll macros Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200
  [PATCH 06/17] x86/tsc: Use the full 64-bit tsc in tsc_delay Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200
  [PATCH 04/17] x86/tsc: Replace rdtscll with native_read_tsc Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200
  [PATCH 05/17] x86/tsc/paravirt: Remove the read_tsc and read_tscp paravirt hooks Andy Lutomirski <luto@kernel.org> - 2015-06-13 02:00 +0200

csiph-web