Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #203947 > unrolled thread
| Started by | Andrea Borgia <andrea@borgia.bo.it> |
|---|---|
| First post | 2019-01-04 11:10 +0100 |
| Last post | 2019-01-04 13:40 +0100 |
| Articles | 8 — 3 participants |
Back to article view | Back to linux.debian.user
odd resolver issue Andrea Borgia <andrea@borgia.bo.it> - 2019-01-04 11:10 +0100
Re: odd resolver issue john doe <johndoe65534@mail.com> - 2019-01-04 11:20 +0100
Re: odd resolver issue Andrea Borgia <andrea@borgia.bo.it> - 2019-01-04 12:50 +0100
Re: odd resolver issue Martin <keine-eile@online.de> - 2019-01-04 11:50 +0100
Re: odd resolver issue Andrea Borgia <andrea@borgia.bo.it> - 2019-01-04 12:50 +0100
Re: odd resolver issue Andrea Borgia <andrea@borgia.bo.it> - 2019-01-04 13:10 +0100
Re: odd resolver issue Martin <keine-eile@online.de> - 2019-01-04 13:20 +0100
Re: odd resolver issue Andrea Borgia <andrea@borgia.bo.it> - 2019-01-04 13:40 +0100
| From | Andrea Borgia <andrea@borgia.bo.it> |
|---|---|
| Date | 2019-01-04 11:10 +0100 |
| Subject | odd resolver issue |
| Message-ID | <xcuAp-7ro-1@gated-at.bofh.it> |
Hi. Two systems on same LAN, let's call them A and B, with domain "localdomain". Identical /etc/resolv.conf (generated by NetworkManager), including a "search localdomain" line. Identical /etc/hosts with only localhost aliases in it. From A: ping shortnameB (OK) ping shortnameB.localdomain (OK) From B: ping shortnameA (failure?!?!?) ping shortnameA.localdomain (OK) Both had DNSSEC turned off because of an annoying bug: https://github.com/systemd/systemd/issues/10579 B is freshly booted and both are current "testing" setups. What else should I check? Thanks, Andrea.
[toc] | [next] | [standalone]
| From | john doe <johndoe65534@mail.com> |
|---|---|
| Date | 2019-01-04 11:20 +0100 |
| Message-ID | <xcuK6-7uH-19@gated-at.bofh.it> |
| In reply to | #203947 |
On 1/4/2019 11:07 AM, Andrea Borgia wrote: > Hi. > > > Two systems on same LAN, let's call them A and B, with domain > "localdomain". > Identical /etc/resolv.conf (generated by NetworkManager), including a > "search localdomain" line. > Identical /etc/hosts with only localhost aliases in it. > > From A: > ping shortnameB (OK) > ping shortnameB.localdomain (OK) > > From B: > ping shortnameA (failure?!?!?) > ping shortnameA.localdomain (OK) > > Both had DNSSEC turned off because of an annoying bug: > https://github.com/systemd/systemd/issues/10579 > > B is freshly booted and both are current "testing" setups. > > What else should I check? > Are the dhcp server's options the same for both clients (identical lease)? -- John Doe
[toc] | [prev] | [next] | [standalone]
| From | Andrea Borgia <andrea@borgia.bo.it> |
|---|---|
| Date | 2019-01-04 12:50 +0100 |
| Message-ID | <xcw9c-8da-3@gated-at.bofh.it> |
| In reply to | #203948 |
Il 04/01/19 11:16, john doe ha scritto: > Are the dhcp server's options the same for both clients (identical lease)? Assuming OpenWRT isn't doing something fancy behind my back, the config entries look identical: (this is global, so same lease) config dhcp 'lan' option interface 'lan' option start '2' option limit '100' option leasetime '24h' option dhcpv6 'server' option ra 'server' option ra_management '1' option force '1' (host A) config host option name 'shortnameA' option ip 'x.y.z.4' option mac 'macA' (host B) config host option name 'shortnameB' option ip 'x.y.z.8' option mac 'wifimacB eth0macB' (this is so that I can use either wifi or ethernet and still get the same address, which always worked fine since I never use both) Given that /etc/resolv.conf is the same on both systems, as generated by NetworkManager, I would say the dhcp options are indeed just fine. The fun thing is that this issue is new: it used to be that the first ping always failed (because of the DNSSEC bug I linked) but then it would work, regardless of which form, short or fqdn. Once I disabled DNSSEC, it would just work, always. Now, it makes no difference whether I use wifi or cable: ping to shortname fails, to fqdn works. Of course, /etc/systemd/resolved.conf is the same: both have DNSSEC=off as the only difference with respect to the file as shipped.
[toc] | [prev] | [next] | [standalone]
| From | Martin <keine-eile@online.de> |
|---|---|
| Date | 2019-01-04 11:50 +0100 |
| Message-ID | <xcvd7-7Er-1@gated-at.bofh.it> |
| In reply to | #203947 |
Am 04.01.19 um 11:07 schrieb Andrea Borgia: > Hi. > > > Two systems on same LAN, let's call them A and B, with domain "localdomain". > Identical /etc/resolv.conf (generated by NetworkManager), including a "search localdomain" line. Add a 'domain localdomain'. When using dhcp and this option is missing, have a look at /etc/dhcp/dhclient.conf. > Identical /etc/hosts with only localhost aliases in it. > > From A: > ping shortnameB (OK) > ping shortnameB.localdomain (OK) > > From B: > ping shortnameA (failure?!?!?) > ping shortnameA.localdomain (OK) > > Both had DNSSEC turned off because of an annoying bug: > https://github.com/systemd/systemd/issues/10579 > > B is freshly booted and both are current "testing" setups. > > What else should I check? > > > Thanks, > Andrea. >
[toc] | [prev] | [next] | [standalone]
| From | Andrea Borgia <andrea@borgia.bo.it> |
|---|---|
| Date | 2019-01-04 12:50 +0100 |
| Message-ID | <xcw9c-8da-9@gated-at.bofh.it> |
| In reply to | #203952 |
Il 04/01/19 11:47, Martin ha scritto: > Add a 'domain localdomain'. To resolv.conf? Let me figure out first how to get N-M to do that, then there's always the question of the different behaviour. > When using dhcp and this option is missing, have a look at /etc/dhcp/dhclient.conf. The files are identical on both systems. Why is one of them consistently failing and the other one consistently working? Off to see what N-M can be told to do...
[toc] | [prev] | [next] | [standalone]
| From | Andrea Borgia <andrea@borgia.bo.it> |
|---|---|
| Date | 2019-01-04 13:10 +0100 |
| Message-ID | <xcwsy-7p-33@gated-at.bofh.it> |
| In reply to | #203956 |
Il 04/01/19 12:43, Andrea Borgia ha scritto: > Il 04/01/19 11:47, Martin ha scritto: >> Add a 'domain localdomain'. > To resolv.conf? Let me figure out first how to get N-M to do that, then > there's always the question of the different behaviour. Did a side-by-side comparison of the output of "nmcli con show", only two differences: * IPv6 was disabled on the failing host: enabled, restarted the connection, no changes (as expected) * the failing host has a 169.254.0.0 route, not relevant I'd say. Puzzling...
[toc] | [prev] | [next] | [standalone]
| From | Martin <keine-eile@online.de> |
|---|---|
| Date | 2019-01-04 13:20 +0100 |
| Message-ID | <xcwCd-aC-1@gated-at.bofh.it> |
| In reply to | #203956 |
Am 04.01.19 um 12:43 schrieb Andrea Borgia: > Il 04/01/19 11:47, Martin ha scritto: > > >> Add a 'domain localdomain'. > > To resolv.conf? Yes. > Let me figure out first how to get N-M to do that, then there's always the question of the different behaviour. > > >> When using dhcp and this option is missing, have a look at /etc/dhcp/dhclient.conf. > > The files are identical on both systems. Why is one of them consistently failing and the other one consistently working? <sarcasm> Because networkmanager knows everything better than anyone else. </sacasm> I have no domain record in resolv.conf as well, but my router is running a kind of dnsmasq. Fixed it there, once and for all. > Off to see what N-M can be told to do... >
[toc] | [prev] | [next] | [standalone]
| From | Andrea Borgia <andrea@borgia.bo.it> |
|---|---|
| Date | 2019-01-04 13:40 +0100 |
| Message-ID | <xcwVz-hl-1@gated-at.bofh.it> |
| In reply to | #203961 |
Il 04/01/19 13:19, Martin ha scritto: > <sarcasm> > Because networkmanager knows everything better than anyone else. > </sacasm> I hear you, I hear you :P However, in this specific case it turned out that the problem was /etc/nsswitch.conf working) hosts: files mdns4_minimal [NOTFOUND=return] dns failing) hosts: files mdns4_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns Thanks to everyone :) Now I just have to figure out how that came to be and which is the default configuration. Andrea.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.user
csiph-web