Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #208223 > unrolled thread
| Started by | Gene Heskett <gheskett@shentel.net> |
|---|---|
| First post | 2019-05-05 19:00 +0200 |
| Last post | 2019-05-06 22:00 +0200 |
| Articles | 20 on this page of 37 — 10 participants |
Back to article view | Back to linux.debian.user
apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-05 19:00 +0200
Re: apache2 missing a file, won't run. Ulf Volmer <u.volmer@u-v.de> - 2019-05-05 19:10 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-05 20:20 +0200
Re: apache2 missing a file, won't run. Kushal Kumaran <kushal@locationd.net> - 2019-05-05 21:20 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-05 23:20 +0200
Re: apache2 missing a file, won't run. <tomas@tuxteam.de> - 2019-05-06 09:20 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 16:40 +0200
Re: apache2 missing a file, won't run. Erik Christiansen <dvalin@internode.on.net> - 2019-05-06 09:20 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 16:30 +0200
Re: apache2 missing a file, won't run. Greg Wooledge <wooledg@eeg.ccf.org> - 2019-05-06 15:50 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 17:10 +0200
Re: apache2 missing a file, won't run. Brian <ad44@cityscape.co.uk> - 2019-05-06 17:30 +0200
Re: apache2 missing a file, won't run. Greg Wooledge <wooledg@eeg.ccf.org> - 2019-05-06 17:40 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 18:00 +0200
Re: apache2 missing a file, won't run. Dan Purgert <dan@djph.net> - 2019-05-06 20:00 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 23:20 +0200
Re: apache2 missing a file, won't run. Dan Purgert <dan@djph.net> - 2019-05-07 11:40 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-07 15:00 +0200
Re: apache2 missing a file, won't run. Dan Purgert <dan@djph.net> - 2019-05-07 15:40 +0200
Re: apache2 missing a file, won't run. Brian <ad44@cityscape.co.uk> - 2019-05-07 18:40 +0200
Re: apache2 missing a file, won't run. Dan Purgert <dan@djph.net> - 2019-05-07 21:00 +0200
Re: apache2 missing a file, won't run. mick crane <mick.crane@gmail.com> - 2019-05-07 21:10 +0200
Re: apache2 missing a file, won't run. Brian <ad44@cityscape.co.uk> - 2019-05-07 21:40 +0200
Re: apache2 missing a file, won't run. Brian <ad44@cityscape.co.uk> - 2019-05-07 21:40 +0200
Re: apache2 missing a file, won't run. Dan Purgert <dan@djph.net> - 2019-05-08 20:20 +0200
Re: apache2 missing a file, won't run. Brian <ad44@cityscape.co.uk> - 2019-05-09 00:00 +0200
Re: apache2 missing a file, won't run. Dan Purgert <dan@djph.net> - 2019-05-09 13:50 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-08 01:00 +0200
Re: apache2 missing a file, won't run. Brian <ad44@cityscape.co.uk> - 2019-05-06 18:00 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 20:20 +0200
Re: apache2 missing a file, won't run. Ulf Volmer <u.volmer@u-v.de> - 2019-05-06 21:20 +0200
Re: apache2 missing a file, won't run. Dan Ritter <dsr@randomstring.org> - 2019-05-06 22:10 +0200
Re: apache2 missing a file, won't run. Ulf Volmer <u.volmer@u-v.de> - 2019-05-06 22:30 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 23:30 +0200
Re: apache2 missing a file, won't run. Brian <ad44@cityscape.co.uk> - 2019-05-07 10:50 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 23:30 +0200
Re: apache2 missing a file, won't run. Gene Heskett <gheskett@shentel.net> - 2019-05-06 22:00 +0200
Page 1 of 2 [1] 2 Next page →
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-05 19:00 +0200 |
| Subject | apache2 missing a file, won't run. |
| Message-ID | <xUsEx-32G-1@gated-at.bofh.it> |
Greetings all; So web page in the sig is dark. Stretch install, from a custom iso the LCNC folks are testing, but the apache2 install was all pulled in with synaptic. No errors. As root; Service apache2 start, gets this from systemctl: May 05 12:49:20 coyote systemd[1]: Starting The Apache HTTP Server... May 05 12:49:20 coyote apachectl[20456]: apache2: Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/authz_default.load: Cannot load /usr/lib/apache2/modules/mod_authz_default.so May 05 12:49:20 coyote apachectl[20456]: Action 'start' failed. And indeed, there is no such module in that directory. Fix?? Thanks all; Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [next] | [standalone]
| From | Ulf Volmer <u.volmer@u-v.de> |
|---|---|
| Date | 2019-05-05 19:10 +0200 |
| Message-ID | <xUsOd-3lq-3@gated-at.bofh.it> |
| In reply to | #208223 |
On 05.05.19 18:56, Gene Heskett wrote: > Stretch install, from a custom iso the LCNC folks are testing, but the > apache2 install was all pulled in with synaptic. No errors. > > As root; > > Service apache2 start, gets this from systemctl: > > May 05 12:49:20 coyote systemd[1]: Starting The Apache HTTP Server... > May 05 12:49:20 coyote apachectl[20456]: apache2: Syntax error on line > 204 of /etc/apache2/apache2.conf: Syntax error on line 1 > of /etc/apache2/mods-enabled/authz_default.load: Cannot > load /usr/lib/apache2/modules/mod_authz_default.so > May 05 12:49:20 coyote apachectl[20456]: Action 'start' failed. mod_authz_default.so has been removed in apache 2.4: https://httpd.apache.org/docs/2.4/upgrading.html I guess you are trying to run a 2.2 config with a 2.4 apache. Best regards Ulf
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-05 20:20 +0200 |
| Message-ID | <xUtTX-3Yt-1@gated-at.bofh.it> |
| In reply to | #208224 |
On Sunday 05 May 2019 01:06:13 pm Ulf Volmer wrote: > On 05.05.19 18:56, Gene Heskett wrote: > > Stretch install, from a custom iso the LCNC folks are testing, but > > the apache2 install was all pulled in with synaptic. No errors. > > > > As root; > > > > Service apache2 start, gets this from systemctl: > > > > May 05 12:49:20 coyote systemd[1]: Starting The Apache HTTP > > Server... May 05 12:49:20 coyote apachectl[20456]: apache2: Syntax > > error on line 204 of /etc/apache2/apache2.conf: Syntax error on line > > 1 > > of /etc/apache2/mods-enabled/authz_default.load: Cannot > > load /usr/lib/apache2/modules/mod_authz_default.so > > May 05 12:49:20 coyote apachectl[20456]: Action 'start' failed. > > mod_authz_default.so has been removed in apache 2.4: > > https://httpd.apache.org/docs/2.4/upgrading.html > > I guess you are trying to run a 2.2 config with a 2.4 apache. > > Best regards > Ulf Now I am certifiably upset, this web page needs printed. This is a new install it took me 3 damned days just to get networking working as it was stuck on ipv6 only, denying me net access to anything on the otgher side of my router, and the nearest ipv6 support is a minimum of 100 miles away. So I am not in a good mood. And the only printer it detected was the printer I wanted to use, but it spit out about 50 pages of blank paper when I did. so I go back into localhost:631 to printers/admin/brother HL-2140 and click on modify to see if I can fix it, to be greeted by an advisory that sys I as first user, has no permissions to do anything. Now, since much of this is owned by root:root, and theres no provisions to use sud, what do I do except chown the whole subdir to me:me, do what I have to do, and change it all back, difficult remember since parts of it are owned by root:Lp So, and I fought with this problem in wheezy too but adding myself to some selected entries in /etc/group half fixed it. Meaning whenever it asked for a password, I changed the displayed username to me, and used my passwd, which worked about 99% of the time. But this is 2019, and now stretch, so what do I add, or edit into to /etc/cupsd.conf, here # Restrict access to the admin pages... <Location /admin> Order allow,deny </Location> To get me, the first user (#1000) not root, to do what I need to do to fix this and add about 4 other profiles, 3 for a huge tabloid capable brother and of course cups.pdf? Thanks all. Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | Kushal Kumaran <kushal@locationd.net> |
|---|---|
| Date | 2019-05-05 21:20 +0200 |
| Message-ID | <xUuQ1-4z1-5@gated-at.bofh.it> |
| In reply to | #208227 |
Gene Heskett <gheskett@shentel.net> writes: > On Sunday 05 May 2019 01:06:13 pm Ulf Volmer wrote: > >> On 05.05.19 18:56, Gene Heskett wrote: >> > Stretch install, from a custom iso the LCNC folks are testing, but >> > the apache2 install was all pulled in with synaptic. No errors. >> > >> > As root; >> > >> > Service apache2 start, gets this from systemctl: >> > >> > May 05 12:49:20 coyote systemd[1]: Starting The Apache HTTP >> > Server... May 05 12:49:20 coyote apachectl[20456]: apache2: Syntax >> > error on line 204 of /etc/apache2/apache2.conf: Syntax error on line >> > 1 >> > of /etc/apache2/mods-enabled/authz_default.load: Cannot >> > load /usr/lib/apache2/modules/mod_authz_default.so >> > May 05 12:49:20 coyote apachectl[20456]: Action 'start' failed. >> >> mod_authz_default.so has been removed in apache 2.4: >> >> https://httpd.apache.org/docs/2.4/upgrading.html >> >> I guess you are trying to run a 2.2 config with a 2.4 apache. >> >> Best regards >> Ulf > > Now I am certifiably upset, this web page needs printed. This is a new > install it took me 3 damned days just to get networking working as it > was stuck on ipv6 only, denying me net access to anything on the otgher > side of my router, and the nearest ipv6 support is a minimum of 100 > miles away. So I am not in a good mood. > > And the only printer it detected was the printer I wanted to use, but it > spit out about 50 pages of blank paper when I did. so I go back into > localhost:631 to printers/admin/brother HL-2140 and click on modify to > see if I can fix it, to be greeted by an advisory that sys I as first > user, has no permissions to do anything. > > Now, since much of this is owned by root:root, and theres no provisions > to use sud, what do I do except chown the whole subdir to me:me, do what > I have to do, and change it all back, difficult remember since parts of > it are owned by root:Lp > > So, and I fought with this problem in wheezy too but adding myself to > some selected entries in /etc/group half fixed it. Meaning whenever it > asked for a password, I changed the displayed username to me, and used > my passwd, which worked about 99% of the time. > > But this is 2019, and now stretch, so what do I add, or edit into > to /etc/cupsd.conf, here > > # Restrict access to the admin pages... > <Location /admin> > Order allow,deny > </Location> > > To get me, the first user (#1000) not root, to do what I need to do to > fix this and add about 4 other profiles, 3 for a huge tabloid capable > brother and of course cups.pdf? > This has nothing to do with the apache2 error you mentioned earlier. To do printer administration using the web interface, add yourself to the lpadmin group. When the web interface asks for credentials, put your own username and password. https://wiki.debian.org/PrintQueuesCUPS#webinterface -- regards, kushal
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-05 23:20 +0200 |
| Message-ID | <xUwI9-5HK-3@gated-at.bofh.it> |
| In reply to | #208231 |
On Sunday 05 May 2019 03:12:40 pm Kushal Kumaran wrote: > Gene Heskett <gheskett@shentel.net> writes: > > On Sunday 05 May 2019 01:06:13 pm Ulf Volmer wrote: > >> On 05.05.19 18:56, Gene Heskett wrote: > >> > Stretch install, from a custom iso the LCNC folks are testing, > >> > but the apache2 install was all pulled in with synaptic. No > >> > errors. > >> > > >> > As root; > >> > > >> > Service apache2 start, gets this from systemctl: > >> > > >> > May 05 12:49:20 coyote systemd[1]: Starting The Apache HTTP > >> > Server... May 05 12:49:20 coyote apachectl[20456]: apache2: > >> > Syntax error on line 204 of /etc/apache2/apache2.conf: Syntax > >> > error on line 1 > >> > of /etc/apache2/mods-enabled/authz_default.load: Cannot > >> > load /usr/lib/apache2/modules/mod_authz_default.so > >> > May 05 12:49:20 coyote apachectl[20456]: Action 'start' failed. > >> > >> mod_authz_default.so has been removed in apache 2.4: > >> > >> https://httpd.apache.org/docs/2.4/upgrading.html > >> > >> I guess you are trying to run a 2.2 config with a 2.4 apache. > >> > >> Best regards > >> Ulf > > > > Now I am certifiably upset, this web page needs printed. This is a > > new install it took me 3 damned days just to get networking working > > as it was stuck on ipv6 only, denying me net access to anything on > > the otgher side of my router, and the nearest ipv6 support is a > > minimum of 100 miles away. So I am not in a good mood. > > > > And the only printer it detected was the printer I wanted to use, > > but it spit out about 50 pages of blank paper when I did. so I go > > back into localhost:631 to printers/admin/brother HL-2140 and click > > on modify to see if I can fix it, to be greeted by an advisory that > > sys I as first user, has no permissions to do anything. > > > > Now, since much of this is owned by root:root, and theres no > > provisions to use sud, what do I do except chown the whole subdir to > > me:me, do what I have to do, and change it all back, difficult > > remember since parts of it are owned by root:Lp > > > > So, and I fought with this problem in wheezy too but adding myself > > to some selected entries in /etc/group half fixed it. Meaning > > whenever it asked for a password, I changed the displayed username > > to me, and used my passwd, which worked about 99% of the time. > > > > But this is 2019, and now stretch, so what do I add, or edit into > > to /etc/cupsd.conf, here > > > > # Restrict access to the admin pages... > > <Location /admin> > > Order allow,deny > > </Location> > > > > To get me, the first user (#1000) not root, to do what I need to do > > to fix this and add about 4 other profiles, 3 for a huge tabloid > > capable brother and of course cups.pdf? > > This has nothing to do with the apache2 error you mentioned earlier. > In a roundabout way it does. I blame it on the extremely excessive security paranoia that pervades the linux environment and gets worse by the next release every time. > To do printer administration using the web interface, add yourself to > the lpadmin group. When the web interface asks for credentials, put > your own username and password. FYI I am a member of the lpadmin group. Whats next? reboot to make it take effect? That involves restarting at least 20 other things this machine does on a 24/7/365.25 basis. Not impossible but a bunch of drugery nonetheless. IOW since I am "it" till I fail to answer roll call, likely in the visible future since I'm already equipt with plastic yeys and a pacemaker and am presently 84 yo, lets swat this once and for all till then. You have made it very clear not to assign a pw to root, do everything with sudo. In which case lets make sudo work since its only used about 20% of the time now. From the cli TBE. But we've been configuring cups from localhost:631 for well over 15 years now, no one wants to try and remember all the arcane text phrases used with lpadmin to configure anything as complex as even a 100 dollar brother b&w laser printer. I have all the brother drivers here for both printers, the other is a brother MFC-J6920DW, which is found 4 times by lpinfo -l -v. But it has both a usb cable and a net cable at its own ip. > https://wiki.debian.org/PrintQueuesCUPS#webinterface I have this page visible in FF right now, and its typical for linux docs, it makes the assumption that everyone has what I assume is a group of env vars so it doesn't waste a crossed t or a dot over a lowercase i to explain just who or what @LOCAL or @ADMIN or @SYSTEM or @OWNER actually is. So lets define them so one can have an idea at least of who or what they represent. Once they are properly defined, maybe I can put them to some usefull purpose. At the end of the day, I want them to Just Work. So lets start with the denial even though I am a member of the lpadmin group. Thank you. Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | <tomas@tuxteam.de> |
|---|---|
| Date | 2019-05-06 09:20 +0200 |
| Message-ID | <xUG4N-3iI-1@gated-at.bofh.it> |
| In reply to | #208238 |
[Multipart message — attachments visible in raw view] — view raw
On Mon, May 06, 2019 at 05:12:55PM +1000, Erik Christiansen wrote: > On 05.05.19 17:16, Gene Heskett wrote: > > You have made it very clear not to assign a pw to root, do everything > > with sudo. > > That's just religion, Gene, promulgated to minimise queries and > complaints from people getting themselves into trouble. Not sure who's proselytizing here. Remember: all generalizations suck. Cheers -- t
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-06 16:40 +0200 |
| Message-ID | <xUMWB-7pR-1@gated-at.bofh.it> |
| In reply to | #208255 |
On Monday 06 May 2019 03:16:30 am tomas@tuxteam.de wrote: > On Mon, May 06, 2019 at 05:12:55PM +1000, Erik Christiansen wrote: > > On 05.05.19 17:16, Gene Heskett wrote: > > > You have made it very clear not to assign a pw to root, do > > > everything with sudo. > > > > That's just religion, Gene, promulgated to minimise queries and > > complaints from people getting themselves into trouble. > > Not sure who's proselytizing here. Remember: all generalizations > suck. > That they often do Tomas But thats not answering my question as to how to make apache2-2.4 run with 2.2 config files all over. Some one posted a link to the diffs I need to fix, but I've no clue where I book naked them because I have yet to convince the system to run FF when I click on a link. It insists on konquerer. And I have no clue where it stores its bookmarks, I can look at them, but those bookmarks I did save are nowhere to be found when I look at its bookmarks, sucks is much too mild a term. > Cheers > -- t Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | Erik Christiansen <dvalin@internode.on.net> |
|---|---|
| Date | 2019-05-06 09:20 +0200 |
| Message-ID | <xUG4N-3iI-3@gated-at.bofh.it> |
| In reply to | #208238 |
On 05.05.19 17:16, Gene Heskett wrote: > You have made it very clear not to assign a pw to root, do everything > with sudo. That's just religion, Gene, promulgated to minimise queries and complaints from people getting themselves into trouble. Like vaccination, it only needs 95% coverage to provide herd immunity. To avoid having to fuss with getting the sudo thing to actually work here, I still do a "su -" in a spare xterm, and leave the root session open for a while, till the current problem is sorted. To remind that more than ordinary user care is warranted in that xterm, in the event of leaving it open beyond short term memory, I put this in /root/.bashrc export PS1="\[\033[1;31m\]\u@\h:\W\$ \[\033[0;0m\]" to make root's prompt red, and declare itself as root. It takes more than a generalisation to alter my habits of more than 30 years. My take is: Use what works best for you, especially if you accept the consequences without complaint. But I figure I'm treading a parallel path to yours there. Erik
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-06 16:30 +0200 |
| Message-ID | <xUMMV-7mO-5@gated-at.bofh.it> |
| In reply to | #208256 |
On Monday 06 May 2019 03:12:55 am Erik Christiansen wrote: > On 05.05.19 17:16, Gene Heskett wrote: > > You have made it very clear not to assign a pw to root, do > > everything with sudo. > > That's just religion, Gene, promulgated to minimise queries and > complaints from people getting themselves into trouble. Like > vaccination, it only needs 95% coverage to provide herd immunity. To > avoid having to fuss with getting the sudo thing to actually work > here, I still do a "su -" in a spare xterm, and leave the root session > open for a while, till the current problem is sorted. > > To remind that more than ordinary user care is warranted in that > xterm, in the event of leaving it open beyond short term memory, I put > this in /root/.bashrc > > export PS1="\[\033[1;31m\]\u@\h:\W\$ \[\033[0;0m\]" > Thats a good reminder, so I "borrowed" it. > to make root's prompt red, and declare itself as root. > > It takes more than a generalisation to alter my habits of more than 30 > years. My take is: Use what works best for you, especially if you > accept the consequences without complaint. But I figure I'm treading a > parallel path to yours there. > > Erik Probably pretty close, :) Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | Greg Wooledge <wooledg@eeg.ccf.org> |
|---|---|
| Date | 2019-05-06 15:50 +0200 |
| Message-ID | <xUMae-6TT-9@gated-at.bofh.it> |
| In reply to | #208238 |
On Sun, May 05, 2019 at 05:16:04PM -0400, Gene Heskett wrote:
> FYI I am a member of the lpadmin group. Whats next? reboot to make it
> take effect?
Log out and back in to acquire the new privileges in your interactive
session.
However, in the case of CUPS via loopback HTTP, I don't know whether
that's actually required. The CUPS daemon may take the privileges
directly from the /etc/{passwd,group} files.
> You have made it very clear not to assign a pw to root, do everything
> with sudo.
Bunk. You can still do things normally. In fact, normal (root having
a password) is still the default in Debian, insofar as anything is.
Also, having a root password makes it possible to login in single user
mode when there's a file system problem. Good luck with that under an
Ubuntu-style (sudo only) setup.
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-06 17:10 +0200 |
| Message-ID | <xUNpD-7Pj-7@gated-at.bofh.it> |
| In reply to | #208273 |
On Monday 06 May 2019 09:43:16 am Greg Wooledge wrote:
> On Sun, May 05, 2019 at 05:16:04PM -0400, Gene Heskett wrote:
> > FYI I am a member of the lpadmin group. Whats next? reboot to make
> > it take effect?
>
> Log out and back in to acquire the new privileges in your interactive
> session.
>
> However, in the case of CUPS via loopback HTTP, I don't know whether
> that's actually required. The CUPS daemon may take the privileges
> directly from the /etc/{passwd,group} files.
>
> > You have made it very clear not to assign a pw to root, do
> > everything with sudo.
>
> Bunk. You can still do things normally. In fact, normal (root having
> a password) is still the default in Debian, insofar as anything is.
>
I've run 4 wheezy installs here for several years, and have never had a
root pw set.
> Also, having a root password makes it possible to login in single user
> mode when there's a file system problem. Good luck with that under an
> Ubuntu-style (sudo only) setup.
A problem I have not had since ext4. But now I'm getting touchy about it
because amanda will not build on stretch. So I've no backups. Using the
stretch version is a huge backup, to 3.3.9 when my stuff is setup to
wrap 3.5.1. And even 3.5.1 can be as buggy as august roadkill that 4
days old. Amanda I'm sorry to say, has been sold to Betsol, who may have
to be sued for putting gpl'd code behind a paywall.
I did get the sound working, so now my list of stretch don't works is a
little shorter. My next step is to edit my .procmailrc and disable the
calls to clamscan as its occasionally locking up at 100%.
Doing that I logged a strange message in the term screen:
gene@coyote:~$ geany .procmailrc
** (geany:17281): WARNING **: Couldn't register with accessibility bus:
Did not receive a reply. Possible causes include: the remote application
did not send a reply, the message bus security policy blocked the reply,
the reply timeout expired, or the network connection was broken.
What the heck is that all about??? And how do I fix that??
Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | Brian <ad44@cityscape.co.uk> |
|---|---|
| Date | 2019-05-06 17:30 +0200 |
| Message-ID | <xUNIZ-7W1-11@gated-at.bofh.it> |
| In reply to | #208273 |
On Mon 06 May 2019 at 09:43:16 -0400, Greg Wooledge wrote:
> On Sun, May 05, 2019 at 05:16:04PM -0400, Gene Heskett wrote:
> > FYI I am a member of the lpadmin group. Whats next? reboot to make it
> > take effect?
>
> Log out and back in to acquire the new privileges in your interactive
> session.
Indeed. It's standard procedure when a user has been added to a group.
> However, in the case of CUPS via loopback HTTP, I don't know whether
> that's actually required. The CUPS daemon may take the privileges
> directly from the /etc/{passwd,group} files.
It is required and conspicuously documented for all users, including
experienced ones, if they can be bothered to do read it. For example,
in the cups README.Debian.
'Administration' is where you need to be to set up a local print queue.
At some point you will be required to authenticate. A User Name of 'root'
and root's password is always acceptable. Any other user must be a member
of the lpadmin group.
--
Brian.
[toc] | [prev] | [next] | [standalone]
| From | Greg Wooledge <wooledg@eeg.ccf.org> |
|---|---|
| Date | 2019-05-06 17:40 +0200 |
| Message-ID | <xUNSF-7Zj-3@gated-at.bofh.it> |
| In reply to | #208292 |
On Mon, May 06, 2019 at 04:24:45PM +0100, Brian wrote:
> On Mon 06 May 2019 at 09:43:16 -0400, Greg Wooledge wrote:
> > Log out and back in to acquire the new privileges in your interactive
> > session.
> >
> > However, in the case of CUPS via loopback HTTP, I don't know whether
> > that's actually required. The CUPS daemon may take the privileges
> > directly from the /etc/{passwd,group} files.
>
> It is required and conspicuously documented for all users, including
> experienced ones, if they can be bothered to do read it. For example,
> in the cups README.Debian.
>
> 'Administration' is where you need to be to set up a local print queue.
> At some point you will be required to authenticate. A User Name of 'root'
> and root's password is always acceptable. Any other user must be a member
> of the lpadmin group.
I don't see any part of that paragraph that says whether you have to log
out and back in, between adding yourself to the lpadmin group and using
the CUPS web interface.
I've only ever used root for this, so I don't know from experience either.
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-06 18:00 +0200 |
| Message-ID | <xUOc1-86w-3@gated-at.bofh.it> |
| In reply to | #208293 |
On Monday 06 May 2019 11:33:33 am Greg Wooledge wrote:
> On Mon, May 06, 2019 at 04:24:45PM +0100, Brian wrote:
> > On Mon 06 May 2019 at 09:43:16 -0400, Greg Wooledge wrote:
> > > Log out and back in to acquire the new privileges in your
> > > interactive session.
> > >
> > > However, in the case of CUPS via loopback HTTP, I don't know
> > > whether that's actually required. The CUPS daemon may take the
> > > privileges directly from the /etc/{passwd,group} files.
> >
> > It is required and conspicuously documented for all users, including
> > experienced ones, if they can be bothered to do read it. For
> > example, in the cups README.Debian.
> >
> > 'Administration' is where you need to be to set up a local print
> > queue. At some point you will be required to authenticate. A User
> > Name of 'root' and root's password is always acceptable. Any other
> > user must be a member of the lpadmin group.
>
> I don't see any part of that paragraph that says whether you have to
> log out and back in, between adding yourself to the lpadmin group and
> using the CUPS web interface.
>
Logged out no, started a new konsole and ran ff from it yes. Managed to
get the little b&w laser working, but a 2 year old 11x17 MFC? Won't
configure, missing file although the latest driver kit from brother is
installed, so I find I have a nearly $700 scanner/copier/printer thats
been discontinued! And they've blocked or removed any access to the old
files. Thats generated a nastygram to brother, its a 2 year old
printer.
> I've only ever used root for this, so I don't know from experience
> either.
Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | Dan Purgert <dan@djph.net> |
|---|---|
| Date | 2019-05-06 20:00 +0200 |
| Message-ID | <xUQ4a-Ud-3@gated-at.bofh.it> |
| In reply to | #208296 |
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA256 Gene Heskett wrote: > [...] > Logged out no, started a new konsole and ran ff from it yes. Managed to > get the little b&w laser working, but a 2 year old 11x17 MFC? Won't > configure, missing file although the latest driver kit from brother is > installed, so I find I have a nearly $700 scanner/copier/printer thats > been discontinued! And they've blocked or removed any access to the old > files. Thats generated a nastygram to brother, its a 2 year old > printer. Which printer was that? Don't forget that some of their printers require multiarch / i386 in order for the pre-processor to run properly. -----BEGIN PGP SIGNATURE----- iQEzBAEBCAAdFiEEBcqaUD8uEzVNxUrujhHd8xJ5ooEFAlzQcvsACgkQjhHd8xJ5 ooHmNQf/Uq3RzmT9v3l3XHBOnFDcXnlf0ngeBbSnr6R5OWZxyg/1+1y9HGoCYtn4 QdH1XxLsTEE/l2iFPN1r0p2NyGSPqOBlF2zPU7sXNPn7REypmyzILAI9kGRuvF8w AlykCSxhTdDhMGz85hPyBd8/EezeYNCTK+sC375r2RDiaaYS/onv5T4Pd9LB4IFi sgocvD8nmK4zA5Oi8lXRL4/p2hB2RP76VJigfMla8dKbDiJ31S+RIUJ0wwUa7De3 wmDwliQtnC4oP9fIa2bOhSZCz38cJ7LTbWAa5XzbLhNd66V0IIU1Gqnw/9lVT8Yq ZfIHa+Gd8oYHKu9EODTcBmrRgufUSg== =AXiT -----END PGP SIGNATURE----- -- |_|O|_| |_|_|O| Github: https://github.com/dpurgert |O|O|O| PGP: 05CA 9A50 3F2E 1335 4DC5 4AEE 8E11 DDF3 1279 A281
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-06 23:20 +0200 |
| Message-ID | <xUTbH-30y-3@gated-at.bofh.it> |
| In reply to | #208305 |
On Monday 06 May 2019 01:46:36 pm Dan Purgert wrote: > Gene Heskett wrote: > > [...] > > Logged out no, started a new konsole and ran ff from it yes. Managed > > to get the little b&w laser working, but a 2 year old 11x17 MFC? > > Won't configure, missing file although the latest driver kit from > > brother is installed, so I find I have a nearly $700 > > scanner/copier/printer thats been discontinued! And they've blocked > > or removed any access to the old files. Thats generated a nastygram > > to brother, its a 2 year old printer. > > Which printer was that? Don't forget that some of their printers > require multiarch / i386 in order for the pre-processor to run > properly. Is that a lib/module I can install to a 4.9.0-9-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.168-1 kernel? Thanks Dan. Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | Dan Purgert <dan@djph.net> |
|---|---|
| Date | 2019-05-07 11:40 +0200 |
| Message-ID | <xV4JP-1OK-1@gated-at.bofh.it> |
| In reply to | #208327 |
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA256 Gene Heskett wrote: > On Monday 06 May 2019 01:46:36 pm Dan Purgert wrote: > >> Gene Heskett wrote: >> > [...] >> > Logged out no, started a new konsole and ran ff from it yes. Managed >> > to get the little b&w laser working, but a 2 year old 11x17 MFC? >> > Won't configure, missing file although the latest driver kit from >> > brother is installed, so I find I have a nearly $700 >> > scanner/copier/printer thats been discontinued! And they've blocked >> > or removed any access to the old files. Thats generated a nastygram >> > to brother, its a 2 year old printer. >> >> Which printer was that? Don't forget that some of their printers >> require multiarch / i386 in order for the pre-processor to run >> properly. > > Is that a lib/module I can install to a > 4.9.0-9-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.168-1 > kernel? Multiarch? It's a dpkg setting so that you can get packages for a different architecture (e.g. 32-bit "i386" packages on a 64-bit machine). You didn't answer which printer it was, though. -----BEGIN PGP SIGNATURE----- iQEzBAEBCAAdFiEEBcqaUD8uEzVNxUrujhHd8xJ5ooEFAlzRT7kACgkQjhHd8xJ5 ooElCwf+LCocheaW7b0gUtnWyBCeO1vWrXaFwkas4AzVYgj+tZqAkU6Kf4EYKNIy dt5xZkzD5A8o/s9asJxXvdvKYszAYZ8nzBgwg2FdwNHW2bkeGzQKGEY6Yu6CWL63 58afChljWsUl/iY2EI0212SEjjsU/8shKYnMsQr9UIS6KicS0UaupCt1+VzVmkEy KRKD1IZBu1UK5v7QTF068TX/6CXFIs78fdWgo/AqDBQywRGqN3l7a8JUTTyt6LEI 9jcVdMtG6JtAyOQB0d7L7NNJu4AJlq37IIlut5ZsgSMZo1W91T3tXGg+6FlOgzHL x7JxNYPRjcrXx5Ru2XFdw6LZuwlsOw== =MmR9 -----END PGP SIGNATURE----- -- |_|O|_| |_|_|O| Github: https://github.com/dpurgert |O|O|O| PGP: 05CA 9A50 3F2E 1335 4DC5 4AEE 8E11 DDF3 1279 A281
[toc] | [prev] | [next] | [standalone]
| From | Gene Heskett <gheskett@shentel.net> |
|---|---|
| Date | 2019-05-07 15:00 +0200 |
| Message-ID | <xV7Rn-3FT-3@gated-at.bofh.it> |
| In reply to | #208340 |
On Tuesday 07 May 2019 05:28:26 am Dan Purgert wrote: > Gene Heskett wrote: > > On Monday 06 May 2019 01:46:36 pm Dan Purgert wrote: > >> Gene Heskett wrote: > >> > [...] > >> > Logged out no, started a new konsole and ran ff from it yes. > >> > Managed to get the little b&w laser working, but a 2 year old > >> > 11x17 MFC? Won't configure, missing file although the latest > >> > driver kit from brother is installed, so I find I have a nearly > >> > $700 > >> > scanner/copier/printer thats been discontinued! And they've > >> > blocked or removed any access to the old files. Thats generated > >> > a nastygram to brother, its a 2 year old printer. > >> > >> Which printer was that? Don't forget that some of their printers > >> require multiarch / i386 in order for the pre-processor to run > >> properly. > > > > Is that a lib/module I can install to a > > 4.9.0-9-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.168-1 > > kernel? > > Multiarch? It's a dpkg setting so that you can get packages for a > different architecture (e.g. 32-bit "i386" packages on a 64-bit > machine). > > You didn't answer which printer it was, though. Brother MFC-J6920DW, it can handle up to 11x17 paper, handy when processing "rockhopper's" output which can if magnified by inkscape far enough to be readable, is then posterized and can occupy better than half a sheet of 1/4 plywood. And apparently cups has upped the anti, needing a filter they name if you read the fine print in the error_log, but which is not part of cups, or the last driver download from brother that I pulled a fresh copy of less than a year ago. For 32 bit of coarse. The error log: /usr/lib/cups/filter/brother_lpdwrapper_mfcj6920dw\" not available: No such file or directory What I have: Is an installer that came with the last download. I had to chmod +x it to run it, and its 95% legal BS as it contains 3 or 4 brother licenses in addition to the usual gpl-v2 boiler plate, but I ran it and was amazed, successfull, so now I have test prints from 2 profiles, and the test page on photo paper looks better than it ever has. And after running it, I have that missing file, but it was built, it does not exist in any of the debs accompanying that download. So now maybe I have some color control, which was previously ignored, giving me very pastel prints. But I've about sucked the cyan tank dry, so I'd better get some ink before messing with the color further. I haven't tried to setup a profile for the rear feed slot taking 11x17 paper yet. I tried to make a feed tray to keep the paper straighter, a huge improvement but wasn't 100% successfull. Yay! I don't have an expen$ive paperweight anymore. Woopee! Thanks for reading, and I'll keep this in case someone else needs it. Now to see if sane can find its scanner and ADF. Thanks again. Cheers, Gene Heskett -- "There are four boxes to be used in defense of liberty: soap, ballot, jury, and ammo. Please use in that order." -Ed Howdershelt (Author) Genes Web page <http://geneslinuxbox.net:6309/gene>
[toc] | [prev] | [next] | [standalone]
| From | Dan Purgert <dan@djph.net> |
|---|---|
| Date | 2019-05-07 15:40 +0200 |
| Message-ID | <xV8u5-48I-7@gated-at.bofh.it> |
| In reply to | #208354 |
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA256 Gene Heskett wrote: > On Tuesday 07 May 2019 05:28:26 am Dan Purgert wrote: >> Gene Heskett wrote: >>> [...] >>> Is that a lib/module I can install to a >>> 4.9.0-9-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.168-1 >>> kernel? >> >> Multiarch? It's a dpkg setting so that you can get packages for a >> different architecture (e.g. 32-bit "i386" packages on a 64-bit >> machine). >> >> You didn't answer which printer it was, though. > > Brother MFC-J6920DW, it can handle up to 11x17 paper, handy when According to the driver install notes [1] (step2), there are some prereq procedures[2]. Prereq (5) on that page is for Debian / Ubuntu 64-bit machines. NOTE -- I just grabbed the LPR *deb package (as I prefer LPR over cups). You can go through the tool here[3] to select the cupswrapper driver, if you prefer. Some features may require that you've connected the printer via USB (I have a MFC-L8860CDW connected to the network that "loses" a lot of the "from the PC" functionality due to that). (Sorry for the wrap) [1] https://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=mfcj6920dw_us_eu_as&os=128&dlid=dlf100969_000&flang=4&type3=559 [2] https://support.brother.com/g/b/faqend.aspx?c=us&lang=en&prod=mfcj6920dw_us_eu_as&faqid=faq00100548_000 [3] https://support.brother.com/g/b/downloadtop.aspx?c=us&lang=en&prod=mfcj6920dw_us_eu_as HTH :) -----BEGIN PGP SIGNATURE----- iQEzBAEBCAAdFiEEBcqaUD8uEzVNxUrujhHd8xJ5ooEFAlzRiEAACgkQjhHd8xJ5 ooFB6ggAiP+oXRxcX2c9ayZgXPAT4KMzGXiB0pVrgGdXmndUPSnTPZyNDWDUNlsc 1TZG086HtcYFGLr9qPh+pEGQLSBFLra7fAaWy7YbVFVb/Qtfy5/ldTXsZvTqc6SW zywWNvw8EwoksHgLRjcTzUHsgIEUmzuq77VF2+b5GV6rMDPmAAhLjm7qb5UjQZku 79AKdcVli9Lpid0Yv3hpY4tXucq9/EAMl01vusdpOIC/ITQfZdDZYqKvPP5PkFOI VTdpFqYst756SWv+JB4JCSVp4HqZr4cYQLPnIXg/+C0nClq+Qpw31cuGmQPchKHx LjMQEADBJow1O5qp7HkpLrKQHx+Kmg== =qpXN -----END PGP SIGNATURE----- -- |_|O|_| |_|_|O| Github: https://github.com/dpurgert |O|O|O| PGP: 05CA 9A50 3F2E 1335 4DC5 4AEE 8E11 DDF3 1279 A281
[toc] | [prev] | [next] | [standalone]
| From | Brian <ad44@cityscape.co.uk> |
|---|---|
| Date | 2019-05-07 18:40 +0200 |
| Message-ID | <xVbii-5SC-7@gated-at.bofh.it> |
| In reply to | #208356 |
On Tue 07 May 2019 at 13:29:39 -0000, Dan Purgert wrote: > -----BEGIN PGP SIGNED MESSAGE----- > Hash: SHA256 > > Gene Heskett wrote: > > On Tuesday 07 May 2019 05:28:26 am Dan Purgert wrote: > >> Gene Heskett wrote: > >>> [...] > >>> Is that a lib/module I can install to a > >>> 4.9.0-9-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.168-1 > >>> kernel? > >> > >> Multiarch? It's a dpkg setting so that you can get packages for a > >> different architecture (e.g. 32-bit "i386" packages on a 64-bit > >> machine). > >> > >> You didn't answer which printer it was, though. > > > > Brother MFC-J6920DW, it can handle up to 11x17 paper, handy when > > According to the driver install notes [1] (step2), there are some prereq > procedures[2]. Prereq (5) on that page is for Debian / Ubuntu 64-bit > machines. > > NOTE -- I just grabbed the LPR *deb package (as I prefer LPR over cups). > You can go through the tool here[3] to select the cupswrapper driver, if > you prefer. There is enough misinformation in Gene's post without adding more. :) Both the LPR and the CUPSwrapper printer driver packages are required. One contains a PPD and the other a driver for conversion to the specific printer language. > Some features may require that you've connected the printer via USB (I > have a MFC-L8860CDW connected to the network that "loses" a lot of the > "from the PC" functionality due to that). MFC-L8860CDW? What features are missing from network connected device? -- Brian. > > > (Sorry for the wrap) > [1] > https://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=mfcj6920dw_us_eu_as&os=128&dlid=dlf100969_000&flang=4&type3=559 > [2] > https://support.brother.com/g/b/faqend.aspx?c=us&lang=en&prod=mfcj6920dw_us_eu_as&faqid=faq00100548_000 > [3] > https://support.brother.com/g/b/downloadtop.aspx?c=us&lang=en&prod=mfcj6920dw_us_eu_as > > HTH :) > > -----BEGIN PGP SIGNATURE----- > > iQEzBAEBCAAdFiEEBcqaUD8uEzVNxUrujhHd8xJ5ooEFAlzRiEAACgkQjhHd8xJ5 > ooFB6ggAiP+oXRxcX2c9ayZgXPAT4KMzGXiB0pVrgGdXmndUPSnTPZyNDWDUNlsc > 1TZG086HtcYFGLr9qPh+pEGQLSBFLra7fAaWy7YbVFVb/Qtfy5/ldTXsZvTqc6SW > zywWNvw8EwoksHgLRjcTzUHsgIEUmzuq77VF2+b5GV6rMDPmAAhLjm7qb5UjQZku > 79AKdcVli9Lpid0Yv3hpY4tXucq9/EAMl01vusdpOIC/ITQfZdDZYqKvPP5PkFOI > VTdpFqYst756SWv+JB4JCSVp4HqZr4cYQLPnIXg/+C0nClq+Qpw31cuGmQPchKHx > LjMQEADBJow1O5qp7HkpLrKQHx+Kmg== > =qpXN > -----END PGP SIGNATURE----- > > -- > |_|O|_| > |_|_|O| Github: https://github.com/dpurgert > |O|O|O| PGP: 05CA 9A50 3F2E 1335 4DC5 4AEE 8E11 DDF3 1279 A281 >
[toc] | [prev] | [next] | [standalone]
Page 1 of 2 [1] 2 Next page →
Back to top | Article view | linux.debian.user
csiph-web