Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #207617 > unrolled thread
| Started by | Mark Fletcher <mark27q1@gmail.com> |
|---|---|
| First post | 2019-04-17 08:30 +0200 |
| Last post | 2019-04-17 21:10 +0200 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.debian.user
Sudden “operation not permitted” Mark Fletcher <mark27q1@gmail.com> - 2019-04-17 08:30 +0200
Re: Sudden “operation not permitted” Reco <recoverym4n@enotuniq.net> - 2019-04-17 10:20 +0200
RESOLVED: Sudden “operation not permitted” Mark Fletcher <mark27q1@gmail.com> - 2019-04-17 17:00 +0200
Re: Sudden “operation not permitted” David Christensen <dpchrist@holgerdanske.com> - 2019-04-17 21:10 +0200
| From | Mark Fletcher <mark27q1@gmail.com> |
|---|---|
| Date | 2019-04-17 08:30 +0200 |
| Subject | Sudden “operation not permitted” |
| Message-ID | <xNMeZ-2Rv-1@gated-at.bofh.it> |
[Multipart message — attachments visible in raw view] — view raw
(Apologies if this mail comes through poorly formatted for the list; my main machine is unavailable due to this problem and I’m writing on an iPad...) Running Stretch on a circa-2009 self-built machine which has run happily without serious issues since it was built, apart from the odd annoyance with Bluetooth audio which the list has already had the pleasure of hearing about. This morning I unlocked it before leaving home, and noticed that load was fairly constant at about 1.0 when it should have been at 0 as the machine should have been idle. I listed processes with top and noticed that upowerd was taking up a whole CPU to itself. Normally I wouldn’t notice this daemon doing its thing. Google turned up nothing relevant. I decided to try a reboot, which cleared the upowerd problem and returned load to 0 or close to it. But now, network activity is not working. Any attempt to ping an IP address (eg my router) results in “Operation not permitted” even when run as root. Attempt to access any web page results in failing to find the site. Attempting to ping a text domain (eg www.google.com) results in an error message (instantly) saying could not resolve... It seems like networking is bejiggered suddenly on this machine. I did not install updates before rebooting, last time updates were installed was Sunday, and all has been well since then until this morning, although I did not reboot during that period until this morning. The machine is attached to my network via an Ethernet cable running to a WiFi+wired router. That is obviously working as the machine was able to get an IP address by DHCP after the reboot (ip route after reboot showed IP address correctly assigned) but unable to resolve any address and unable to ping an IP address of the form 192.168.xx.yy with the “Operation not permitted” error. All the pinging I’ve been trying worked without issues before this problem occurred, both as root and as an unprivileged user. Looking through the journalctl since my reboot, I do not see anything that obviously points to the problem. Network Manager seems to start OK, as far as I can tell. I don’t see any significant errors except postgreSQL failing to start, which is normal and I don’t use it. The first sign of trouble (to my eye, anyway) in the boot log is when services that want the network eg ntp start trying to interact with it, and failing. A second reboot produced exactly the same result. Other devices on my network are working fine. Putting the upowerd behavior together with the suddenness of this problem, I’m very afraid that this isn’t really permissions and is in fact some sort of hardware issue — the machine is 10 years old, was built by me, and has been in continuous use since it was built... Any suggestions for what I can do to diagnose? Thanks in advance Mark
[toc] | [next] | [standalone]
| From | Reco <recoverym4n@enotuniq.net> |
|---|---|
| Date | 2019-04-17 10:20 +0200 |
| Message-ID | <xNNXr-3Xv-3@gated-at.bofh.it> |
| In reply to | #207617 |
Hi. On Wed, Apr 17, 2019 at 03:25:39PM +0900, Mark Fletcher wrote: > I decided to try a reboot, which cleared the upowerd problem and returned > load to 0 or close to it. But now, network activity is not working. Seems like a coincidence to me. > Any attempt to ping an IP address (eg my router) results in “Operation not > permitted” even when run as root. This. About the only known (for me, at least) way to achieve this is to send back ICMP Type 3 (Destination Unreachable) Code 9 or 10 (network/host administratively prohibited). It *could* be a SELinux or Apparmor misconfiguration, of course, but we'll deal with it later. The main question is, who sends ICMP back to your host. Can you please post the output of "iptables-save" (needs to be run as root)? And do you have "tcpdump" installed? > Looking through the journalctl since my reboot, I do not see anything that > obviously points to the problem. Network Manager seems to start OK, as far > as I can tell. It means nothing. The thing is always "starting". Whenever it's doing anything useful or harmful is entirely different matter. Reco
[toc] | [prev] | [next] | [standalone]
| From | Mark Fletcher <mark27q1@gmail.com> |
|---|---|
| Date | 2019-04-17 17:00 +0200 |
| Subject | RESOLVED: Sudden “operation not permitted” |
| Message-ID | <xNUcx-7yW-7@gated-at.bofh.it> |
| In reply to | #207630 |
On Wed, Apr 17, 2019 at 11:17:04AM +0300, Reco wrote: > Hi. > > On Wed, Apr 17, 2019 at 03:25:39PM +0900, Mark Fletcher wrote: > > I decided to try a reboot, which cleared the upowerd problem and returned > > load to 0 or close to it. But now, network activity is not working. > > Seems like a coincidence to me. You were right -- see below > > > > Any attempt to ping an IP address (eg my router) results in “Operation not > > permitted” even when run as root. > > This. About the only known (for me, at least) way to achieve this is to > send back ICMP Type 3 (Destination Unreachable) Code 9 or 10 > (network/host administratively prohibited). > It *could* be a SELinux or Apparmor misconfiguration, of course, but > we'll deal with it later. > > The main question is, who sends ICMP back to your host. > No one -- as it turns out. The cause turned out to be that recent changes I had made to this machine to support making its MTA available to my VPN introduced a buggy iptables startup script which left my iptables settings in a stupid state on boot (blocking EVERYTHING). I'd never have thought of that if you hadn't asked me for the output of iptables-save. Soon as my eye landed on "iptables" I was like, "ooooooooohhhhhhhhhhh, sh*t". Fixing the bug in the startup script and rebooting (to make sure it will work next time) -- all is now well. No hardware fault, I'm very pleased to report. I don't know what caused upowerd to go nuts and probably never will, but right now I'm just happy my machine is back up and running properly. Thanks Reco Mark
[toc] | [prev] | [next] | [standalone]
| From | David Christensen <dpchrist@holgerdanske.com> |
|---|---|
| Date | 2019-04-17 21:10 +0200 |
| Message-ID | <xNY6u-1Gw-13@gated-at.bofh.it> |
| In reply to | #207617 |
On 4/16/19 11:25 PM, Mark Fletcher wrote: > (Apologies if this mail comes through poorly formatted for the list; my > main machine is unavailable due to this problem and I’m writing on an > iPad...) > > Running Stretch on a circa-2009 self-built machine which has run happily > without serious issues since it was built, apart from the odd annoyance > with Bluetooth audio which the list has already had the pleasure of hearing > about. > > This morning I unlocked it before leaving home, and noticed that load was > fairly constant at about 1.0 when it should have been at 0 as the machine > should have been idle. I listed processes with top and noticed that upowerd > was taking up a whole CPU to itself. Normally I wouldn’t notice this daemon > doing its thing. > > Google turned up nothing relevant. > > I decided to try a reboot, which cleared the upowerd problem and returned > load to 0 or close to it. But now, network activity is not working. Any > attempt to ping an IP address (eg my router) results in “Operation not > permitted” even when run as root. Attempt to access any web page results in > failing to find the site. Attempting to ping a text domain (eg > www.google.com) results in an error message (instantly) saying could not > resolve... > > It seems like networking is bejiggered suddenly on this machine. I did not > install updates before rebooting, last time updates were installed was > Sunday, and all has been well since then until this morning, although I did > not reboot during that period until this morning. The machine is attached > to my network via an Ethernet cable running to a WiFi+wired router. That is > obviously working as the machine was able to get an IP address by DHCP > after the reboot (ip route after reboot showed IP address correctly > assigned) but unable to resolve any address and unable to ping an IP > address of the form 192.168.xx.yy with the “Operation not permitted” error. > > All the pinging I’ve been trying worked without issues before this problem > occurred, both as root and as an unprivileged user. > > Looking through the journalctl since my reboot, I do not see anything that > obviously points to the problem. Network Manager seems to start OK, as far > as I can tell. I don’t see any significant errors except postgreSQL failing > to start, which is normal and I don’t use it. The first sign of trouble (to > my eye, anyway) in the boot log is when services that want the network eg > ntp start trying to interact with it, and failing. > > A second reboot produced exactly the same result. Other devices on my > network are working fine. > > Putting the upowerd behavior together with the suddenness of this problem, > I’m very afraid that this isn’t really permissions and is in fact some sort > of hardware issue — the machine is 10 years old, was built by me, and has > been in continuous use since it was built... Any suggestions for what I can > do to diagnose? > > Thanks in advance > > Mark If you updated/ upgraded but did not reboot, then there could be a problem with one or more upgrades. (I try to reboot immediately after upgrading to avoid delayed surprises.) I would pull the system drive, put it into a second machine, boot it, and see if the problems persist. I would also run the system drive manufacturer's diagnostic tool and test the system drive. While testing the system drive in another machine, I would test the first machine -- e.g. verify all cables fully seated, test the power supply with a hardware tester, run any motherboard firmware diagnostics, run software memory diagnostics, etc.. David
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.user
csiph-web