Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #203346 > unrolled thread

printers

Started bymick crane <mick.crane@gmail.com>
First post2018-12-13 20:50 +0100
Last post2018-12-13 22:50 +0100
Articles 14 — 6 participants

Back to article view | Back to linux.debian.user


Contents

  printers mick crane <mick.crane@gmail.com> - 2018-12-13 20:50 +0100
    Re: printers Brian <ad44@cityscape.co.uk> - 2018-12-13 21:40 +0100
      Re: printers Brian <ad44@cityscape.co.uk> - 2018-12-14 00:00 +0100
        Re: printers aces and eights <mick.crane@gmail.com> - 2018-12-14 10:00 +0100
        Re: printers mick crane <mick.crane@gmail.com> - 2018-12-14 11:40 +0100
    Re: printers Michael Stone <mstone@debian.org> - 2018-12-13 21:50 +0100
      Re: printers mick crane <mick.crane@gmail.com> - 2018-12-13 22:10 +0100
        Re: printers Michael Stone <mstone@debian.org> - 2018-12-13 22:30 +0100
      Re: printers mick crane <mick.crane@gmail.com> - 2018-12-14 13:40 +0100
    Re: printers basti <mailinglist@unix-solution.de> - 2018-12-13 22:20 +0100
      Re: printers mick crane <mick.crane@gmail.com> - 2018-12-13 22:40 +0100
        Re: printers Michael Stone <mstone@debian.org> - 2018-12-13 22:50 +0100
      Re: printers Gene Heskett <gheskett@shentel.net> - 2018-12-13 22:40 +0100
      Re: printers Michael Stone <mstone@debian.org> - 2018-12-13 22:50 +0100

#203346 — printers

Frommick crane <mick.crane@gmail.com>
Date2018-12-13 20:50 +0100
Subjectprinters
Message-ID<x4F9E-6Ax-7@gated-at.bofh.it>
I think I must be getting elderly
I have a debian buster PC that works as a print server. I can send files 
to it from windows and I can print from it by typing
"lpr filename"
I think I set it up with the cups web interface.

I have another debian buster PC that I sometimes fiddle about on and I'd 
like to type on that.
"lpr filename"
I don't want the cups sever on it just to print.

I typed
"lpadmin -U mick -h http://10.0.0.107:631 -d HP_LaserJet_4000_series"
hoping it might do something but says
"Unable to connect to server: No such file or directory"

I attempted to use the GUI from the desktop System/Print Settings where 
I hoped I could put in sensible values but it says it is locked and ask 
for authentication.
I put in the root password but it won't do anything
why might that be then ?

mick



-- 
Key ID    4BFEBB31

[toc] | [next] | [standalone]


#203349

FromBrian <ad44@cityscape.co.uk>
Date2018-12-13 21:40 +0100
Message-ID<x4FW1-76w-3@gated-at.bofh.it>
In reply to#203346
On Thu 13 Dec 2018 at 19:44:29 +0000, mick crane wrote:

> I think I must be getting elderly
> I have a debian buster PC that works as a print server. I can send files to
> it from windows and I can print from it by typing
> "lpr filename"
> I think I set it up with the cups web interface.
> 
> I have another debian buster PC that I sometimes fiddle about on and I'd
> like to type on that.
> "lpr filename"
> I don't want the cups sever on it just to print.

What else do you want the server to do? Play the USA national anthem?

> I typed
> "lpadmin -U mick -h http://10.0.0.107:631 -d HP_LaserJet_4000_series"
> hoping it might do something but says
> "Unable to connect to server: No such file or directory"

Seems clear enough as an error message.
 
> I attempted to use the GUI from the desktop System/Print Settings where I
> hoped I could put in sensible values but it says it is locked and ask for
> authentication.

Which GUI? Which program?

> I put in the root password but it won't do anything
> why might that be then ?

How is this connected with your first stated problem? What you are
attempting to do in all of this?

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#203363

FromBrian <ad44@cityscape.co.uk>
Date2018-12-14 00:00 +0100
Message-ID<x4I7w-8nL-9@gated-at.bofh.it>
In reply to#203349
On Thu 13 Dec 2018 at 20:32:14 +0000, Brian wrote:

> On Thu 13 Dec 2018 at 19:44:29 +0000, mick crane wrote:
 
[...]
 
> > I typed
> > "lpadmin -U mick -h http://10.0.0.107:631 -d HP_LaserJet_4000_series"
> > hoping it might do something but says
> > "Unable to connect to server: No such file or directory"
> 
> Seems clear enough as an error message.

-U is of no great imortance. Now read the manual carefully and look what
you wrote.

-- 
Brian.

[toc] | [prev] | [next] | [standalone]


#203365

Fromaces and eights <mick.crane@gmail.com>
Date2018-12-14 10:00 +0100
Message-ID<x4Ru9-5Jy-7@gated-at.bofh.it>
In reply to#203363

[Multipart message — attachments visible in raw view] — view raw

well I removed the http:// bit and it did something but who know what.
seems that this lpadmin administers the server and I thought would inform
client.
not working but there is a more urgent problem in that weirdly after typing.
lpadmin  -h 10.0.0.107:631 -d HP_LaserJet_4000_series"
php seems to have stopped working on server so no mail server
just displays the text.
there is error in apache2 error log
[php7:error] [pid 5733] [client 10.0.0.101:53579] PHP Fatal error:
Uncaught Error: Class 'DOMDocument' not found in
/usr/share/roundcubemail-1.3.8/program/lib/Roundcube/html.php:357\nStack
trace:\n#0

so I don't know what goes on.



On Thu, 13 Dec 2018 at 22:51, Brian <ad44@cityscape.co.uk> wrote:

> On Thu 13 Dec 2018 at 20:32:14 +0000, Brian wrote:
>
> > On Thu 13 Dec 2018 at 19:44:29 +0000, mick crane wrote:
>
> [...]
>
> > > I typed
> > > "lpadmin -U mick -h http://10.0.0.107:631 -d HP_LaserJet_4000_series"
> > > hoping it might do something but says
> > > "Unable to connect to server: No such file or directory"
> >
> > Seems clear enough as an error message.
>
> -U is of no great imortance. Now read the manual carefully and look what
> you wrote.
>
> --
> Brian.
>
>

[toc] | [prev] | [next] | [standalone]


#203368

Frommick crane <mick.crane@gmail.com>
Date2018-12-14 11:40 +0100
Message-ID<x4T2V-6L3-5@gated-at.bofh.it>
In reply to#203363
On 2018-12-13 22:51, Brian wrote:
> On Thu 13 Dec 2018 at 20:32:14 +0000, Brian wrote:
> 
>> On Thu 13 Dec 2018 at 19:44:29 +0000, mick crane wrote:
> 
> [...]
> 
>> > I typed
>> > "lpadmin -U mick -h http://10.0.0.107:631 -d HP_LaserJet_4000_series"
>> > hoping it might do something but says
>> > "Unable to connect to server: No such file or directory"
>> 
>> Seems clear enough as an error message.
> 
> -U is of no great imortance. Now read the manual carefully and look 
> what
> you wrote.

I don't know if previous mail turns up I sent reply via gmail because 
....

"well I removed the http:// bit and it did something but who know what.
seems that this lpadmin administers the server and I thought would 
inform client.
not working but there is a more urgent problem in that weirdly after 
typing.
lpadmin  -h 10.0.0.107:631 -d HP_LaserJet_4000_series"
php seems to have stopped working on server so no mail server
just displays the text.
there is error in apache2 error log
[php7:error] [pid 5733] [client 10.0.0.101:53579] PHP Fatal error:  
Uncaught Error: Class 'DOMDocument' not found in 
/usr/share/roundcubemail-1.3.8/program/lib/Roundcube/html.php:357\nStack 
trace:\n#0

so I don't know what goes on."

mail server seems happy now after reinstalling some php modules but 
that's enough computer for one day


-- 
Key ID    4BFEBB31

[toc] | [prev] | [next] | [standalone]


#203351

FromMichael Stone <mstone@debian.org>
Date2018-12-13 21:50 +0100
Message-ID<x4G5I-7ar-9@gated-at.bofh.it>
In reply to#203346
On Thu, Dec 13, 2018 at 07:44:29PM +0000, mick crane wrote:
>I have a debian buster PC that works as a print server. I can send 
>files to it from windows 

How? Do you have samba and the windows machines print via smb, or are 
they printing via ipp?

>I have another debian buster PC that I sometimes fiddle about on and 
>I'd like to type on that.
>"lpr filename"
>I don't want the cups sever on it just to print.

You should be able to do that with just the cups-client package and 
setting /etc/cups/client.conf to contain "ServerName whatever" where 
"whatever" is the hostname or IP of your print server. If that doesn't 
work it's likely that the print server isn't set to accept remote 
connections (the windows machines wouldn't need that if they're printing 
via smb).

It's also possible to make this all magically work via network 
broadcasts, but I find it simpler & more reliable to just configure 
client.conf in a single print server situaton.

[toc] | [prev] | [next] | [standalone]


#203352

Frommick crane <mick.crane@gmail.com>
Date2018-12-13 22:10 +0100
Message-ID<x4Gp4-7wF-11@gated-at.bofh.it>
In reply to#203351
On 2018-12-13 20:42, Michael Stone wrote:
> On Thu, Dec 13, 2018 at 07:44:29PM +0000, mick crane wrote:
>> I have a debian buster PC that works as a print server. I can send 
>> files to it from windows
> 
> How? Do you have samba and the windows machines print via smb, or are
> they printing via ipp?
> 
>> I have another debian buster PC that I sometimes fiddle about on and 
>> I'd like to type on that.
>> "lpr filename"
>> I don't want the cups sever on it just to print.
> 
> You should be able to do that with just the cups-client package and
> setting /etc/cups/client.conf to contain "ServerName whatever" where
> "whatever" is the hostname or IP of your print server. If that doesn't
> work it's likely that the print server isn't set to accept remote
> connections (the windows machines wouldn't need that if they're
> printing via smb).
> 
> It's also possible to make this all magically work via network
> broadcasts, but I find it simpler & more reliable to just configure
> client.conf in a single print server situaton.

Ok Is no samba, I look cups-client conf, mostly was preamble. Question 
was curious why can't authenticate with xfce GUI System|Print settings

-- 
Key ID    4BFEBB31

[toc] | [prev] | [next] | [standalone]


#203356

FromMichael Stone <mstone@debian.org>
Date2018-12-13 22:30 +0100
Message-ID<x4GIq-7Dr-13@gated-at.bofh.it>
In reply to#203352
On Thu, Dec 13, 2018 at 09:03:45PM +0000, mick crane wrote:
>Ok Is no samba, I look cups-client conf, mostly was preamble. Question 
>was curious why can't authenticate with xfce GUI System|Print settings

If you are in a client-only configuration you can't set things on the 
client side--you're actually trying to change the server settings. So 
lpq should work, but lpadmin won't. (Unless you additionally configure 
cups to allow remote administration, which is by default (I think--it's 
been a long time since I had a default config) tighter than just being 
able to print.)

[toc] | [prev] | [next] | [standalone]


#203371

Frommick crane <mick.crane@gmail.com>
Date2018-12-14 13:40 +0100
Message-ID<x4UV3-7RM-3@gated-at.bofh.it>
In reply to#203351
On 2018-12-13 20:42, Michael Stone wrote:
> On Thu, Dec 13, 2018 at 07:44:29PM +0000, mick crane wrote:
>> I have a debian buster PC that works as a print server. I can send 
>> files to it from windows
> 
> How? Do you have samba and the windows machines print via smb, or are
> they printing via ipp?
> 
>> I have another debian buster PC that I sometimes fiddle about on and 
>> I'd like to type on that.
>> "lpr filename"
>> I don't want the cups sever on it just to print.
> 
> You should be able to do that with just the cups-client package and
> setting /etc/cups/client.conf to contain "ServerName whatever" where
> "whatever" is the hostname or IP of your print server.

Ok that does it.
would be cool if client.conf already existed with line saying
# put ipaddress of print server here.

-- 
Key ID    4BFEBB31

[toc] | [prev] | [next] | [standalone]


#203354

Frombasti <mailinglist@unix-solution.de>
Date2018-12-13 22:20 +0100
Message-ID<x4GyJ-7A4-3@gated-at.bofh.it>
In reply to#203346

On 13.12.18 20:44, mick crane wrote:
> I think I must be getting elderly
> I have a debian buster PC that works as a print server. I can send files
> to it from windows and I can print from it by typing
> "lpr filename"
> I think I set it up with the cups web interface.
> 
> I have another debian buster PC that I sometimes fiddle about on and I'd
> like to type on that.
> "lpr filename"
> I don't want the cups sever on it just to print
is the cups server runing on IP 10.0.0.107 ?
what does "ss -tulpen | grep 631" say?

> 
> I typed
> "lpadmin -U mick -h http://10.0.0.107:631 -d HP_LaserJet_4000_series"
> hoping it might do something but says
> "Unable to connect to server: No such file or directory"

you can install cups-client on this machine an then create a file
/etc/cups/client.conf like:

ServerName 10.0.0.107

> 
> I attempted to use the GUI from the desktop System/Print Settings where
> I hoped I could put in sensible values but it says it is locked and ask
> for authentication.
> I put in the root password but it won't do anything
> why might that be then ?

is root in the lpamin group?

> 
> mick
> 
> 
> 

[toc] | [prev] | [next] | [standalone]


#203357

Frommick crane <mick.crane@gmail.com>
Date2018-12-13 22:40 +0100
Message-ID<x4GS6-7GF-1@gated-at.bofh.it>
In reply to#203354
On 2018-12-13 20:43, basti wrote:
> On 13.12.18 20:44, mick crane wrote:
>> I think I must be getting elderly
>> I have a debian buster PC that works as a print server. I can send 
>> files
>> to it from windows and I can print from it by typing
>> "lpr filename"
>> I think I set it up with the cups web interface.
>> 
>> I have another debian buster PC that I sometimes fiddle about on and 
>> I'd
>> like to type on that.
>> "lpr filename"
>> I don't want the cups sever on it just to print
> is the cups server runing on IP 10.0.0.107 ?
> what does "ss -tulpen | grep 631" say?

yes cups server 107

:~$ ss -tulpen | grep 631
udp    UNCONN   0        0                 0.0.0.0:631            
0.0.0.0:*      ino:17297 sk:1 <->
tcp    LISTEN   0        5               127.0.0.1:631            
0.0.0.0:*      ino:17288 sk:c <->
tcp    LISTEN   0        5                   [::1]:631               
[::]:*      ino:17287 sk:13 v6only:1 <->

>> 
>> I typed
>> "lpadmin -U mick -h http://10.0.0.107:631 -d HP_LaserJet_4000_series"
>> hoping it might do something but says
>> "Unable to connect to server: No such file or directory"
> 
> you can install cups-client on this machine an then create a file
> /etc/cups/client.conf like:
> 
> ServerName 10.0.0.107

cups is there likely I haven't set anything up
> 
>> 
>> I attempted to use the GUI from the desktop System/Print Settings 
>> where
>> I hoped I could put in sensible values but it says it is locked and 
>> ask
>> for authentication.
>> I put in the root password but it won't do anything
>> why might that be then ?
> 
> is root in the lpamin group?

this was really my question, sometimes I just don't get these 
permissions. I thought root was access everywhere.


mick

-- 
Key ID    4BFEBB31

[toc] | [prev] | [next] | [standalone]


#203359

FromMichael Stone <mstone@debian.org>
Date2018-12-13 22:50 +0100
Message-ID<x4H1L-7K4-1@gated-at.bofh.it>
In reply to#203357
On Thu, Dec 13, 2018 at 09:35:49PM +0000, mick crane wrote:
>yes cups server 107
>
>:~$ ss -tulpen | grep 631
>udp    UNCONN   0        0                 0.0.0.0:631            
>0.0.0.0:*      ino:17297 sk:1 <->
>tcp    LISTEN   0        5               127.0.0.1:631            
>0.0.0.0:*      ino:17288 sk:c <->
>tcp    LISTEN   0        5                   [::1]:631               
>[::]:*      ino:17287 sk:13 v6only:1 <->

If that's on the cups server then go back and look at the windows 
machines again to see how they're printing--it's not through here. (This 
system is only listening to connections from the local host.)

[toc] | [prev] | [next] | [standalone]


#203358

FromGene Heskett <gheskett@shentel.net>
Date2018-12-13 22:40 +0100
Message-ID<x4GS6-7GF-15@gated-at.bofh.it>
In reply to#203354
On Thursday 13 December 2018 15:43:22 basti wrote:

> On 13.12.18 20:44, mick crane wrote:
> > I think I must be getting elderly
> > I have a debian buster PC that works as a print server. I can send
> > files to it from windows and I can print from it by typing
> > "lpr filename"
> > I think I set it up with the cups web interface.
> >
> > I have another debian buster PC that I sometimes fiddle about on and
> > I'd like to type on that.
> > "lpr filename"
> > I don't want the cups sever on it just to print
>
> is the cups server runing on IP 10.0.0.107 ?
> what does "ss -tulpen | grep 631" say?
>
> > I typed
> > "lpadmin -U mick -h http://10.0.0.107:631 -d
> > HP_LaserJet_4000_series" hoping it might do something but says
> > "Unable to connect to server: No such file or directory"
>
> you can install cups-client on this machine an then create a file
> /etc/cups/client.conf like:
>
> ServerName 10.0.0.107
>
> > I attempted to use the GUI from the desktop System/Print Settings
> > where I hoped I could put in sensible values but it says it is
> > locked and ask for authentication.
> > I put in the root password but it won't do anything
> > why might that be then ?
>
> is root in the lpamin group?

Did you mean the lpadmin group?
>
> > mick



-- 
Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

[toc] | [prev] | [next] | [standalone]


#203360

FromMichael Stone <mstone@debian.org>
Date2018-12-13 22:50 +0100
Message-ID<x4H1M-7K4-3@gated-at.bofh.it>
In reply to#203354
On Thu, Dec 13, 2018 at 09:43:22PM +0100, basti wrote:
>> I attempted to use the GUI from the desktop System/Print Settings where
>> I hoped I could put in sensible values but it says it is locked and ask
>> for authentication.
>> I put in the root password but it won't do anything
>> why might that be then ?
>
>is root in the lpamin group?

It doesn't need to be.

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.user


csiph-web