Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #192618 > unrolled thread
| Started by | bolakim53@mail2tor.com |
|---|---|
| First post | 2018-02-18 17:50 +0100 |
| Last post | 2018-04-03 17:40 +0200 |
| Articles | 9 — 7 participants |
Back to article view | Back to linux.debian.user
Re: hostname bolakim53@mail2tor.com - 2018-02-18 17:50 +0100
Re: hostname Greg Wooledge <wooledg@eeg.ccf.org> - 2018-02-19 17:40 +0100
Re: hostname Reco <recoverym4n@gmail.com> - 2018-02-19 18:00 +0100
Re: hostname Richard Hector <richard@walnut.gen.nz> - 2018-02-21 01:50 +0100
Re: hostname Greg Wooledge <wooledg@eeg.ccf.org> - 2018-02-21 15:10 +0100
Re: hostname Dan Purgert <dan@djph.net> - 2018-02-21 15:50 +0100
Re: hostname David Wright <deblis@lionunicorn.co.uk> - 2018-03-31 11:00 +0200
Re: hostname john doe <johndoe65534@mail.com> - 2018-04-03 08:40 +0200
Re: hostname David Wright <deblis@lionunicorn.co.uk> - 2018-04-03 17:40 +0200
| From | bolakim53@mail2tor.com |
|---|---|
| Date | 2018-02-18 17:50 +0100 |
| Subject | Re: hostname |
| Message-ID | <vkAk1-7wk-1@gated-at.bofh.it> |
Subject: hostname Re: hostname to debian-user@lists.debian.org terminology confusion : there are so many configuration & choices that it is bit out of scope. e.g on a lan or a mesh network. > is my hostname transmitted as soon as i am connected ? >>>> if you are operating under the assumption that your hostname is being broadcast to the entire network so that your peers can open your shares, well, that's not a thing in Linux-world. >>>> That's only a thing in Windows-world. >>>> linux/Unix hostname resolution is only done by consulting respected services, not by everyone announcing themselves in broadcast mode. *so the hostname is not shared & not transmitted *blindly. >>>> If you use a DHCP client, then probably it is sent by the DHCP client to the DHCP server whenever it's time to get a new IP address. >>>> This will occur when you boot, and whenever your IP address lease expires. *the response was exactly that i asked. In fact the topic came from an old article about the threat to be hacked/targeted : backdoor & hostname_nsa tool. Anyway the new equipment/hardware could solve all these 'confusion' in a near future by simplifying the terminology and perhaps implementing officially backdoors (software too ? on the tor blog someone asked the question - no response). i wonder if the 'independent' dns will be "allowed" but it is another story. o-t >>>>Well there is a heavy brainwash in Europe regarding guns in the US, but some of us know very well where the real problem is. * i do not think so : the mutual non-comprehension became a crime.
[toc] | [next] | [standalone]
| From | Greg Wooledge <wooledg@eeg.ccf.org> |
|---|---|
| Date | 2018-02-19 17:40 +0100 |
| Message-ID | <vkWDT-5pu-1@gated-at.bofh.it> |
| In reply to | #192618 |
On Sun, Feb 18, 2018 at 04:23:53PM -0000, bolakim53@mail2tor.com wrote: > In fact the topic came from an old article about the threat to be > hacked/targeted : backdoor & hostname_nsa tool. > Anyway the new equipment/hardware could solve all these 'confusion' in a > near future by simplifying the terminology and perhaps implementing > officially backdoors (software too ? on the tor blog someone asked the > question - no response). i wonder if the 'independent' dns will be > "allowed" but it is another story. What on EARTH are you talking about now? You appear to be concerned that your hostname contains secret information, and that having your hostname "leaked" to the rest of the world will be an issue for you? If that's the case, try not putting secret information into your hostname. E.g. naming your machine my_mothers_maiden_name_is_johnson might be a bad idea. Hope this helps. P.S. Your text formatting is quite difficult to read. Please separate your lines from the quoted lines with a blank line, and please do not indent your lines.
[toc] | [prev] | [next] | [standalone]
| From | Reco <recoverym4n@gmail.com> |
|---|---|
| Date | 2018-02-19 18:00 +0100 |
| Message-ID | <vkWXf-5wG-1@gated-at.bofh.it> |
| In reply to | #192686 |
Hi. On Mon, Feb 19, 2018 at 11:32:46AM -0500, Greg Wooledge wrote: > On Sun, Feb 18, 2018 at 04:23:53PM -0000, bolakim53@mail2tor.com wrote: > > In fact the topic came from an old article about the threat to be > > hacked/targeted : backdoor & hostname_nsa tool. > > Anyway the new equipment/hardware could solve all these 'confusion' in a > > near future by simplifying the terminology and perhaps implementing > > officially backdoors (software too ? on the tor blog someone asked the > > question - no response). i wonder if the 'independent' dns will be > > "allowed" but it is another story. > > What on EARTH are you talking about now? > > You appear to be concerned that your hostname contains secret information, > and that having your hostname "leaked" to the rest of the world will be > an issue for you? > > If that's the case, try not putting secret information into your > hostname. E.g. naming your machine my_mothers_maiden_name_is_johnson > might be a bad idea. It is a bad idea regardless of information disclosure as it violates RFC 1123. > Hope this helps. > > P.S. Your text formatting is quite difficult to read. Please separate > your lines from the quoted lines with a blank line, and please do not > indent your lines. OP's using SquirrelMail, which is known to produce pure gibberish instead of coherent text. Reco
[toc] | [prev] | [next] | [standalone]
| From | Richard Hector <richard@walnut.gen.nz> |
|---|---|
| Date | 2018-02-21 01:50 +0100 |
| Message-ID | <vlqLD-7Xq-1@gated-at.bofh.it> |
| In reply to | #192686 |
[Multipart message — attachments visible in raw view] — view raw
On 20/02/18 05:32, Greg Wooledge wrote: > You appear to be concerned that your hostname contains secret information, > and that having your hostname "leaked" to the rest of the world will be > an issue for you? > > If that's the case, try not putting secret information into your > hostname. E.g. naming your machine my_mothers_maiden_name_is_johnson > might be a bad idea. I haven't been following the thread, but to be fair hostnames could sometimes contain info that you might not want to spread around unnecessarily. Eg "pg1-linode-tx" might be a useful hostname for your first Texas DB VM, but you might not want to reveal that much info to the whole world. Richard
[toc] | [prev] | [next] | [standalone]
| From | Greg Wooledge <wooledg@eeg.ccf.org> |
|---|---|
| Date | 2018-02-21 15:10 +0100 |
| Message-ID | <vlDfP-7Oh-11@gated-at.bofh.it> |
| In reply to | #192798 |
On Wed, Feb 21, 2018 at 01:48:32PM +1300, Richard Hector wrote: > On 20/02/18 05:32, Greg Wooledge wrote: > > You appear to be concerned that your hostname contains secret information, > > and that having your hostname "leaked" to the rest of the world will be > > an issue for you? > > > > If that's the case, try not putting secret information into your > > hostname. E.g. naming your machine my_mothers_maiden_name_is_johnson > > might be a bad idea. > > I haven't been following the thread, but to be fair hostnames could > sometimes contain info that you might not want to spread around > unnecessarily. Eg "pg1-linode-tx" might be a useful hostname for your > first Texas DB VM, but you might not want to reveal that much info to > the whole world. Then don't choose that hostname. That's the entire point I'm trying to make. In Debian, you get to choose what your hostname is. If you want it to be as meaningless as possible, use something like pwgen to generate a random string for you. Why this is even being *discussed* is beyond me. I still don't understand the OP's rants. Maybe it's a Windows-user thing?
[toc] | [prev] | [next] | [standalone]
| From | Dan Purgert <dan@djph.net> |
|---|---|
| Date | 2018-02-21 15:50 +0100 |
| Message-ID | <vlDSy-81v-7@gated-at.bofh.it> |
| In reply to | #192816 |
Greg Wooledge wrote: > Why this is even being *discussed* is beyond me. I still don't understand > the OP's rants. Maybe it's a Windows-user thing? I think you were spot on with the mobile-user thing in your first or second response. -- |_|O|_| Registered Linux user #585947 |_|_|O| Github: https://github.com/dpurgert |O|O|O| PGP: 05CA 9A50 3F2E 1335 4DC5 4AEE 8E11 DDF3 1279 A281
[toc] | [prev] | [next] | [standalone]
| From | David Wright <deblis@lionunicorn.co.uk> |
|---|---|
| Date | 2018-03-31 11:00 +0200 |
| Message-ID | <vzkwF-2WD-1@gated-at.bofh.it> |
| In reply to | #192816 |
On Wed 21 Feb 2018 at 09:03:41 (-0500), Greg Wooledge wrote: > On Wed, Feb 21, 2018 at 01:48:32PM +1300, Richard Hector wrote: > > On 20/02/18 05:32, Greg Wooledge wrote: > > > You appear to be concerned that your hostname contains secret information, > > > and that having your hostname "leaked" to the rest of the world will be > > > an issue for you? > > > > > > If that's the case, try not putting secret information into your > > > hostname. E.g. naming your machine my_mothers_maiden_name_is_johnson > > > might be a bad idea. > > > > I haven't been following the thread, but to be fair hostnames could > > sometimes contain info that you might not want to spread around > > unnecessarily. Eg "pg1-linode-tx" might be a useful hostname for your > > first Texas DB VM, but you might not want to reveal that much info to > > the whole world. > > Then don't choose that hostname. That's the entire point I'm trying > to make. In Debian, you get to choose what your hostname is. If you > want it to be as meaningless as possible, use something like pwgen to > generate a random string for you. > > Why this is even being *discussed* is beyond me. I still don't understand > the OP's rants. Maybe it's a Windows-user thing? It may simply be that the OP has read RFC 8117. Section 5 could cause consternation to john doe! https://lists.debian.org/debian-user/2018/03/msg01075.html (And to D Libes, author of RFC 1178.) Cheers, David.
[toc] | [prev] | [next] | [standalone]
| From | john doe <johndoe65534@mail.com> |
|---|---|
| Date | 2018-04-03 08:40 +0200 |
| Message-ID | <vAnLP-4bU-7@gated-at.bofh.it> |
| In reply to | #194359 |
On 3/30/2018 6:30 PM, David Wright wrote: > On Wed 21 Feb 2018 at 09:03:41 (-0500), Greg Wooledge wrote: >> On Wed, Feb 21, 2018 at 01:48:32PM +1300, Richard Hector wrote: >>> On 20/02/18 05:32, Greg Wooledge wrote: >>>> You appear to be concerned that your hostname contains secret information, >>>> and that having your hostname "leaked" to the rest of the world will be >>>> an issue for you? >>>> >>>> If that's the case, try not putting secret information into your >>>> hostname. E.g. naming your machine my_mothers_maiden_name_is_johnson >>>> might be a bad idea. >>> >>> I haven't been following the thread, but to be fair hostnames could >>> sometimes contain info that you might not want to spread around >>> unnecessarily. Eg "pg1-linode-tx" might be a useful hostname for your >>> first Texas DB VM, but you might not want to reveal that much info to >>> the whole world. >> >> Then don't choose that hostname. That's the entire point I'm trying >> to make. In Debian, you get to choose what your hostname is. If you >> want it to be as meaningless as possible, use something like pwgen to >> generate a random string for you. >> >> Why this is even being *discussed* is beyond me. I still don't understand >> the OP's rants. Maybe it's a Windows-user thing? > > It may simply be that the OP has read RFC 8117. > Section 5 could cause consternation to john doe! This only applies to server facing internet if my understanding is correct. -- John Doe
[toc] | [prev] | [next] | [standalone]
| From | David Wright <deblis@lionunicorn.co.uk> |
|---|---|
| Date | 2018-04-03 17:40 +0200 |
| Message-ID | <vAwcq-1kp-3@gated-at.bofh.it> |
| In reply to | #194432 |
On Tue 03 Apr 2018 at 08:39:31 (+0200), john doe wrote: > On 3/30/2018 6:30 PM, David Wright wrote: > >On Wed 21 Feb 2018 at 09:03:41 (-0500), Greg Wooledge wrote: > >>On Wed, Feb 21, 2018 at 01:48:32PM +1300, Richard Hector wrote: > >>>On 20/02/18 05:32, Greg Wooledge wrote: > >>>>You appear to be concerned that your hostname contains secret information, > >>>>and that having your hostname "leaked" to the rest of the world will be > >>>>an issue for you? > >>>> > >>>>If that's the case, try not putting secret information into your > >>>>hostname. E.g. naming your machine my_mothers_maiden_name_is_johnson > >>>>might be a bad idea. > >>> > >>>I haven't been following the thread, but to be fair hostnames could > >>>sometimes contain info that you might not want to spread around > >>>unnecessarily. Eg "pg1-linode-tx" might be a useful hostname for your > >>>first Texas DB VM, but you might not want to reveal that much info to > >>>the whole world. > >> > >>Then don't choose that hostname. That's the entire point I'm trying > >>to make. In Debian, you get to choose what your hostname is. If you > >>want it to be as meaningless as possible, use something like pwgen to > >>generate a random string for you. > >> > >>Why this is even being *discussed* is beyond me. I still don't understand > >>the OP's rants. Maybe it's a Windows-user thing? > > > >It may simply be that the OP has read RFC 8117. > >Section 5 could cause consternation to john doe! > > This only applies to server facing internet if my understanding is correct. Difficult to reconcile this with the RFC's: "Suppose an adversary wants to track the people connecting to a specific Wi-Fi hot spot, for example, in a railroad station. Assume that the adversary is able to retrieve the hostname used by a specific laptop. That, in itself, might not be enough to identify the laptop's owner. Suppose, however, that the adversary observes that the laptop name is "dthaler-laptop" and that the laptop has established a VPN connection to the Microsoft corporate network. The two pieces of information, put together, firmly point to Dave Thaler, employed by Microsoft. The identification is successful." Difficult to reconcile this with §5's: "There are several ways to remedy the hostname practices. We could instruct people to just turn off any protocol that leaks hostnames, at least when they visit some "insecure" place." Cheers, David.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.user
csiph-web