Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #180112 > unrolled thread

Exim4 problem?

Started byCharlie <taoquester@gmail.com>
First post2017-04-14 02:40 +0200
Last post2017-04-15 00:30 +0200
Articles 9 — 4 participants

Back to article view | Back to linux.debian.user


Contents

  Exim4 problem? Charlie <taoquester@gmail.com> - 2017-04-14 02:40 +0200
    Re: Exim4 problem? songbird <songbird@anthive.com> - 2017-04-14 04:30 +0200
      Re: Exim4 problem? Charlie <taoquester@gmail.com> - 2017-04-14 09:00 +0200
        Re: Exim4 problem? deloptes <deloptes@gmail.com> - 2017-04-14 11:00 +0200
          Re: Exim4 problem? Charlie <taoquester@gmail.com> - 2017-04-14 14:00 +0200
    Re: Exim4 problem? Joe <joe@jretrading.com> - 2017-04-14 10:10 +0200
      Re: Exim4 problem? Charlie <taoquester@gmail.com> - 2017-04-14 14:10 +0200
        Re: Exim4 problem? deloptes <deloptes@gmail.com> - 2017-04-14 15:40 +0200
          Re: Exim4 problem? Charlie <taoquester@gmail.com> - 2017-04-15 00:30 +0200

#180112 — Exim4 problem?

FromCharlie <taoquester@gmail.com>
Date2017-04-14 02:40 +0200
SubjectExim4 problem?
Message-ID<tvXrk-2iA-3@gated-at.bofh.it>
Received this on attempted upgrade:

systemctl status exim4.service
● exim4.service - LSB: exim Mail Transport Agent
   Loaded: loaded (/etc/init.d/exim4; generated; vendor preset: enabled)
   Active: failed (Result: resources) since Fri 2017-04-14 10:24:05
AEST; 4min 44s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 9436 ExecStart=/etc/init.d/exim4 start (code=exited,
status=0/SUCCESS)

Assume nothing I can do? Something that needs to be done higher up the scale?

Can't uninstall or purge exim4 either.

Be well,
Charlie

[toc] | [next] | [standalone]


#180113

Fromsongbird <songbird@anthive.com>
Date2017-04-14 04:30 +0200
Message-ID<tvZ9L-3BM-3@gated-at.bofh.it>
In reply to#180112
Charlie wrote:
> Received this on attempted upgrade:
>
> systemctl status exim4.service
> ● exim4.service - LSB: exim Mail Transport Agent
>    Loaded: loaded (/etc/init.d/exim4; generated; vendor preset: enabled)
>    Active: failed (Result: resources) since Fri 2017-04-14 10:24:05
> AEST; 4min 44s ago
>      Docs: man:systemd-sysv-generator(8)
>   Process: 9436 ExecStart=/etc/init.d/exim4 start (code=exited,
> status=0/SUCCESS)
>
> Assume nothing I can do? Something that needs to be done higher up the scale?
>
> Can't uninstall or purge exim4 either.

  hmm...

  i'm assuming this is on testing/stretch version?


  is there something still running?  as it looks
like to me that it tried to restart when perhaps
another instance was running or something like
that...

  why would you need to uninstall or purge?  did
you interrupt the upgrade?  are your apt/dpkg
files inconsistent or showing dependency problems?

  what does systemctl status exim4 say
after you do a systemctl stop exim4

  ?

  and then a start?

  does it restart?

  check /var/log/apt/term.log
  and /var/log/dpkg.log

  or does something show up in the systemd 
journal from that timeframe?

  see if there are any messages in those that may
give an idea of what is going on.

  i had exim4 upgrade go through today too.
because there were so many processes still
out of date according to checkrestart i
rebooted before doing anything else.

  i didn't see any errors in the upgrade or
in the reboot and my exim4 has been chugging
along all day.


  songbird

[toc] | [prev] | [next] | [standalone]


#180114

FromCharlie <taoquester@gmail.com>
Date2017-04-14 09:00 +0200
Message-ID<tw3n3-6h6-1@gated-at.bofh.it>
In reply to#180113
On 14/04/2017, songbird <songbird@anthive.com> wrote:
> Charlie wrote:
>> Received this on attempted upgrade:
>>
>> systemctl status exim4.service
>> ● exim4.service - LSB: exim Mail Transport Agent
>>    Loaded: loaded (/etc/init.d/exim4; generated; vendor preset: enabled)
>>    Active: failed (Result: resources) since Fri 2017-04-14 10:24:05
>> AEST; 4min 44s ago
>>      Docs: man:systemd-sysv-generator(8)
>>   Process: 9436 ExecStart=/etc/init.d/exim4 start (code=exited,
>> status=0/SUCCESS)
>>
>> Assume nothing I can do? Something that needs to be done higher up the
>> scale?
>>
>> Can't uninstall or purge exim4 either.
>
>   hmm...
>
>   i'm assuming this is on testing/stretch version?
>
>
>   is there something still running?  as it looks
> like to me that it tried to restart when perhaps
> another instance was running or something like
> that...
>
>   why would you need to uninstall or purge?  did
> you interrupt the upgrade?  are your apt/dpkg
> files inconsistent or showing dependency problems?
>
>   what does systemctl status exim4 say
> after you do a systemctl stop exim4
>
>   ?
>
>   and then a start?
>
>   does it restart?
>
>   check /var/log/apt/term.log
>   and /var/log/dpkg.log
>
>   or does something show up in the systemd
> journal from that timeframe?
>
>   see if there are any messages in those that may
> give an idea of what is going on.
>
>   i had exim4 upgrade go through today too.
> because there were so many processes still
> out of date according to checkrestart i
> rebooted before doing anything else.
>
>   i didn't see any errors in the upgrade or
> in the reboot and my exim4 has been chugging
> along all day.
>
>
>   songbird

Thanks Songbird,

Debian testing is correct.

Posted the top part of what systemctl status exim4 in the first email.

Hadn't done systemctl stop exim4

After systemctl stop exim4 reads like this:

systemctl status exim4
● exim4.service - LSB: exim Mail Transport Agent
   Loaded: loaded (/etc/init.d/exim4; generated; vendor preset: enabled)
   Active: failed (Result: resources) since Fri 2017-04-14 16:22:17
AEST; 1min 41s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1489 ExecStart=/etc/init.d/exim4 start (code=exited,
status=0/SUCCESS)

Apr 14 16:22:13 taogypsy systemd[1]: Starting LSB: exim Mail Transport Agent...
Apr 14 16:22:17 taogypsy exim4[1489]: Starting MTA: exim4.
Apr 14 16:22:17 taogypsy exim4[1489]: ALERT: exim paniclog
/var/log/exim4/paniclog has non-zero size, mail system possibly broken
Apr 14 16:22:17 taogypsy systemd[1]: exim4.service: PID file
/run/exim4/exim.pid not readable (yet?) after start: No such file or
directory
Apr 14 16:22:17 taogypsy systemd[1]: exim4.service: Daemon never wrote
its PID file. Failing.
Apr 14 16:22:17 taogypsy systemd[1]: Failed to start LSB: exim Mail
Transport Agent.
Apr 14 16:22:17 taogypsy systemd[1]: exim4.service: Unit entered failed state.
Apr 14 16:22:17 taogypsy systemd[1]: exim4.service: Failed with result
'resources'.

/var/log/exim4/paniclog says:

2017-04-14 10:13:04 IPv6 socket creation failed: Address family not
supported by protocol

ipv6 has been disabled for the 6 years or so I have had this regularly
upgraded Debian system installed.
/etc/default/grub
GRUB_CMDLINE_LINUX="ipv6.disable=1"

The reason: I have a router that doesn't do ipv6. Also I was told that
satellite, which I am locked into, does not do ipv6 I have never
required it and have never changed it.

Then did: systemctl start exim4

 systemctl start exim4

Job for exim4.service failed because of unavailable resources or
another system error.
See "systemctl status exim4.service" and "journalctl -xe" for details.

journalctl -xe

Apr 14 16:40:15 taogypsy systemd[1]: Starting LSB: exim Mail Transport Agent...
-- Subject: Unit exim4.service has begun start-up
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- Unit exim4.service has begun starting up.
Apr 14 16:40:17 taogypsy exim4[2209]: Starting MTA: exim4.
Apr 14 16:40:17 taogypsy exim4[2209]: ALERT: exim paniclog
/var/log/exim4/paniclog has non-zero size, mail system possibly broken
Apr 14 16:40:17 taogypsy systemd[1]: exim4.service: PID file
/run/exim4/exim.pid not readable (yet?) after start: No such file or
directory
Apr 14 16:40:17 taogypsy systemd[1]: exim4.service: Daemon never wrote
its PID file. Failing.
Apr 14 16:40:17 taogypsy systemd[1]: Failed to start LSB: exim Mail
Transport Agent.
-- Subject: Unit exim4.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
-- 
-- Unit exim4.service has failed.
-- 
-- The result is failed.
Apr 14 16:40:17 taogypsy systemd[1]: exim4.service: Unit entered failed state.
Apr 14 16:40:17 taogypsy systemd[1]: exim4.service: Failed with result
'resources'.
Apr 14 16:40:29 taogypsy kernel: iptables denied: IN=eth0 OUT=
MAC=01:00:5e:00:00:01:08:86:3b:89:13:c6:08:00 SRC=192.168.2.1
DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1
Apr 14 16:40:32 taogypsy kernel: iptables denied: IN=eth0 OUT=
MAC=01:00:5e:00:00:01:08:86:3b:89:13:c6:08:00 SRC=192.168.2.1
DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1
Apr 14 16:41:29 taogypsy kernel: iptables denied: IN=eth0 OUT=
MAC=01:00:5e:00:00:01:08:86:3b:89:13:c6:08:00 SRC=192.168.2.1
DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1
Apr 14 16:41:32 taogypsy kernel: iptables denied: IN=eth0 OUT=
MAC=01:00:5e:00:00:01:08:86:3b:89:13:c6:08:00 SRC=192.168.2.1
DST=224.0.0.1 LEN=32 TOS=0x00 PREC=0x00 TTL=1

This is something that has happened after the last upgrade. Won't
upgrade now with this error.

I wanted to remove or purge exim4 if it was a problem. That's why.
Would have reinstalled when it was fixed.

So do I need to use ipv6 now? If so why?

[toc] | [prev] | [next] | [standalone]


#180117

Fromdeloptes <deloptes@gmail.com>
Date2017-04-14 11:00 +0200
Message-ID<tw5fb-7mS-1@gated-at.bofh.it>
In reply to#180114
Charlie wrote:

> /var/log/exim4/paniclog has non-zero size, mail system possibly broken

This is common for exim . 
1. check the paniclog
2. take actions if needed based on 1.
3. remove paniclog
4. proceed with restart

it has nothing to do with systemd. it is exims "normal" behavior 

regards

[toc] | [prev] | [next] | [standalone]


#180124

FromCharlie <taoquester@gmail.com>
Date2017-04-14 14:00 +0200
Message-ID<tw83n-Dy-1@gated-at.bofh.it>
In reply to#180117
On 14/04/2017, deloptes <deloptes@gmail.com> wrote:
> Charlie wrote:
>
>> /var/log/exim4/paniclog has non-zero size, mail system possibly broken
>
> This is common for exim .
> 1. check the paniclog
> 2. take actions if needed based on 1.
> 3. remove paniclog
> 4. proceed with restart
>
> it has nothing to do with systemd. it is exims "normal" behavior
>
> regards

Thank you for that suggestion.

It didn't work. But doesn't matter as this system has been up and
running many years and it's time to reinstall at any rate.

Thank you again,
Charlie

[toc] | [prev] | [next] | [standalone]


#180115

FromJoe <joe@jretrading.com>
Date2017-04-14 10:10 +0200
Message-ID<tw4sN-77g-1@gated-at.bofh.it>
In reply to#180112
On Fri, 14 Apr 2017 10:35:42 +1000
Charlie <taoquester@gmail.com> wrote:

> Received this on attempted upgrade:
> 
> systemctl status exim4.service
> ● exim4.service - LSB: exim Mail Transport Agent
>    Loaded: loaded (/etc/init.d/exim4; generated; vendor preset:
> enabled) Active: failed (Result: resources) since Fri 2017-04-14
> 10:24:05 AEST; 4min 44s ago
>      Docs: man:systemd-sysv-generator(8)
>   Process: 9436 ExecStart=/etc/init.d/exim4 start (code=exited,
> status=0/SUCCESS)
> 
> Assume nothing I can do? Something that needs to be done higher up
> the scale?
> 
> Can't uninstall or purge exim4 either.
> 


I don't know if it helps, it may be a red herring, but...

 ..years ago, long before systemd, I had this happen to exim4 during a
dist-upgrade of one stable to the next. The exim4 upgrade stuck part of
the way through, and would go neither forward nor back nor run, and even
dpkg was not able to remove it to reinstall. In the end, I had to
manually delete files to get it to the point where I could reinstall
from scratch.

The reason turned out to be that exim4 needed a version upgrade to one
which not only didn't honour debconf statements in the configuration
file, but was violently sick on finding them, to the extent of breaking
the upgrade. It installed fine with a default config file, and I then
transferred my configurations to that.

So this just *might* be an incompatible configuration issue, and you
just *might* have to rip files out by hand. There was certainly an
issue with exim4, which may not have been fixed, which resulted in some
kind of deadlock over old and new parts during the upgrade. Exim4
seemed to need to restart part of the way through the upgrade, and
couldn't restart with an incompatible config file.

I didn't have the means to reproduce the situation and file a useful
bug, and in any case, the developer would just have told me I should
have read the release notes for the new exim4 and not been so stupid as
to try to re-use the old config file.

-- 
Joe

[toc] | [prev] | [next] | [standalone]


#180126

FromCharlie <taoquester@gmail.com>
Date2017-04-14 14:10 +0200
Message-ID<tw8d3-VF-1@gated-at.bofh.it>
In reply to#180115
On 14/04/2017, Joe <joe@jretrading.com> wrote:
> On Fri, 14 Apr 2017 10:35:42 +1000
> Charlie <taoquester@gmail.com> wrote:
>
>> Received this on attempted upgrade:
>>
>> systemctl status exim4.service
>> ● exim4.service - LSB: exim Mail Transport Agent
>>    Loaded: loaded (/etc/init.d/exim4; generated; vendor preset:
>> enabled) Active: failed (Result: resources) since Fri 2017-04-14
>> 10:24:05 AEST; 4min 44s ago
>>      Docs: man:systemd-sysv-generator(8)
>>   Process: 9436 ExecStart=/etc/init.d/exim4 start (code=exited,
>> status=0/SUCCESS)
>>
>> Assume nothing I can do? Something that needs to be done higher up
>> the scale?
>>
>> Can't uninstall or purge exim4 either.
>>
>
>
> I don't know if it helps, it may be a red herring, but...
>
>  ..years ago, long before systemd, I had this happen to exim4 during a
> dist-upgrade of one stable to the next. The exim4 upgrade stuck part of
> the way through, and would go neither forward nor back nor run, and even
> dpkg was not able to remove it to reinstall. In the end, I had to
> manually delete files to get it to the point where I could reinstall
> from scratch.
>
> The reason turned out to be that exim4 needed a version upgrade to one
> which not only didn't honour debconf statements in the configuration
> file, but was violently sick on finding them, to the extent of breaking
> the upgrade. It installed fine with a default config file, and I then
> transferred my configurations to that.
>
> So this just *might* be an incompatible configuration issue, and you
> just *might* have to rip files out by hand. There was certainly an
> issue with exim4, which may not have been fixed, which resulted in some
> kind of deadlock over old and new parts during the upgrade. Exim4
> seemed to need to restart part of the way through the upgrade, and
> couldn't restart with an incompatible config file.
>
> I didn't have the means to reproduce the situation and file a useful
> bug, and in any case, the developer would just have told me I should
> have read the release notes for the new exim4 and not been so stupid as
> to try to re-use the old config file.
>
> --
> Joe

Thank you.

It didn't work.

Put exim4 on hold, purged it with dpkg at some point.

Then systematically removed everything I could find of exim4, piece by
piece and at each step tried to upgrade the system with the same error
message. Removed the panic.log each time as well and finally the
/var/exim4 directory as the last thing. Several reboots, almost after
each step.

Still came up with the same error message.

It doesn't matter. This system needs to be reinstalled, so I won't
bother with updates and upgrades and when I reinstall it, I will
remove exim4 right from the word go and see how that works.

Thank you for your suggestion, it was another path to follow.
Charlie

[toc] | [prev] | [next] | [standalone]


#180129

Fromdeloptes <deloptes@gmail.com>
Date2017-04-14 15:40 +0200
Message-ID<tw9Ca-1Db-1@gated-at.bofh.it>
In reply to#180126
Charlie wrote:

> It doesn't matter. This system needs to be reinstalled, so I won't
> bother with updates and upgrades and when I reinstall it, I will
> remove exim4 right from the word go and see how that works.

you could identify the reason for the misbehavior by looking at paniclog and
mainlog

but proceed as you wish

regards

[toc] | [prev] | [next] | [standalone]


#180145

FromCharlie <taoquester@gmail.com>
Date2017-04-15 00:30 +0200
Message-ID<twhT3-6QO-7@gated-at.bofh.it>
In reply to#180129
On 14/04/2017, deloptes <deloptes@gmail.com> wrote:
> Charlie wrote:
>
>> It doesn't matter. This system needs to be reinstalled, so I won't
>> bother with updates and upgrades and when I reinstall it, I will
>> remove exim4 right from the word go and see how that works.
>
> you could identify the reason for the misbehavior by looking at paniclog
> and
> mainlog
>
> but proceed as you wish
>
> regards

Thank you for your help and advice. There was no enlightenment that
would assist me in those either of those.

Everything is working well. One thing I have noticed working even
better since purging exim4, but that could also be due to the updates
installed. When I rebuild this system I will think twice before
installing exim again.

It's all good. Thank you.
Charlie

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.user


csiph-web