Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #179342 > unrolled thread

Apt trusted.gpg file problems

Started byMiltiades Vasiliades <miltosv@outlook.com.gr>
First post2017-03-26 11:30 +0200
Last post2017-03-26 15:50 +0200
Articles 5 — 5 participants

Back to article view | Back to linux.debian.user


Contents

  Apt trusted.gpg file problems Miltiades Vasiliades <miltosv@outlook.com.gr> - 2017-03-26 11:30 +0200
    Re: Apt trusted.gpg file problems <tomas@tuxteam.de> - 2017-03-26 12:00 +0200
    Re: Apt trusted.gpg file problems SDA <marathon.durandal@gmail.com> - 2017-03-26 15:00 +0200
    Re: Apt trusted.gpg file problems Frank <zuiderduin@gmx.com> - 2017-03-26 15:30 +0200
    Re: Apt trusted.gpg file problems Cindy-Sue Causey <butterflybytes@gmail.com> - 2017-03-26 15:50 +0200

#179342 — Apt trusted.gpg file problems

FromMiltiades Vasiliades <miltosv@outlook.com.gr>
Date2017-03-26 11:30 +0200
SubjectApt trusted.gpg file problems
Message-ID<tpcEN-6f8-1@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

I tried switching the mirrors through synaptic then synaptic as usual asked to refresh however the refresh ended with the following errors

W: http://repo.steampowered.com/steam/dists/precise/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://security.debian.org/…/dists/stretch/updates/InRelease<http://security.debian.org/debian-security/dists/stretch/updates/InRelease>: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
W: http://ftp.de.debian.org/debian/dists/stretch/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.


Any ideas how to resolve that issue?


Thank you!

[toc] | [next] | [standalone]


#179347

From<tomas@tuxteam.de>
Date2017-03-26 12:00 +0200
Message-ID<tpd7P-6vi-1@gated-at.bofh.it>
In reply to#179342
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Sun, Mar 26, 2017 at 09:03:31AM +0000, Miltiades Vasiliades wrote:
> I tried switching the mirrors through synaptic then synaptic as usual asked to refresh however the refresh ended with the following errors
> 
> W: http://repo.steampowered.com/steam/dists/precise/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
> W: http://security.debian.org/…/dists/stretch/updates/InRelease<http://security.debian.org/debian-security/dists/stretch/updates/InRelease>: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
> W: http://ftp.de.debian.org/debian/dists/stretch/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
> 
> 
> Any ideas how to resolve that issue?

Hm. Some newfangled sandboxing stuff, it seems. On my system (no synaptic,
no desktop environment), the trusted keys are just readable by root:

  tomas@rasputin:~$ ls -l /etc/apt/trusted.gpg
  -rw------- 1 root root 0 Aug  7  2012 /etc/apt/trusted.gpg

I *gues* this _apt thing is to allow running synaptic as non-root (which
in itself is a Good Thing, one might guess).

Can you do the following, on a console:

  grep "_apt" /etc/passwd

(this is to see whether, and how an user named _apt is known to your
system) and

  ls -l /etc/apt/trusted.gpg

(this is to see the file's permissions, etc.), and then perhaps

  getfacl /etc/apt/trusted.gpg

(more info about the access controls to that file) and post your
results here?

Regards
- -- tomás
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAljXjtYACgkQBcgs9XrR2kbKowCfXaHGW1yy4nJgc5v84893a6yg
lv8Anj2/q5fq5pm5S9GIVUhuvc7+87VL
=uVEh
-----END PGP SIGNATURE-----

[toc] | [prev] | [next] | [standalone]


#179359

FromSDA <marathon.durandal@gmail.com>
Date2017-03-26 15:00 +0200
Message-ID<tpfW2-8tD-3@gated-at.bofh.it>
In reply to#179342
On Sun, Mar 26, 2017 at 09:03:31AM +0000, Miltiades Vasiliades wrote:
> I tried switching the mirrors through synaptic then synaptic as usual asked to refresh however the refresh ended with the following errors
> 
> W: http://repo.steampowered.com/steam/dists/precise/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
> W: http://security.debian.org/…/dists/stretch/updates/InRelease<http://security.debian.org/debian-security/dists/stretch/updates/InRelease>: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
> W: http://ftp.de.debian.org/debian/dists/stretch/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.
> 
> 
> Any ideas how to resolve that issue?

Have noticed the exact same problem on a clients desktop too, after installing via the Stretch RC2 installer & subsequent upgrade via synaptic.

[toc] | [prev] | [next] | [standalone]


#179360

FromFrank <zuiderduin@gmx.com>
Date2017-03-26 15:30 +0200
Message-ID<tpgp3-wE-3@gated-at.bofh.it>
In reply to#179342
Op 26-03-17 om 11:03 schreef Miltiades Vasiliades:
> I tried switching the mirrors through synaptic then synaptic as usual
> asked to refresh however the refresh ended with the following errors
>
> W: http://repo.steampowered.com/steam/dists/precise/InRelease: The
> key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is
> not readable by user '_apt' executing apt-key.
> W: http://security.debian.org/…/dists/stretch/updates/InRelease
> <http://security.debian.org/debian-security/dists/stretch/updates/InRelease>:
> The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file
> is not readable by user '_apt' executing apt-key.
> W: http://ftp.de.debian.org/debian/dists/stretch/InRelease: The key(s)
> in the keyring /etc/apt/trusted.gpg are ignored as the file is not
> readable by user '_apt' executing apt-key.
>
>
> Any ideas how to resolve that issue?

On my stretch system, the permissions for that file are 0644 rather than 
0600. Check what they are on your system and change them if necessary. I 
assume you know how to do that as you're apparently using 
stretch/testing (the _apt user only exists since apt version 
1.1~exp<something>, which isn't available for jessie).

Regards,
Frank

[toc] | [prev] | [next] | [standalone]


#179361

FromCindy-Sue Causey <butterflybytes@gmail.com>
Date2017-03-26 15:50 +0200
Message-ID<tpgIp-Em-5@gated-at.bofh.it>
In reply to#179342
On 3/26/17, Miltiades Vasiliades <miltosv@outlook.com.gr> wrote:
> I tried switching the mirrors through synaptic then synaptic as usual asked
> to refresh however the refresh ended with the following errors
>
> W: http://repo.steampowered.com/steam/dists/precise/InRelease: The key(s) in
> the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by
> user '_apt' executing apt-key.
> W:
> http://security.debian.org/…/dists/stretch/updates/InRelease<http://security.debian.org/debian-security/dists/stretch/updates/InRelease>:
> The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is
> not readable by user '_apt' executing apt-key.
> W: http://ftp.de.debian.org/debian/dists/stretch/InRelease: The key(s) in
> the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by
> user '_apt' executing apt-key.
>
>
> Any ideas how to resolve that issue?


DISCLAIMER: This may be apples and oranges thus not even close, but am
writing anyway because I've seen something similar to that "not
readable by user '_apt'" part.

That said...

*heh!* That's the message I've had before. I referenced it somewhere
on here a while back. Do you have anything symlinked?

In my case, I had /var/cache/apt/archives symlinked because it's
massive k/t being on dialup yada-yada. I went through and looked at
permissions in my case. They didn't seem to change, but that
symlinking definitely borked/broked it somehow.

I thought maybe there was a permissions disintegration because my
symlinking traveled a few levels into a non-standard (homegrown
personalized) directory tree on an external hard drive.

As a test, I tried rsync copying over the directory tree from the
primary one that worked. Rsync very nicely properly preserves
permissions. I then symlinked to that new directory, but at that
moment it still did not work......

One thing I don't know is if it has always been like that, or if it is
something that became a new bug somehow. The error is new for me in
the last six months to a year or so.

An important detail that I can't remember is if I was symlinking in
this manner prior to that time. That would have shown if things used
to work and now don't... or not.

This is the deal that turned out to be the culprit in my MANY failed
debootstrap efforts. There would be an error message about _apt and
permissions before debootstrap finished. I'd run debootstrap again
because that works for apt-get (yeah, I know, apples, oranges, former
bleached blonde, but anyway).

There'd be no error message on that second run, and it missed my
consciousness that things didn't go all the way through to the normal
successful install message. I'd chroot in, and that's when root's "I
Have No Name!" identity crisis slash eventual debootstrap install fail
came into play.

Just thinking out loud..... :)

Cindy :)

-- 
Cindy-Sue Causey
Talking Rock, Pickens County, Georgia, USA

* runs with duct tape *

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.user


csiph-web