Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #270738 > unrolled thread
| Started by | Jörg Kastning <joerg.kastning@gmail.com> |
|---|---|
| First post | 2024-07-02 17:00 +0200 |
| Last post | 2024-07-02 21:00 +0200 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.debian.user
Cannot execute any container using podman run Jörg Kastning <joerg.kastning@gmail.com> - 2024-07-02 17:00 +0200
Re: Cannot execute any container using podman run john doe <johndoe65534@mail.com> - 2024-07-02 18:50 +0200
Re: Cannot execute any container using podman run didier gaumet <didier.gaumet@gmail.com> - 2024-07-02 20:20 +0200
[Solved] Re: Cannot execute any container using podman run Jörg Kastning <joerg.kastning@gmail.com> - 2024-07-02 21:00 +0200
| From | Jörg Kastning <joerg.kastning@gmail.com> |
|---|---|
| Date | 2024-07-02 17:00 +0200 |
| Subject | Cannot execute any container using podman run |
| Message-ID | <IVN98-7bar-5@gated-at.bofh.it> |
Dear Debian users, I have installed Podman via `sudo apt install podman` on Debian 12 (Bookworm) and setup subuids and subgids for my user to use rootless podman. However my host seems to have some issue as I'm not able to run (instantiate) any container using the `podman run` command. Please see the following code block for information regarding my installation and the error I get when trying to run some container: ~~~ :~$ podman version Client: Podman Engine Version: 4.3.1 API Version: 4.3.1 Go Version: go1.19.8 Built: Thu Jan 1 01:00:00 1970 OS/Arch: linux/amd64 :~$ podman images REPOSITORY TAG IMAGE ID CREATED SIZE docker.io/library/hello-world latest d2c94e258dcb 14 months ago 28.5 kB :~$ podman run --rm hello-world conmon: option parsing failed: Unknown option --full-attach Error: write child: broken pipe ~~~ I don't know how to troubleshoot this issue and did not find any useful search result on the web. Your guidance and help in troubleshooting is much appreciated. In case you need more information to be able to help, please let me know what you need to know. Best regards, Joerg
[toc] | [next] | [standalone]
| From | john doe <johndoe65534@mail.com> |
|---|---|
| Date | 2024-07-02 18:50 +0200 |
| Message-ID | <IVORz-7che-1@gated-at.bofh.it> |
| In reply to | #270738 |
On 7/2/24 16:38, Jörg Kastning wrote: > Dear Debian users, > > I have installed Podman via `sudo apt install podman` on Debian 12 > (Bookworm) and setup subuids and subgids for my user to use rootless > podman. > > However my host seems to have some issue as I'm not able to run > (instantiate) any container using the `podman run` command. > > Please see the following code block for information regarding my > installation and the error I get when trying to run some container: > > ~~~ > :~$ podman version > Client: Podman Engine > Version: 4.3.1 > API Version: 4.3.1 > Go Version: go1.19.8 > Built: Thu Jan 1 01:00:00 1970 > OS/Arch: linux/amd64 > > :~$ podman images > REPOSITORY TAG IMAGE ID CREATED > SIZE > docker.io/library/hello-world latest d2c94e258dcb 14 months ago > 28.5 kB > > :~$ podman run --rm hello-world > conmon: option parsing failed: Unknown option --full-attach > Error: write child: broken pipe > ~~~ > > I don't know how to troubleshoot this issue and did not find any useful > search result on the web. > > Your guidance and help in troubleshooting is much appreciated. In case > you need more information to be able to help, please let me know what > you need to know. > > Best regards, > Joerg > I would first try to purge the podman package with the autoremove option and reinstall the package. When installed, use sudo to gain root access. -- John Doe
[toc] | [prev] | [next] | [standalone]
| From | didier gaumet <didier.gaumet@gmail.com> |
|---|---|
| Date | 2024-07-02 20:20 +0200 |
| Message-ID | <IVQgF-7djt-3@gated-at.bofh.it> |
| In reply to | #270738 |
Le 02/07/2024 à 16:38, Jörg Kastning a écrit : [...] > :~$ podman run --rm hello-world > conmon: option parsing failed: Unknown option --full-attach > Error: write child: broken pipe [...] Hello, please be aware that I never used podman nor conmon so what I say may be totally irrelevant the above error message could indicate that somehow by default there is a --full-attach option that is not recognized. the podman (8) manpage mentions: [...] "--attach, -a=stdin | stdout | stderr Attach to STDIN, STDOUT or STDERR. In foreground mode (the default when -d is not specified), podman run can start the process in the container and attach the console to the process’s standard input, output, and error. It can even pretend to be a TTY (this is what most command-line executables expect) and pass along signals. The -a option can be set for each of stdin, stdout, and stderr." [...] so perhaps, depending on the behavior you wish, you could combine several -a options, for example: $ podman run -a=stdout --rm hello-world or $ podman run -a=stdin -a=stdout -a=stderr --rm hello-world
[toc] | [prev] | [next] | [standalone]
| From | Jörg Kastning <joerg.kastning@gmail.com> |
|---|---|
| Date | 2024-07-02 21:00 +0200 |
| Subject | [Solved] Re: Cannot execute any container using podman run |
| Message-ID | <IVQTn-7dyA-15@gated-at.bofh.it> |
| In reply to | #270738 |
On 02.07.24 19:36, CToID wrote: > On 7/2/24 22:38, Jörg Kastning wrote: > >> :~$ podman run --rm hello-world >> conmon: option parsing failed: Unknown option --full-attach >> Error: write child: broken pipe > > Maybe try run with `podman --log-level=debug run --rm hello-world` to > get more information? Thank you! Running with debug loglevel I was able to solve the issue. Here is the snipped from the debug output that shows the issue: ~~~ DEBU[0000] running conmon: /usr/local/libexec/podman/conmon args="[--api-version 1 -c 6f126044b414b2ded703c7f1036f580e52a14833d97298d9326f6354f3832336 -u 6f126044b414b2ded703c7f1036f580e52a14833d97298d9326f6354f3832336 -r /usr/bin/crun -b /home/tronde/.local/share/containers/storage/vfs-containers/6f126044b414b2ded703c7f1036f580e52a14833d97298d9326f6354f3832336/userdata -p /run/user/1000/containers/vfs-containers/6f126044b414b2ded703c7f1036f580e52a14833d97298d9326f6354f3832336/userdata/pidfile -n vibrant_moore --exit-dir /run/user/1000/libpod/tmp/exits --full-attach -s -l journald --log-level debug --syslog --conmon-pidfile /run/user/1000/containers/vfs-containers/6f126044b414b2ded703c7f1036f580e52a14833d97298d9326f6354f3832336/userdata/conmon.pid --exit-command /usr/bin/podman --exit-command-arg --root --exit-command-arg /home/tronde/.local/share/containers/storage --exit-command-arg --runroot --exit-command-arg /run/user/1000/containers --exit-command-arg --log-level --exit-command-arg debug --exit-command-arg --cgroup-manager --exit-command-arg systemd --exit-command-arg --tmpdir --exit-command-arg /run/user/1000/libpod/tmp --exit-command-arg --network-config-dir --exit-command-arg --exit-command-arg --network-backend --exit-command-arg netavark --exit-command-arg --volumepath --exit-command-arg /home/tronde/.local/share/containers/storage/volumes --exit-command-arg --runtime --exit-command-arg crun --exit-command-arg --storage-driver --exit-command-arg vfs --exit-command-arg --events-backend --exit-command-arg journald --exit-command-arg --syslog --exit-command-arg container --exit-command-arg cleanup --exit-command-arg --rm --exit-command-arg 6f126044b414b2ded703c7f1036f580e52a14833d97298d9326f6354f3832336]" conmon: option parsing failed: Unknown option --full-attach ~~~ I solved the issue by executing the following commands: 1. sudo apt purge conmon podman 2. sudo apt install conmon podman I missed purging conmon during my previous troubleshooting attempts. Just removing it has left /usr/local/libexec/podman/conmon on my host causing the issue. Cheers, Joerg
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.user
csiph-web