Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #242993 > unrolled thread

Re: CUPS mailing list (was: Re: bullseye fusses)

Started byGene Heskett <gheskett@shentel.net>
First post2021-12-12 06:20 +0100
Last post2021-12-12 18:40 +0100
Articles 2 — 2 participants

Back to article view | Back to linux.debian.user


Contents

  Re: CUPS mailing list (was: Re: bullseye fusses) Gene Heskett <gheskett@shentel.net> - 2021-12-12 06:20 +0100
    Re: CUPS mailing list (was: Re: bullseye fusses) "Andrew M.A. Cater" <amacater@einval.com> - 2021-12-12 18:40 +0100

#242993 — Re: CUPS mailing list (was: Re: bullseye fusses)

FromGene Heskett <gheskett@shentel.net>
Date2021-12-12 06:20 +0100
SubjectRe: CUPS mailing list (was: Re: bullseye fusses)
Message-ID<Dtprb-4mo-7@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

On Sat, 11 Dec, 2021 at 10:32 PM, Andy Smith <andy@strugglers.net> wrote:
 

To: debian-user@lists.debian.org
On Sun, Dec 12, 2021 at 02:56:12AM +0000, Andy Smith wrote:
> Is that the list that you are talking about?

For those playing along at home, Gene directly sent me a rambling
HTML reply which did confirm that cups@cups.org<mailto:cups@cups.org> is the list he is
talking about, but only went on to say that he has attempted to
subscribe to it again and has not yet received an error.

So it seems most likely that this is user error as opposed to the
evil machinations of Apple corp, but we will probably never know
because as usual Gene does not provide any details as to what errors
he has seen up until now.

> I think you will do better if you did the usual thing of
> explaining:
> 
> - exactly what you did
> - what exactly happened including exact output of any error message
>   given (not your recollection of what may have happened)
> - what exactly you expected to happen instead

Gene's idea of progressing this was as follows:

   I expected the smtp agent to be able to query imap.shentel.net<http://imap.shentel.net>
   for port and protocol supported auto fill. but it apparently
   can't do that yet.

…which is basically just a restatement of "thing does not work"
without providing any useful information. Though did provide several
paragraphs of irrelevant personal rambling and insults aimed at
various software projects.

Maybe someone else can have a go and have more luck, but trying to
extract any usable information out of Gene seems like it will be, as
usual, an exhausting and unrewarding process.

Thanks,
Andy



That does it Andy, I had a TL;DR message tracing an attempt to send myself
a msg via kmail, and was going to send it, but something in FF changed
the list address from .org to .net, and the display of the To: address at the
top of this fixed size form only shows it as debian-user@lists.de... so I can't
see it, wrong damned address = instant rejection.


I am sick of trying to explain
whats going on with kmail and being told I have no valid info in my complaints,
even when I copy/paste what I'm getting.


I don't like webmail anymore than you do but everytime my ancient fingers touch
two adjacent keys, the screen blinks and FF does something to screw up the 

whole mail WITHOUT SHOWING ME ONSCREEN THAT ITS SCREWED. Now I just found
a copy of that email in the FF sent folder, so let me see if I can copy/paste the
working parts:



So here's the TL;DR version of trying to receive email files put in
/home/gene/.Maildir by procmail:


1. Set that address in config/kmail/accounts/receiving.
There are currently about 270 email files there: Or were the last
time I looked, but they are gone now, in which case should I not have
about 270 new, unread mails? Checking the mail, kmail has rx'ed those
msgs according to the dates, but in nothing resembling real time.  Next
day maybe? So assuming that is somewhat working, does kmail recognise
that I have seen those mails with firefox, so it doesn't mark them as new 

when it pulls them from local storage, fetched by fetchmail and placed in
/home/gene./Maildir by procmail?


just for S&G, I'll try sending me a msg with kmail's snmp.
But an email to <gheskett@shentel.net> is rejected by the server at my
ISP and is stuck in the outbox, fail msg is:
Failed to transport message. The remote host closed the connection


I can move it to trash and have. And at no point in that did I see a button
to query the isp's version of dovecot to see what it wants.



I composed another after cleaning out the outbox, but got the same msg
as above after I found and used the auto-config and it did set stuff differently.


This is the raw msg:
====================


From: gene <gheskett@shentel.net>
To: Gene <gheskett@shentel.net>
Subject: testing kmails send
Date: Sat, 11 Dec 2021 23:20:39 -0500
Message-ID: <3261619.4cKSPi9zZA@coyote>
X-KMail-Identity: 2255060675
X-KMail-Transport: 1827825406
X-KMail-Fcc: 239
X-KMail-Identity-Name: Default
X-KMail-Transport-Name: shentel.net<http://shentel.net> #1
MIME-Version: 1.0
Content-Transfer-Encoding: 7Bit
Content-Type: text/plain; charset="us-ascii"


Hi gene, did it work?
==============

and sending is now set by the autoconfig for:
checked SSL/TLS
port 465 and I just found the authentification unchecked for at least the 10th time.
Set it, made sure the pw was correct and hit ctl+l to send.


The outbox emptied, but nothing in kmails sent-mail. And nothing from 

me in firefox after several minutes and a couple inbox refreshes.


End of copy/paste. Is that detailed enough?

-- 
https://bitfolk.com/ -- No-nonsense VPS hosting

.

[toc] | [next] | [standalone]


#243020

From"Andrew M.A. Cater" <amacater@einval.com>
Date2021-12-12 18:40 +0100
Message-ID<DtAZk-2SE-11@gated-at.bofh.it>
In reply to#242993
On Sat, Dec 11, 2021 at 09:12:49PM -0800, Gene Heskett wrote:
> On Sat, 11 Dec, 2021 at 10:32 PM, Andy Smith <andy@strugglers.net> wrote:
>  
> 
> To: debian-user@lists.debian.org
> On Sun, Dec 12, 2021 at 02:56:12AM +0000, Andy Smith wrote:
> > Is that the list that you are talking about?
> 
> For those playing along at home, Gene directly sent me a rambling
> HTML reply which did confirm that cups@cups.org<mailto:cups@cups.org> is the list he is
> talking about, but only went on to say that he has attempted to
> subscribe to it again and has not yet received an error.
> 
> So it seems most likely that this is user error as opposed to the
> evil machinations of Apple corp, but we will probably never know
> because as usual Gene does not provide any details as to what errors
> he has seen up until now.
> 
> > I think you will do better if you did the usual thing of
> > explaining:
> > 
> > - exactly what you did
> > - what exactly happened including exact output of any error message
> >   given (not your recollection of what may have happened)
> > - what exactly you expected to happen instead
> 

[Bunch of mail configuration stuff snipped - as for printing]

Gene, 

Is this Debian 10 or Debian 11?

In another thread, I cut and pasted this from the Debian 11 release notes
ref CUPS

2.2.2. Driverless scanning and printing

Both printing with CUPS and scanning with SANE are increasingly likely to be 
possible without the need for any driver (often non-free) specific to the 
model of the hardware, especially in the case of devices marketed in the past 
five years or so.

2.2.2.1. CUPS and driverless printing

Modern printers connected by ethernet or wireless can already use driverless 
printing, implemented via CUPS and cups-filters, as was described in the 
Release Notes for buster. Debian 11 “bullseye” brings the new package 
ipp-usb, which is recommended by cups-daemon and uses the vendor-neutral 
IPP-over-USB protocol supported by many modern printers. This allows a USB 
device to be treated as a network device, extending driverless printing to 
include USB-connected printers. The specifics are outlined on the wiki.

The systemd service file included in the ipp-usb package starts the ipp-usb 
daemon when a USB-connected printer is plugged in, thus making it available 
to print to. By default cups-browsed should configure it automatically, or 
it can be manually set up with a local driverless print queue.

2.2.2.2. SANE and driverless scanning

The official SANE driverless backend is provided by sane-escl in libsane1. An 
independently developed driverless backend is sane-airscan. Both backends 
understand the eSCL protocol but sane-airscan can also use the WSD protocol. 
Users should consider having both backends on their systems.

eSCL and WSD are network protocols. Consequently they will operate over a USB 
connection if the device is an IPP-over-USB device (see above). Note that 
libsane1 has ipp-usb as a recommended package. This leads to a suitable 
device being automatically set up to use a driverless backend driver when 
it is connected to a USB port.

-

Can we sort one problem at a time?

All the very best, as ever,

Andy Cater

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.user


csiph-web