Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #210899

X server does not start after upgrading to Debian 10

From Teemu Likonen <tlikonen@iki.fi>
Newsgroups linux.debian.user
Subject X server does not start after upgrading to Debian 10
Date 2019-07-07 13:30 +0200
Message-ID <yhdwJ-NH-5@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

Upgrade to Debian 10 didn't end up well although all packages upgraded
smoothly.

The problem: X server doesn't start anymore with Debian 10's default
kernel version 4.19. The X server starts and works nicely with kernel
4.9 which I have still installed from Debian 9.

What happens: Even a simple X session like "startx /usr/bin/xterm" just
freezes. After freeze if I change to different virtual console and back
with Ctrl+Alt+Fn the X session crashes and the Xorg.0.log is appended
with this:

----------
[  1892.784] (EE) modeset(0): failed to set mode: Invalid argument
[  1892.784] (EE) 
Fatal server error:
[  1892.784] (EE) EnterVT failed for screen 0
[  1892.784] (EE) 
[  1892.784] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[  1892.784] (EE) Please also check the log file at "/home/dtw/.local/share/xorg/Xorg.0.log" for additional information.
[  1892.784] (EE) 
[  1892.784] (II) AIGLX: Suspending AIGLX clients for VT switch
[  1892.842] (EE) Server terminated with error (1). Closing log file.
----------

The computer has Intel graphics adapter which uses i915 kernel module.
"journalctl -f" says nothing: nothing is added to system logs.

I reported the issue here:
    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=931528
The bug report has the full Xorg.0.log as an attachment.

Do you have ideas about how to get X server working again or help making
the bug report better?

-- 
///  OpenPGP key: 4E1055DC84E9DFF613D78557719D69D324539450
//  https://keys.openpgp.org/search?q=tlikonen@iki.fi
/  https://keybase.io/tlikonen  https://github.com/tlikonen

Back to linux.debian.user | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

X server does not start after upgrading to Debian 10 Teemu Likonen <tlikonen@iki.fi> - 2019-07-07 13:30 +0200
  Re: X server does not start after upgrading to Debian 10 Sven Joachim <svenjoac@gmx.de> - 2019-07-07 14:10 +0200
  Re: X server does not start after upgrading to Debian 10 Teemu Likonen <tlikonen@iki.fi> - 2019-07-07 14:20 +0200
    Re: X server does not start after upgrading to Debian 10 Felix Miata <mrmazda@earthlink.net> - 2019-07-09 05:30 +0200
      Re: X server does not start after upgrading to Debian 10 Felix Miata <mrmazda@earthlink.net> - 2019-07-09 06:30 +0200

csiph-web