Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #206593
| From | stupidate@gmail.com |
|---|---|
| Newsgroups | linux.debian.user |
| Subject | Re: relocation error: /lib/x86_64-linux-gnu/libnss_files.so.2: symbol __libc_readline_unlocked version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference |
| Date | 2019-03-25 22:50 +0100 |
| Message-ID | <xFFDH-3lG-1@gated-at.bofh.it> (permalink) |
| References | <x0Syu-6vJ-3@gated-at.bofh.it> <xFFDH-3lG-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
I had the same issue, mariadb will actually start if you do so manually, what fails is the command `install` from coreutils, try to upgrade that package. On Monday, December 3, 2018 at 1:20:04 AM UTC-8, Office onFocus wrote: > Hi! > > > How can I correctly report the following error? > > > "relocation error: /lib/x86_64-linux-gnu/libnss_files.so.2: symbol __libc_readline_unlocked version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference" > > > > > After the libc6:amd64 (2.27-8, 2.28-1) update, I can no longer start databases on different servers. > > .. I neet libc6 >= 2.27 for apache2, ... > > > For testing you can install stretch with mariadb 10-1 and then upgrade libc6 to 2.28-1 == sid > > > > > > root@rs33073:~# dpkg -l | grep mariadb-server > ii mariadb-server-10.1 10.1.37-0+deb9u1 amd64 MariaDB database server binaries > ii mariadb-server-core-10.1 10.1.37-0+deb9u1 amd64 MariaDB database core server files > > > > root@rs33073:~# /etc/init.d/mysql restart > [....] Restarting mysql (via systemctl): mysql.serviceJob for mariadb.service failed because the control process exited with error code. > See "systemctl status mariadb.service" and "journalctl -xe" for details. > failed! > > > > > Dec 3 09:24:26 rs33073 systemd[9747]: (systemd): relocation error: /lib/x86_64-linux-gnu/libnss_files.so.2: symbol __libc_readline_unlocked version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference > > > > root@rs33073:~# /lib/x86_64-linux-gnu/libc.so.6 > GNU C Library (Debian GLIBC 2.28-1) stable release version 2.28. > Copyright (C) 2018 Free Software Foundation, Inc. > This is free software; see the source for copying conditions. > There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A > PARTICULAR PURPOSE. > Compiled by GNU CC version 8.2.0. > libc ABIs: UNIQUE IFUNC ABSOLUTE > For bug reporting instructions, please see: > <http://www.debian.org/Bugs/>. > > > > > > > > > root@mysql57a:~# dpkg -l | grep mysql-server > ii mysql-server 5.7.24-1debian8 amd64 MySQL Server meta package depending on latest version > > > E not defined in file libc.so.6 with link time reference > Nov 30 09:10:44 mysql57a mysql-systemd-start[12394]: (md-start): relocation error: /lib/x86_64-linux-gnu/libnss_files.so.2: symbol __libc_readline_unlocked version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference > > > > > > root@mysql57a:~# cat /etc/apt/preferences > > Package: * > Pin: release a=old-stable > Pin-Priority: 500 > > > Package: * > Pin: release a=testing > Pin-Priority: 50 > > > Package: * > Pin: release a=unstable > Pin-Priority: 50 > > > Package: * > Pin: release a=stable > Pin-Priority: 50 > > > Package: apache2 apache2-bin apache2-data apache2-utils curl fontconfig-config libapache2-mod-php7.2 libapache2-mod-php7.3 libapr1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libargon2-0 libargon2-1 libbrotli1 libc-bin libc-l10n libc6 libcom-err2 libcomerr2 libcurl4 libfontconfig1 libgcrypt20 libgd3 libgdbm5 libgdbm6 libgpg-error0 libgssapi-krb5-2 libidn2-0 libjansson4 libk5crypto3 libkrb5-3 libkrb5support0 libncurses6 libnghttp2-14 libpcre2-8-0 libpng16-16 libpsl5 libsodium23 libssh2-1 libssl1.1 libtinfo6 libunistring2 libwebp6 libzip4 linux-base locales os-prober php php-bz2 php-common php-curl php-gd php-mbstring php-mysql php-phpseclib php-xml php-zip php7.2 php7.2-bz2 php7.2-cli php7.2-common php7.2-curl php7.2-gd php7.2-json php7.2-mbstring php7.2-mysql php7.2-opcache php7.2-readline php7.2-xml php7.2-zip php7.3 php7.3-bz2 php7.3-cli php7.3-common php7.3-curl php7.3-gd php7.3-json php7.3-mbstring php7.3-mysql php7.3-opcache php7.3-readline php7.3-xml php7.3-zip phpmyadmin publicsuffix zlib1g libgpg-error-l10n libncurses5 libncursesw5 libtinfo5 > Pin: release a=unstable > Pin-Priority: 600 > > > > > > > > > > > > > > best, > > Daniel > > -- > onFocus.at e.U. > > off...@onfocus.at
Back to linux.debian.user | Previous | Next — Previous in thread | Find similar | Unroll thread
relocation error: /lib/x86_64-linux-gnu/libnss_files.so.2: symbol __libc_readline_unlocked version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference Office onFocus <office@onfocus.at> - 2018-12-03 10:20 +0100 Re: relocation error: /lib/x86_64-linux-gnu/libnss_files.so.2: symbol __libc_readline_unlocked version GLIBC_PRIVATE not defined in file libc.so.6 with link time reference stupidate@gmail.com - 2019-03-25 22:50 +0100
csiph-web