Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.user > #197786

Re: apache not running at boot

From mick crane <mick.crane@gmail.com>
Newsgroups linux.debian.user
Subject Re: apache not running at boot
Date 2018-07-19 08:30 +0200
Message-ID <wdaBP-7db-1@gated-at.bofh.it> (permalink)
References <wcUQq-63n-11@gated-at.bofh.it> <wcUQq-63n-9@gated-at.bofh.it> <wcVt7-6w6-1@gated-at.bofh.it> <wd1yy-1uc-1@gated-at.bofh.it> <wd5su-3Hy-13@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 2018-07-19 01:57, Dave wrote:
> On 07/18/2018 04:41 PM, Dave wrote:
> 
>> On 07/18/2018 10:12 AM, Jonathan Dowland wrote:
>> On Wed, Jul 18, 2018 at 09:36:14AM -0400, Greg Wooledge wrote:
>> Sounds like the service may be disabled for some reason.  What is
>> the
>> output of:
>> 
>> systemctl status apache2
>> 
>> If you see "; disabled;" on the "Loaded" line, then this should fix
>> it,
>> one hopes:
>> 
>> systemctl enable apache2
>> 
>> After doing that, you should see "; enabled;" on the Loaded line.
>> 
>> The above should address having apache2 start on system boot (or
>> restart
>> if killed for some reason); to start it on a running system you will
>> 
>> also want to issue
>> 
>> systemctl start apache2
>> 
>> However, from what I recall, none of this should be necessary by
>> default, so there is likely a configuration problem. If all of the
>> above
> 
> hello when i run systemctl this is what i get
> 
> ● apache2.service - The Apache HTTP Server
>    Loaded: loaded (/lib/systemd/system/apache2.service; enabled;
> vendor preset: enabled)
>    Active: failed (Result: exit-code) since Wed 2018-07-18 16:35:30
> EDT; 1min 2s ago
>   Process: 614 ExecStart=/usr/sbin/apachectl start (code=exited,
> status=1/FAILURE)
> 
> Jul 18 16:35:30 culser systemd[1]: Starting The Apache HTTP Server...
> Jul 18 16:35:30 culser apachectl[614]: (99)Cannot assign requested
> address: AH00072: make_sock: could not bind to addres
> Jul 18 16:35:30 culser apachectl[614]: no listening sockets available,
> shutting down
> Jul 18 16:35:30 culser apachectl[614]: AH00015: Unable to open logs
> Jul 18 16:35:30 culser apachectl[614]: Action 'start' failed.
> Jul 18 16:35:30 culser apachectl[614]: The Apache error log may have
> more information.
> Jul 18 16:35:30 culser systemd[1]: apache2.service: Control process
> exited, code=exited status=1
> Jul 18 16:35:30 culser systemd[1]: Failed to start The Apache HTTP
> Server.
> Jul 18 16:35:30 culser systemd[1]: apache2.service: Unit entered
> failed state.
> Jul 18 16:35:30 culser systemd[1]: apache2.service: Failed with result
> 'exit-code'.
> 
>> does not result in a running apache2, check "journalctl -u
>> apache2.service" for clues, and failing that, /var/log/apache2/*
> 
> hello when i run systemctl this is what i get
> 
> ● apache2.service - The Apache HTTP Server
>    Loaded: loaded (/lib/systemd/system/apache2.service; enabled;
> vendor preset: enabled)
>    Active: failed (Result: exit-code) since Wed 2018-07-18 16:35:30
> EDT; 1min 2s ago
>   Process: 614 ExecStart=/usr/sbin/apachectl start (code=exited,
> status=1/FAILURE)
> 
> Jul 18 16:35:30 culser systemd[1]: Starting The Apache HTTP Server...
> Jul 18 16:35:30 culser apachectl[614]: (99)Cannot assign requested
> address: AH00072: make_sock: could not bind to addres
> Jul 18 16:35:30 culser apachectl[614]: no listening sockets available,
> shutting down
> Jul 18 16:35:30 culser apachectl[614]: AH00015: Unable to open logs
> Jul 18 16:35:30 culser apachectl[614]: Action 'start' failed.
> Jul 18 16:35:30 culser apachectl[614]: The Apache error log may have
> more information.
> Jul 18 16:35:30 culser systemd[1]: apache2.service: Control process
> exited, code=exited status=1
> Jul 18 16:35:30 culser systemd[1]: Failed to start The Apache HTTP
> Server.
> Jul 18 16:35:30 culser systemd[1]: apache2.service: Unit entered
> failed state.
> Jul 18 16:35:30 culser systemd[1]: apache2.service: Failed with result
> 'exit-code'. update:
> 
> after boot apache is not running,
> if i run systemctl status apache2, i get the address bind error shown
> above
> 
> at the command line after boot if i run apache2 -k restart, no errors.
> 
> after boot if i start apache2 via /etc/init.d/apache2 start or
> /usr/sbin/apache2ctl start
> then - systemctl does not get the error.
> 
> /var/log/apache2 the error.log is "0" bytes
> 
> how may i start apache2 at boot with out the error.

Seems apache is starting before network is ready.
I used to put the ip adddress to Listen to and it worked then with one 
release it stopped working so edited to Listen 127.0.0.1 in apache conf 
file or Listen * and it worked but now this release cannot find Listen 
to interface in any of the apache2 conf files only the ports in 
ports.conf

Perhaps there is some way to find what order
"systemctl enable     "
puts things in ?

mick




-- 
Key ID    4BFEBB31

Back to linux.debian.user | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

Re: apache not running at boot Greg Wooledge <wooledg@eeg.ccf.org> - 2018-07-18 15:40 +0200
  Re: apache not running at boot Jonathan Dowland <jmtd@debian.org> - 2018-07-18 16:20 +0200
    Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-18 22:50 +0200
      Re: apache not running at boot Greg Wooledge <wooledg@eeg.ccf.org> - 2018-07-18 23:00 +0200
      Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-19 03:00 +0200
        Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-19 08:30 +0200
        Re: apache not running at boot Joe <joe@jretrading.com> - 2018-07-19 09:00 +0200
        Re: apache not running at boot Curt <curty@free.fr> - 2018-07-19 10:30 +0200
          Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-19 11:30 +0200
            Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-20 10:40 +0200
              Re: apache not running at boot Greg Wooledge <wooledg@eeg.ccf.org> - 2018-07-25 14:40 +0200
          Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-20 01:00 +0200
            Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-21 06:00 +0200
              Re: apache not running at boot メット <mett@pmars.jp> - 2018-07-21 06:50 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-21 09:00 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-21 10:40 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-21 11:00 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-21 11:30 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-21 14:10 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-21 14:50 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-21 15:50 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-21 16:10 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-21 17:40 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-21 23:30 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-22 08:20 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-22 15:00 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-22 15:20 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-22 16:10 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-22 16:40 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-22 17:00 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-22 17:00 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-22 17:20 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-22 17:30 +0200
                Re: apache not running at boot Cindy-Sue Causey <butterflybytes@gmail.com> - 2018-07-22 19:10 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-23 00:20 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-23 00:40 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-23 01:00 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-23 08:30 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-23 13:20 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-23 22:00 +0200
                Re: apache not running at boot Joe <joe@jretrading.com> - 2018-07-23 09:50 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-23 10:30 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-22 17:40 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-22 19:00 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-22 20:00 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-25 15:10 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-25 17:00 +0200
                Re: apache not running at boot mick crane <mick.crane@gmail.com> - 2018-07-25 19:20 +0200
                Re: apache not running at boot john doe <johndoe65534@mail.com> - 2018-07-25 20:00 +0200
                Re: apache not running at boot Curt <curty@free.fr> - 2018-07-22 17:40 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-21 16:00 +0200
                Re: apache not running at boot Curt <curty@free.fr> - 2018-07-21 17:50 +0200
                Re: apache not running at boot Dave <debiantechquestions@gmx.com> - 2018-07-21 23:10 +0200

csiph-web