Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.user > #267983
| From | Markus Schönhaber <debian-user@list-post.mks-mail.de> |
|---|---|
| Newsgroups | linux.debian.user |
| Subject | Re: Error: Failed to start Apache2 service on boot |
| Date | 2024-03-01 17:20 +0100 |
| Message-ID | <IddM6-dIT4-1@gated-at.bofh.it> (permalink) |
| References | <Idd9n-dIq6-9@gated-at.bofh.it> <Idd9n-dIq6-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
01.03.24, 16:36 +0100, Stephen P. Molnar: > I am running up to date Bookworm and get the 'Failed to start Apache2 > service on boot' error message. > > I searched Google and found > https://forums.debian.net/voew.top9c,php?t=14419s which didn't solve the > problem. > > I then tried sudo systemctl status apache2.service resulting in: > > × apache2.service - The Apache HTTP Server > Loaded: loaded (/lib/systemd/system/apache2.service; enabled; > preset: enabled) > Active: failed (Result: exit-code) since Fri 2024-03-01 10:14:07 > EST; 20min ago > Docs: https://httpd.apache.org/docs/2.4/ > Process: 4474 ExecStart=/usr/sbin/apachectl start (code=exited, > status=1/FAILURE) > CPU: 41ms > > Mar 01 10:14:07 AbNormal systemd[1]: Starting apache2.service - The > Apache HTTP Server... > Mar 01 10:14:07 AbNormal apachectl[4477]: AH00526: Syntax error on line > 11 of /etc/apache2/mods-enabled/userdir.conf: [1] ^^^^^^ > Mar 01 10:14:07 AbNormal apachectl[4477]: Illegal option ExecCG [2] ^^^^^^ > Mar 01 10:14:07 AbNormal apachectl[4474]: Action 'start' failed. > Mar 01 10:14:07 AbNormal apachectl[4474]: The Apache error log may have > more information. > Mar 01 10:14:07 AbNormal systemd[1]: apache2.service: Control process > exited, code=exited, status=1/FAILURE > Mar 01 10:14:07 AbNormal systemd[1]: apache2.service: Failed with result > 'exit-code'. > Mar 01 10:14:07 AbNormal systemd[1]: Failed to start apache2.service - > The Apache HTTP Server. > > Unfortunately, I am not conversant in ancient Greek and wold very > appreciative of assistance. Hm, to me it seems that the problem description in the log is written in pretty plain English: [1] Look at /etc/apache2/mods-enabled/userdir.conf line 11 there you should see something like [2] "ExecCG" which probably should read "ExecCGI" instead. -- Regards mks
Back to linux.debian.user | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Error: Failed to start Apache2 service on boot "Stephen P. Molnar" <s.molnar@sbcglobal.net> - 2024-03-01 16:40 +0100
Re: Error: Failed to start Apache2 service on boot Markus Schönhaber <debian-user@list-post.mks-mail.de> - 2024-03-01 17:20 +0100
Re: Error: Failed to start Apache2 service on boot "Stephen P. Molnar" <s.molnar@sbcglobal.net> - 2024-03-01 17:50 +0100
Re: Error: Failed to start Apache2 service on boot Dan Ritter <dsr@randomstring.org> - 2024-03-01 19:30 +0100
csiph-web