Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #88478 > unrolled thread
| Started by | phil.nightowl@gmail.com |
|---|---|
| First post | 2025-07-21 15:10 +0200 |
| Last post | 2025-07-31 10:40 +0200 |
| Articles | 4 — 3 participants |
Back to article view | Back to linux.debian.kernel
Bug#1109666: Fails to boot on Marvell Armada 385 phil.nightowl@gmail.com - 2025-07-21 15:10 +0200
Processed: Re: Bug#1109666: Fails to boot on Marvell Armada 385 "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-07-23 13:50 +0200
Bug#1109666: Fails to boot on Marvell Armada 385 Ben Hutchings <ben@decadent.org.uk> - 2025-07-23 13:50 +0200
Bug#1109666: Fails to boot on Marvell Armada 385 phil.nightowl@gmail.com - 2025-07-31 10:40 +0200
| From | phil.nightowl@gmail.com |
|---|---|
| Date | 2025-07-21 15:10 +0200 |
| Subject | Bug#1109666: Fails to boot on Marvell Armada 385 |
| Message-ID | <LaYrf-1AMj-1@gated-at.bofh.it> |
[Multipart message — attachments visible in raw view] — view raw
Package: linux-image-armmp Version: 6.10.6-1~bpo12+1 Severity: important -- System Information: Debian Release: 12.10 APT prefers stable-updates APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable') Architecture: armhf Dear maintainer, since some time ago, the backports kernel updates fail to boot on the mentioned CPU. The last working version was 6.6.13-1~bpo12+1. Since then, every upgrade attempt so far has failed with a kernel panic, the last such attempt having been with 6.10.6-1~bpo12+1. Sadly, I am not familiar with kernel developement. While happy to provide additional debugging information, I would need instructions on how to obtain that. At this point, I am only attaching the panic log from a failed boot attempt. Older kernels on the same /boot partitions do boot without problems, so there should be no problems with MMC (where /boot resides) access or with reading the filesystem, etc. Best regards, Phil
[toc] | [next] | [standalone]
| From | "Debian Bug Tracking System" <owner@bugs.debian.org> |
|---|---|
| Date | 2025-07-23 13:50 +0200 |
| Subject | Processed: Re: Bug#1109666: Fails to boot on Marvell Armada 385 |
| Message-ID | <LbG8V-236g-3@gated-at.bofh.it> |
| In reply to | #88478 |
Processing control commands: > tag -1 moreinfo Bug #1109666 [linux-image-armmp] Fails to boot on Marvell Armada 385 Added tag(s) moreinfo. -- 1109666: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1109666 Debian Bug Tracking System Contact owner@bugs.debian.org with problems
[toc] | [prev] | [next] | [standalone]
| From | Ben Hutchings <ben@decadent.org.uk> |
|---|---|
| Date | 2025-07-23 13:50 +0200 |
| Message-ID | <LbG8V-236g-1@gated-at.bofh.it> |
| In reply to | #88478 |
[Multipart message — attachments visible in raw view] — view raw
Control: tag -1 moreinfo
On Mon, 2025-07-21 at 14:59 +0200, phil.nightowl@gmail.com wrote:
> Package: linux-image-armmp
> Version: 6.10.6-1~bpo12+1
> Severity: important
>
>
> -- System Information:
> Debian Release: 12.10
> APT prefers stable-updates
> APT policy: (500, 'stable-updates'), (500, 'stable-security'), (500, 'stable')
> Architecture: armhf
>
>
> Dear maintainer,
>
> since some time ago, the backports kernel updates fail to boot on the
> mentioned CPU. The last working version was 6.6.13-1~bpo12+1. Since then,
> every upgrade attempt so far has failed with a kernel panic, the last such
> attempt having been with 6.10.6-1~bpo12+1.
[...]
Please test again with the current version (6.12.33-1~bpo12+1). I think
this may have been fixed upstream by:
commit 3c44d31cb34ce4eb8311a2e73634d57702948230
Author: Herbert Xu <herbert@gondor.apana.org.au>
Date: Sat Aug 17 14:58:35 2024 +0800
crypto: simd - Do not call crypto_alloc_tfm during registration
Ben.
--
Ben Hutchings
Hoare's Law of Large Problems:
Inside every large problem is a small problem struggling to get out.
[toc] | [prev] | [next] | [standalone]
| From | phil.nightowl@gmail.com |
|---|---|
| Date | 2025-07-31 10:40 +0200 |
| Message-ID | <LewZr-45PH-1@gated-at.bofh.it> |
| In reply to | #88499 |
> Please test again with the current version (6.12.33-1~bpo12+1). I think > this may have been fixed upstream by: > > commit 3c44d31cb34ce4eb8311a2e73634d57702948230 > Author: Herbert Xu <herbert@gondor.apana.org.au> > Date: Sat Aug 17 14:58:35 2024 +0800 I did test with 6.12.35+deb12-armmp, the bug is still there, even a bit nastier. Kind of assumed that, as the commit you mentioned went into 6.1.113 and my last known working version is 6.6.13+bpo-armmp. With 6.12.35+deb12-armmp, the kernel does not panic immediately during a boot attempt, but errors begin to appear soon. During my testing, I got many different messages mainly around the SATA subsystem (resetting the controller, ...). Some of them even indicated possible data corruption. I've got more errors (and they appeared earlier) when two SATA drives were attached, compared to having only a single drive. However, with either configuration, the system would hang sooner or later. With 6.6.13+bpo-armmp, everything is running fine and stable with the same hardware. I did save some logfiles, so I can send them if you wish. However, there is a ton of it with only small portions being relevant, so I would need some time to process them. Phil
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.kernel
csiph-web