Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #89830 > unrolled thread
| Started by | Richard <rrosner5@gmail.com> |
|---|---|
| First post | 2025-10-30 11:40 +0100 |
| Last post | 2025-10-30 11:40 +0100 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.debian.kernel
Bug#1119673: error: not xen image Richard <rrosner5@gmail.com> - 2025-10-30 11:40 +0100
| From | Richard <rrosner5@gmail.com> |
|---|---|
| Date | 2025-10-30 11:40 +0100 |
| Subject | Bug#1119673: error: not xen image |
| Message-ID | <LLyet-97sY-1@gated-at.bofh.it> |
[Multipart message — attachments visible in raw view] — view raw
Package: linux-image-amd64 Version: 6.12.48-1 Severity: important Tags: patch Dear Maintainer, like already mentioned in Bug#1098798, the Linux kernels in Trixie that are installed by linux-image-amd64 are not capable of booting on a Xen hypervisor. This is an issue with the config used to compile the kernel. The error message that's produced is Loading Linux 6.12.48-amd64 ... error: not xen image. Loading initial ramdisk ... error: you need to load the kernel first. Press any key to continue... VM type is "pv". After asking on the Project Xen mailing list I can now say with certainty that the offending config is "CONFIG_KERNEL_ZSTD". Disabling it lets the kernel boot again. The cause is pvgrub not supporting the required zstdio iofilter, which supposedly is being fixed right now with grub-2.14~rc1. Best regards Richard
Back to top | Article view | linux.debian.kernel
csiph-web