Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #86118 > unrolled thread
| Started by | Richard <rrosner5@gmail.com> |
|---|---|
| First post | 2025-02-24 13:30 +0100 |
| Last post | 2025-04-04 15:20 +0200 |
| Articles | 2 — 2 participants |
Back to article view | Back to linux.debian.kernel
Bug#1098798: linux-image-amd64: networking issues with IPv6 Richard <rrosner5@gmail.com> - 2025-02-24 13:30 +0100
Bug#1098798: linux-image-amd64: networking issues with IPv6 Salvatore Bonaccorso <carnil@debian.org> - 2025-04-04 15:20 +0200
| From | Richard <rrosner5@gmail.com> |
|---|---|
| Date | 2025-02-24 13:30 +0100 |
| Subject | Bug#1098798: linux-image-amd64: networking issues with IPv6 |
| Message-ID | <KjFKV-1CJp-5@gated-at.bofh.it> |
Package: linux-image-amd64 Version: 6.12.16-1 Severity: normal Dear Maintainer, I'm not 100 % sure this is caused by the Kernel, but I'm convinced like 99 %. For about two weeks I have issues with the networking on several of my servers, mainly with mounting NFS shares. Mounting them works only on the servers that are on Debian Stable, but the ones on Testing, and thus running 6.12.x, have issues. I've now tried out to switch every server running Testing and failing to mount their NFS share to the 6.13.4 Kernel found in experimental, and for now it looks like this has fixed the issue. Though I couldn't update it on one server running as a VM on a Xen hypervisor. When trying to boot 6.13.4 on it, I can see in "xl console" this message: Loading Linux 6.13-amd64 ... error: not xen image. Loading initial ramdisk ... error: you need to load the kernel first. so I need to select one of the installed 6.12.x Kernels. After successfull boot, the first two messages that come up in the journal with priority warning or higher are Feb 24 13:01:18 kernel: Cannot find an available gap in the 32-bit address range Feb 24 13:01:18 kernel: PCI devices with unassigned 32-bit BARs may not work! I'm not sure what these two lines refer to, so no idea if that's in any way related or completely separate. But beyond that, I don't see any anything on any of the servers that I was able to update, that was in the logs before the update, but not afterwards. So sadly, right now I can't really help with what has changed in one of the 6.12.x versions that seems to have been fixed in 6.13. But it would be great if whatever the fix is could be backported to 6.12. -- System Information: Debian Release: trixie/sid APT prefers testing APT policy: (990, 'testing'), (50, 'unstable') Architecture: amd64 (x86_64) Kernel: Linux 6.13-amd64 (SMP w/12 CPU threads; PREEMPT) Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE not set Shell: /bin/sh linked to /usr/bin/dash Init: systemd (via /run/systemd/system) LSM: AppArmor: enabled Versions of packages linux-image-amd64 depends on: ii linux-image-6.12.16-amd64 6.12.16-1 linux-image-amd64 recommends no packages. linux-image-amd64 suggests no packages. -- no debconf information
[toc] | [next] | [standalone]
| From | Salvatore Bonaccorso <carnil@debian.org> |
|---|---|
| Date | 2025-04-04 15:20 +0200 |
| Message-ID | <KxP7I-b1YP-9@gated-at.bofh.it> |
| In reply to | #86118 |
Hi, On Mon, Feb 24, 2025 at 01:18:50PM +0100, Richard wrote: > Package: linux-image-amd64 > Version: 6.12.16-1 > Severity: normal > > Dear Maintainer, > > I'm not 100 % sure this is caused by the Kernel, but I'm convinced like 99 %. For about two weeks I have issues with the networking on several of my servers, mainly with mounting NFS shares. Mounting them works only on the servers that are on Debian Stable, but the ones on Testing, and thus running 6.12.x, have issues. I've now tried out to switch every server running Testing and failing to mount their NFS share to the 6.13.4 Kernel found in experimental, and for now it looks like this has fixed the issue. Though I couldn't update it on one server running as a VM on a Xen hypervisor. When trying to boot 6.13.4 on it, I can see in "xl console" this message: > > > Loading Linux 6.13-amd64 ... > error: not xen image. > Loading initial ramdisk ... > error: you need to load the kernel first. > > > so I need to select one of the installed 6.12.x Kernels. After successfull boot, the first two messages that come up in the journal with priority warning or higher are > > > Feb 24 13:01:18 kernel: Cannot find an available gap in the 32-bit address range > Feb 24 13:01:18 kernel: PCI devices with unassigned 32-bit BARs may not work! > > > I'm not sure what these two lines refer to, so no idea if that's in > any way related or completely separate. But beyond that, I don't see > any anything on any of the servers that I was able to update, that > was in the logs before the update, but not afterwards. So sadly, > right now I can't really help with what has changed in one of the > 6.12.x versions that seems to have been fixed in 6.13. But it would > be great if whatever the fix is could be backported to 6.12. Can you please test the most recent 6.12.y kernel available in Debian? (6.12.21-1), is the issue resolved there? If not, can you bisect the changes in upstream to see which commit fixes the issue? Regards, Salvatore
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.kernel
csiph-web